WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Empty per-page-gallery after upgrade to 0.9.0 (11 posts)

  1. hostage-nl
    Member
    Posted 1 year ago #

    Hi,

    After upgrading to the newest version, when i open the upload/insert link while editing a page, the gallery tab remains completely empty after uploading multiple images. It does say "Gallery(2)" but no images appear.

    This problem doesn't appear in version 0.8.10.

    thanks
    martijn.

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    It should be linked to this: http://wordpress.org/support/topic/no-posts-found-no-pages-found-with-polylang-09

    Can you try the development version?
    http://downloads.wordpress.org/plugin/polylang.zip

    And then play at least one time with the new language filter in the admin bar.

  3. hostage-nl
    Member
    Posted 1 year ago #

    Thanks for your fast reply!

    The development version fixed it a bit...

    On existing pages, the gallery remains broken

    When i create a new page with a new gallery, it works

    When i add new images to the gallery of an existing page, it doesn't fix it...

    I did switch the language filter in all possible ways...

    thanks
    Martijn.

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    So it means that up to now, you did not have multilingual captions and descriptions for your media. Maybe it is better to go on like this by setting:

    define('PLL_MEDIA_SUPPORT', false);

    in wp-config.php
    (More info at the end of the documentation)

  5. Gonçalo Peres
    Member
    Posted 1 year ago #

    Greetings Chouby.

    I noticed this problem too, after upgrading to 0.9.1.
    Tried the latest development version (0.9.13), but the problem persists:

    When clicking the add media button (Upload/Insert) inside "Edit Post/Page" no images are shown. If I go to the "Media" section, edit a image and just click "Update Media", the default language gets set. Then if I go to "Edit Post" and click the add media button, that image is the only one that appears (if the language of the media matches the language of the post).

    I understand where you are going, making the media "language aware". But there should be an option in the "add media modal window", allowing to show all media/images, regardless of the language they are set.

    Otherwise, people with existing sites, will have no way of adding media to their posts.

    Also, there could be a feature/button in the plugin settings page which when clicked would set the language for all media according to this:

    • if the media is attached to a particular post, set it to the same language
    • if the media is unattached, set it to the default language

    But the option for showing all media regardless of language should also exist, because we may want to use the same image for posts in different languages.

    Right now I have no time, but I may try to look at it, next week.

    Regards.

  6. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    • if the media is attached to a particular post, set it to the same language
    • if the media is unattached, set it to the default language>

    In fact, it works like this...

    When you upload a new media from the library, its language default to the user preferred language (ie the language selected in the admin toolbar on top, which defaults to default language if "all languages" is selected).

    When you upload a new media from a post, its language defaults to post language. There is however an issue. It does work only if the post is saved after switching the language. I will see if I can improve this in the future.

    I already answered to the request to see the media with no languages together with the media in one language: http://wordpress.org/support/topic/plugin-polylang-images-and-most-recent-version-of-polylang?replies=8#post-3176376

  7. Gonçalo Peres
    Member
    Posted 1 year ago #

    Yes, I know it does. I mentioned this feature so people upgrading to this new version could have all their already existing images default to some language.
    What's happening now is: you upgrade and then go to a post and try to insert a existing image, but the list is empty.

    But when you get the issue solved (see the media with no languages together with the media in one language), that won't be a problem.
    And yes, i know i can set PLL_MEDIA_SUPPORT to false.

    :)

    Tnak you Chouby and keep it up :)

  8. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    When you upload a new media from a post, its language defaults to post language. There is however an issue. It does work only if the post is saved after switching the language. I will see if I can improve this in the future.

    should now be solved in the latest development version.

    PLL_MEDIA_SUPPORT will be transferred to ui in the next major release to make things easier.

    But when you get the issue solved (see the media with no languages together with the media in one language), that won't be a problem.
    And yes, i know i can set PLL_MEDIA_SUPPORT to false.

    I find it not easy to make a query which return posts with no value in a given taxonomy + posts which have a given value in that taxonomy. I am not sure that what I made in http://pastebin.com/bsEM0P2R is very efficient...

  9. hostage-nl
    Member
    Posted 1 year ago #

    I never told you that you solved my problem :-)

    I did not set the PLL_MEDIA_SUPPORT flag to false, i just entered the media library and made sure that all images have the language set correctly.

    Still thinking that this issue should be solved more elegantly though, not by a flag that disables a (new?) feature ;-)

    thanks anyway for the help and this great plug-in!

  10. hostage-nl
    Member
    Posted 1 year ago #

    btw i'm on 0.9.2 now, flawless update, great :-)

  11. Benji007
    Member
    Posted 1 year ago #

    on a side note, LOVE this plugin!!
    I searched so long for a good language plugin, this is it!! :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic