WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Crash in default (28 posts)

  1. The Crazy Travel
    Member
    Posted 2 years ago #

    Take a look:
    http://miesquinica.com/

    I didn't change anything since last time and now, when you open the main url, it appears all languages together. :S

    http://wordpress.org/extend/plugins/polylang/

  2. The Crazy Travel
    Member
    Posted 2 years ago #

    I have updated to the last version and the problem continue there. :(

  3. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    Yes I see that your homepage is messed. Did you uncheck "Hide URL language information for default language" ?

    I think to that because http://miesquinica.com/es/ doesn't send me to a 404 Error but does send all Spanish posts as it would do if you don't hide the language in url. The same with http://miesquinica.com/es/2011/ which works and should not.

  4. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    I made tests at home. It seems that it is your permalink structure for which you use /%postname%/ which breaks the things. Could you try something else to confirm ?

  5. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    With the tests I am currently doing with your custom permalink structure WordPress 3.2.1 is broken but not WordPress 3.3 beta 3 !

    I know that things have changed in the core since starting from 3.3, the /%postname%/ permalink structure appeared in the options proposed in the permalink settings panel whereas it was not recommended to use it in 3.2.1 an older versions due to performance reasons.

  6. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    Well it seems that it has nothing to do with the WordPress version...

    When debugging my code, I discovered that WordPress was sending wrong informations about the homepage when setting the permalink structure to /%postname%/. In fact it was telling that it was a page but did no set it. So to know if there was a conflict with a specific page, I put all the pages to trash, restored it one by one, relinked translated pages (as putting pages to trash intentionally breaks the link) and now it works ! And to be honest, I don't understand why. And worst I am no more able to reproduce the bug !

    However, as my first idea was a conflict with another plugin, I made tests with All in One SEO Pack. And obviously there are conflicts between the two plugins :(

  7. The Crazy Travel
    Member
    Posted 2 years ago #

    So... problem is conflict with All in One Seo? not the permalink? Has no sense that before it worked and now it doesn't :S

    I installed 2-3 related post plugins, try them, I didn't like any of them and I deleted them. It's the only thing I did in the time between working and no working. :S

  8. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    All in One SEO breaks other things but not this. It's really the /%postname%/ permalink structure which allowed me to reproduce the bug. In fact, WordPress generated bad rewriting rules in this case. But now I can't reproduce the bug anymore.

    It's true that I activate and de-activate a lot of plugins on my test site to test conflicts. Could you tell me what are the plugins you tested ? I will look at them.

  9. The Crazy Travel
    Member
    Posted 2 years ago #

    Better Related Posts
    Yet Another Related Posts Plugin

    I think another one more but I don't remeber which one.

    I have deleted All in One SEO and doesn't help, you are right, it's not that... but I was reading that another translate plugins have problems with this one, and because of that I checked.

    In the end it was going to be easier to install one new blog for every language, lol

  10. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    Yes Polylang is still young and first users are likely to experience problems...

    Did you try another permalink structure ?

  11. The Crazy Travel
    Member
    Posted 2 years ago #

    No, I didn't, but I if try change it I will have problems with all posts? any other good permalink structure you want me to try?

  12. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    The permalink of all posts will be modified. If you care about SEO, it is not good. However you can make a short test and come back to the current one. Can you try the "month and name" ?

  13. The Crazy Travel
    Member
    Posted 2 years ago #

    Done it.

  14. The Crazy Travel
    Member
    Posted 2 years ago #

    Continue with problems, different ones... but problems. Sometimes before when I was in the main page and when I click to go to English it was going to one Spanish post.

    Now it did the same, it opened:
    http://miesquinica.com/2011/10/pensando-en-asia-desde-los-pirineos/

  15. The Crazy Travel
    Member
    Posted 2 years ago #

    I got it working. That bug didn't happen again, but you can navigate around the website for checking if it happens again.

    For having it working I have turn it on the option of detect browser language and remove /language/. But I have disabled the other two, the last one I think was giving me problems.

  16. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    This is exactly the kind of problems I had when activating all in one SEO.

    I wonder. Could you try to come back to your initial permalink structure and then delete the cache in WP Super Cache ?

  17. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    I was answering to the previous post.

  18. The Crazy Travel
    Member
    Posted 2 years ago #

    Do you want me to try that again for checking what happens? when you have finished checking how it's now let me know and I got back to the original permalinks. ;-)

  19. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    Yes you can try it now.

  20. The Crazy Travel
    Member
    Posted 2 years ago #

    Done it, let see what happens xD

  21. The Crazy Travel
    Member
    Posted 2 years ago #

    Back to the other problem, all the entries, categories and all the staff in the main domain, when it should have redirect to the /es.

  22. The Crazy Travel
    Member
    Posted 2 years ago #

    Any idea? If not I could leave it in "month and name"... I don't like that much but...

  23. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    I see. Did you keep the option "Hide URL language information for default language" disabled ?

  24. The Crazy Travel
    Member
    Posted 2 years ago #

    That's disabled, if I activate it I have that bug that we talked about (with the other permalinks), when clicking in English from the main page get me to one Spanish post.

  25. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    OK. So, for the moment I have no other alternative to propose than changing your permalink structure. I don't know what generate this bad url rewriting.

  26. The Crazy Travel
    Member
    Posted 2 years ago #

    Ok, back to the alternative permalink structure.

    Let's close this, plugin works but not with that permalink structure (but now).

    I will have time to optimize the blog until this Monday evening, after that I will be on the road again and I will not be able to check things, so if you want to check anything else I am your subject. ;-)

    Thanks.

  27. Chouby
    Member
    Plugin Author

    Posted 2 years ago #

    OK thank you. I will go to bed for now ;-)

  28. The Crazy Travel
    Member
    Posted 2 years ago #

    Good night. ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags