WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] All Posts, Categories, Tags not showing in dashboard (9 posts)

  1. Equilibrium3
    Member
    Posted 1 year ago #

    Hi

    Great software. I have a issue though.
    Firstly my site is installed in English. There was no languages directory in wp-content or the current theme I am using which is Wappos.
    I created the languages directory in wp-content.
    Polylang downloaded the Bahah indonesian file successfully.
    Then since I am using the /LANG-CODE/ permalink structure I downloaded english as well.
    Its set up so English is default language and public_html/ redirects to public_html/en/.

    When I enter dashboard none of my posts are showing or tags or categories.
    The dashboard admin url is domain/wp-admin. I tried both domain/en/wp-admin and domain/id/wp-admin and both just gave 404 error!

    When I visit the site on en all my previous posts show and categories as well.
    When I visit id (indonesian) nothing shows but its because I have written nothing for there.

    I want to translate the posts that are already there and add to id but I can't access them.

    Also some aspects of the theme aren't translated like the page not found text. The theme doesn't have a id or en translation file so what do I do?

    Help?

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    You don't need to download English. WordPress is written in English.
    What do you call /LANG-CODE/ permalink structure? How did you setup this?

  3. Equilibrium3
    Member
    Posted 1 year ago #

    The reason I downloaded English is because in the Language settings the first option which is default did not show English!
    I first downloaded Indonesian and then the only language in the default dropdown was Indonesian.
    So I couldn't save the changes I made there as I didn't want that default!

    /LANG-CODE/ refers to the 2nd setting which is URL modifications.
    I selected the second one which is add /en/ to pretty permalinks.

    Initially after I downloaded English (reason above) I selected the add all current posts etc highlighted in red and saved.

    The other settings active are remove /language/ in pretty permalinks and the last one 'allow to synchronise categories etc.' Is checked
    My posts are there and if my default is English I don't understand why they're not showing.

    And also why adding /en/ before /wp-admin/ won't work.

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Maybe I misunderstood 'download'. Polylang does not set any language when you install it, so you need to choose the languages in the Polylang admin panel. For all languages except English, Polylang tries to download the WordPress languages files when they exist. For English, the language is registered but no language file is downloaded as WordPress is already written in English.

    Polylang does not modify the admin urls. The same for login. It does modify only the public side of your site.

    Which version of Polylang are you using?

  5. Equilibrium3
    Member
    Posted 1 year ago #

    0.9.1. Downloaded today :)

  6. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Could you look at which option is selected for 'languages' in the toolbar on top of your admin screen?

  7. Equilibrium3
    Member
    Posted 1 year ago #

    I had a plugin to disable the admin bar.
    I deactivated it and the language dropdown was there.
    Indonesian was selected.

    In case of anyone having this issue in future this is the direct url. http://example.com/wp-admin/edit.php?lang=all

    Thanks.

    And again I say "Great Plugin".
    Its much more than a translator and exactly what I need!

  8. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    For your information, there is still a bug in 0.9.1 and the admin content languages filter may switch in an unexpected way (when you add tags in a post). It can be rather annoying if you hide the admin toolbar. The development version (0.9.1.2) should correct this. http://downloads.wordpress.org/plugin/polylang.zip

  9. Equilibrium3
    Member
    Posted 1 year ago #

    Thanks :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic