WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
"All languages" option for posts and pages (39 posts)

  1. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    It works for me. Could you just try to resave your permalinks settings?

  2. jussi.r
    Member
    Posted 1 year ago #

    I resaved "/%category%/%postname%/" but still getting "page not found". If I select a language for the post, it works.

    I'm using polylang 0.9.2 and polaylang displays all posts 0.2. I downloaded polylang from this address where the development version was before: http://downloads.wordpress.org/plugin/polylang.zip

  3. mcdermottmb
    Member
    Posted 1 year ago #

    Should this code work with 0.9.6 running on WP MU 3.4.2 I created a folder named display-all-languages in my plugin directory and placed the all languages code in a php file display-all-languages.php activated it in the plugin manager and I can find no additional option in my language selector. Am I doing something wrong or is the code incompatible?

    thanks

  4. spicewiesel
    Member
    Posted 1 year ago #

    I tried to set this up with polylang 0.9,8 yesterday, but without success. We need to display all languages by default and to filter the specific language, if an user selects one. Is that possible?

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    @spicewiesel It has been a while that I did not work on this and so nothing improved. Even if it would work, it does not cover your request. The goal here was to display some posts in all languages (independantly of any user choice).

  6. tntrush
    Member
    Posted 1 year ago #

    Hallo,

    My question could be very noobish, but how could I use the code from http://pastebin.com/bsEM0P2R?

    E.g. What will the filename containing the code be and in which directory should be saved?

    Kind regards,
    tntrush

  7. manngo
    Member
    Posted 1 year ago #

    Hi,

    I have strange way the opposite issue. I have 2 languages: English as default and Chinese as secondary. All posts are translated to both languages. However when I display the archive I have this:
    for English: All posts are displayed even the Chinese ones.
    for Chinese: only Chinese posts are displayed.
    See it here: http://www.theinvestorclub.org/2013/03/
    Than change to Chinese.

    Settings:
    Default: English
    When the front page is visited, set the language according to the browser preference -> Yes
    The language is set from content. Posts, pages, categories and tags urls are not modified.
    Remove /language/ in pretty permalinks.
    Hide URL language information for default language -> Yes
    Activate languages and translations for media -> Yes
    Synchronization: Everything enabled.

    Further test:
    I changed the setting:
    "Hide URL language information for default language"
    to NO. Than it shows only the English posts in English and only the Chinese ones in Chinese. There is something about this setting, it doesn't seem to work in all parts of the site.

  8. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    @tntrush
    copy paste the code in a file called "something.php", upload this file in your plugins directory and finally activate the newly created plugin. As mentionned above, the code was quite experimental and buggy and I did not work on it for several months.

    @manngo
    You should have opened a new topic for this. Could you try with the development version?
    http://downloads.wordpress.org/plugin/polylang.zip

  9. i haven't understand if this plugin http://pastebin.com/bsEM0P2R allows to set a post for all language.
    i have downlaod and activated on my site but in the language dropdown i see only the language allowed for the site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags