WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
"All languages" option for posts and pages (39 posts)

  1. jussi.r
    Member
    Posted 1 year ago #

    Hey,

    In our webpage we have the news (posts) only in english. If we want them to be visible at all languages we don't know any other way to do this than creating a copy of the posts for all language versions and its stupid.

    Is there any other way or could it be possible to add in the future a option "Post's language: All languages"?

    Thanks for this great plugin!

    http://wordpress.org/extend/plugins/polylang/

  2. jussi.r
    Member
    Posted 1 year ago #

    Added "polylang" tag.

  3. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Maybe you can try this. http://pastebin.com/bsEM0P2R and give me your feedback.

  4. jussi.r
    Member
    Posted 1 year ago #

    I have problem adding my "No language" -post to a category. When I select the category in post editor and press "Update" the category goes unselected. Its not even in the "Uncategorized" -category.

    At our website every post has to be in a category.

    Thanks for the reply!

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Well, I made some new tests... There is still a lot of work to do.

  6. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Still experimental, but here are already some bug corrections (including the one you mentioned).
    you need the development version of Polylang (v0.9.0.5): http://downloads.wordpress.org/plugin/polylang.zip

    and the updated version of "Polylang displays all posts" (0.1.1):
    http://pastebin.com/bsEM0P2R

  7. jussi.r
    Member
    Posted 1 year ago #

    I updated both of those and now i have the "no posts, no pages" problem again at admin panel.

  8. jussi.r
    Member
    Posted 1 year ago #

    But i removed the filter frmo admim-filters so I can test more.

    I made a post without language. It doesnt show up for other than default language in frontend at the category (with twentyten theme) and when trying to open the post it stays at the same page.

    Now it goes to the category I want though.

  9. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Which option is selected in the "languages" menu included in the admin bar?

  10. jussi.r
    Member
    Posted 1 year ago #

    "No language"

  11. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Normally, you can set "No language" for a post, but this option should not exist in the admin bar. You should have "Show all languages" as first option and then the list of all the languages you have defined.

  12. jussi.r
    Member
    Posted 1 year ago #

    So it is a bug?

  13. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Very strange indeed as I cannot imagine how it can occur except if a language called "No language" has been created.

    What happens if you select "Show all languages"? Or an existing language?

  14. jussi.r
    Member
    Posted 1 year ago #

    I don't see option "Show all languages" at post editor. I willl post a screenshot tomorrow if needed.

  15. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    It seems that we don't speak of the same thing.
    I refer to the languages menu added by Polylang in the admin toolbar http://codex.wordpress.org/Administration_Panels#Toolbar (which should be at the right of "+new")

  16. jussi.r
    Member
    Posted 1 year ago #

    Oh so we've been talking about different things all the time. I've been talking about the "Page's language:" at post editor. I'd like to have a way for a single post with one language to be seen at all languages in frontend.

    For example I make a post with English, but I want it is shown when any of my languages is selected by language switcher at frontend.
    Only way to do this is to make a post for all the languages with the same english content and thats not nice.

    I thought "No language" option was meant for this purpose because it appears at page/post editor when I activate your "Polylang displays all posts" plugin.

  17. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    In fact, we are talking of two different things:

    1. The "no posts, no pages" issue which is a bug of the languages filter I added in the admin bar (in Polylang v0.9). It should be corrected with the development version of Polylang. You need to choose an option - either "all languages" or any language - to display your posts again. Is this problem solved?

    2. Your request to display posts in all languages which is the goal of the "Polylang displays all posts" add-on. If you select "No language" for a post, it should be visible whatever the language chosen on frontend. This is however still experimental. And you first feedback already helped me correcting some bugs.

  18. jussi.r
    Member
    Posted 1 year ago #

    1. This problem is solved. Thanks. =)

    2. If I select "No language":
    "I made a post without language. It doesnt show up for other than default language in frontend at the post category (with twentyten theme) and when trying to open the post it stays at the same page. Also at backend when pressing "View post" at post editor it doesn't go anywhere."

  19. jussi.r
    Member
    Posted 1 year ago #

    So the link to the post is empty i think, because the behaviour was like clicking this would be:
    View post
    <a href="">View post</a>

  20. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I don't have this issue. To help me reproduce, could you tell me if you use pretty permalinks and what are your Polylang settings in Languages->Settings?

  21. jussi.r
    Member
    Posted 1 year ago #

    Permalinks: /%category%/%postname%/

    Here is a list of all checked options at Settings tab (everything else is unchecked):

    • Default language: English
    • Detect browser language
    • The language code, for example /en/, is added to all urls when using pretty permalinks.
    • Remove /language/ in pretty permalinks.
    • When using static front page, redirect the language page to the front page in the right language
    • Allow to synchronize categories, tags, featured image and other metas between translations of a post or page
  22. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I made tests with your configuration and it's true that almost nothing works... I will go on working on the add-on and come back to you with an upgrade. Thanks for your tests !

  23. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I am coming back on this issue. Which canonical url do you expect for a post without language, when you choose to add the language code to all urls?

  24. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Current development version of Polylang (v0.9.1.5) and "Polylang displays all posts" (v0.2) should improve the situation.

    I chose not to add any language information in the url of posts without language, even when "add the language code to all urls" is checked.

  25. Mr.ayed abduallh
    Member
    Posted 1 year ago #

    No language?

  26. jussi.r
    Member
    Posted 1 year ago #

    Thanks. Where I can get the new "polylang displays all posts"?

  27. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Always on the same link: http://pastebin.com/bsEM0P2R

  28. jussi.r
    Member
    Posted 1 year ago #

    It improved a little. Now the link to the post isn't empty but I get 404 page of my theme when I try to visit a post with "No language" selected.

  29. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    How is the url which is 404? I expect it to be:
    yoursite.com/your_category/your_post_with_no_language
    just the same as if Polylang were not activated

  30. jussi.r
    Member
    Posted 1 year ago #

    Yes, the URL is like that.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags