WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: PollDaddy Polls & Ratings] PollDaddy Error at Version 1.8.1: triggered a fatal error (8 posts)

  1. a1000car
    Member
    Posted 4 years ago #

    I'm having this, after trying to activate: Plugin could not be activated because it triggered a fatal error.

    http://wordpress.org/extend/plugins/polldaddy/

  2. Eoin Gallagher
    Member
    Posted 4 years ago #

    Hi, I have added an update. Can you try the latest version and see if you have any trouble?

  3. swaroopch
    Member
    Posted 4 years ago #

    I'm facing the same problem with WP 2.9.2 and PollDaddy 1.8.2 :(

  4. swaroopch
    Member
    Posted 4 years ago #

    It seems like I can activate only one of "PollDaddy" or "PollDaddy Polls" plugins, not both at the same time - which is the installation howto, as far as I remember.

  5. Eoin Gallagher
    Member
    Posted 4 years ago #

    Hi, I cannot replicate this error. There is only one plugin, Polldaddy Polls and Ratings. Is there anything else specific to your blog that may be causing this?

  6. movielakay
    Member
    Posted 4 years ago #

    Same here. Polldaddy is not working - It was working fine until I tried to upgrade to 1.8.2. Now none of my polls is working :-(

    "Plugin could not be activated because it triggered a fatal error.

    Fatal error: Class pd_top_rated: Cannot inherit from undefined class wp_widget in .../html/wp-content/plugins/polldaddy/polldaddy-org.php on line 515"

    I'm using WordPress 2.7

  7. movielakay
    Member
    Posted 4 years ago #

    I downgraded to version 1.7.5 and everything is working now. I guess version 1.8.2 didn't work because of that new Polldaddy Rating add-on. I already had WP-PostRatings installed. So WP-PostRatings and Polldaddy rating are not compatible.

  8. Eoin Gallagher
    Member
    Posted 4 years ago #

    I figured out what was causing this error, I was using the WP_Widget class which is not supported on older installations. I have added a fix to 1.8.3, feel free to try it out and get back to me if you are still having bother.

Topic Closed

This topic has been closed to new replies.

About this Topic