WordPress.org

Ready to get started?Download WordPress

Forums

podPress
[resolved] Server returned HTTP Error 403: Forbidden (42 posts)

  1. toptm
    Member
    Posted 3 years ago #

    Tim,

    Please help. I received the 403 Error when I tried to validate my feed, http://theonlypodcast.com/?feed=podcast. But when I input the feed listed in the Feed Podcast section of your plugin, http://theonlypodcast.com/feed/podcast, the feed validates fine, with only minor errors on line 206.

    I have done everything you suggested in a previous post; re-saved my permalink structure, made sure the slug name remained "podcast", and made sure that I the feed is active. Is there anything else I can do, or am I missing something completely?

    Thanks,
    Andrew

  2. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Andrew,

    I'm sorry. I have no concrete idea why the URL http://theonlypodcast.com/?feed=podcast does not work. But I have noticed that this problem seems to be limited to the additional Feeds of podPress. For instance the redirection of the default RSS Feed URL http://theonlypodcast.com/?feed=rss2 works.
    It seems to be more an issue of these redirections. I have of course installed podPress in my blog too and it is no problem in this blog to use both URL schemes while a non-default Permalink scheme is active.

    Please, try to set the Permalink scheme back to the default scheme for a moment and control whether the URL http://theonlypodcast.com/?feed=podcast works with this settings.
    Does it work with the default Permalink scheme?

    (You can test the URL in your browser. But it might be necessary to clear the cache of the browser to see a difference before reloading the "page".)

    I need to research a little bit before I can try to help you more.

    Regards,
    Tim

  3. toptm
    Member
    Posted 3 years ago #

    Tim,

    After setting the permalinks to default, the feed validates and works as a URL in my browser. It only works in the default scheme though, as I tried using the other permalink setting, aside from custom, and came up with the previous results.

    Obviously I am keeping the permalink structure to default for now, but I still wonder why this would happen all of the sudden, as I've been using your plugin for months.

    Thanks for the help,
    Andrew

  4. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Are you able to tell since which podPress version this problem has occurred?

  5. toptm
    Member
    Posted 3 years ago #

    It started with 8.8.8.4. I had no problems when I had 8.8.6.3 installed.

  6. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    I have thought about this problem a lot and I know two further blogs besides my own blog where podPress 8.8.8.x is running and the /?feed=podcast and the /feed/podcast Feed is working at the same time.
    That is why I think that it might be a problem on your server or blog. Are you able to rule out that no other plugin interferes with your Permalinks or rewrite rules?
    I have also read the first post in this thread again and I have noticed the last sub section:

    I have done everything you suggested in a previous post; re-saved my permalink structure, made sure the slug name remained "podcast", and made sure that I the feed is active.

    The order of the action is important.

    Maybe you should try it this way:
    * controlling/changing the Slug Name
    * check the Active Feed checkbox
    * saving the podPress Feed settings
    (after this step the /?feed=podcast Feed should work)
    * saving the Permalink settings (if you are using a non-default Permalink scheme)
    (after this step the /feed/podcast Feed should also work)

    If you have done these action in this order then maybe try it again while the other plugins are deactivated temporarily.

    You could also try to find out whether the podPress Feeds like the "podcast" Feed has been added correctly to the rewrite rules of your blog. The plugin AskApache RewriteRules Viewer can show you all the rewrite rules. At the options page of this plugin are several boxes one of them with the name "feeds Supported default feeds." (the second box with this name) should contain a section which looks like this

    [root_rewrite] => Array
    (
        [feed/(feed|rdf|rss|rss2|atom|podcast|enhancedpodcast|torrent|premium|playlist.xspf)/?$] => index.php?&feed=$1
        [(feed|rdf|rss|rss2|atom|podcast|enhancedpodcast|torrent|premium|playlist.xspf)/?$] => index.php?&feed=$1
        [page/?([0-9]{1,})/?$] => index.php?&paged=$1
        [comment-page-([0-9]{1,})/?$] => index.php?&page_id=2&cpage=$1
    )

    As you can see this list contains and should contain all slug names of the additional feeds. Please, control whether the podcast Feed is in this list when the non-default Permalink scheme is active.
    The slug name should also be in first box with this name. That other contains only a simple list with all the slug names of the feeds. The slug name of the of the "podcast" Feed should be in that list as long as podPress and this Feed is active regardless of the Permalink scheme.

    Control also the mod_rewrite_rules box. While you are using a non-default Permalink scheme e.g. Day and Name, the content of this box should contain

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    While you are using the default Permalinks, this box is probably empty.
    If it is not empty in this situation, please post here what is in there.

  7. toptm
    Member
    Posted 3 years ago #

    I followed all of your instructions, to no avail. I even turned off all of my other plugins, besides yours and the AA RewriteRules, to see if one of them was interfering. I still come up with the same results: if the permalink structure is default, "?feed=podcast" works and "/feed/podcast/" comes up with a 404 Error. When a non default permalink is active, "feed=podcast" comes up with the 403 Error and "feed/podcast" works fine.
    There is only one thing I noticed when looking at the rewrite rules:

    [root_rewrite] => Array
    (   
    
    [feed/(feed|rdf|rss|rss2|atom|podcast|enhancedpodcast|torrent|premium|playlist.xspf)/?$] => index.php?&feed=$1
    [(feed|rdf|rss|rss2|atom|podcast|enhancedpodcast|torrent|premium|playlist.xspf)/?$] => index.php?&feed=$1
    [page/?([0-9]{1,})/?$] => index.php?&paged=$1
    
    )

    The only line missing from mine and the example you gave me is the line containing "[comment-page...]". other than that, your example and mine match, whether or not the default permalink is active.

    For further proof, this is what my mod_rewrite_rules look like

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Do you think I should take this up with my domain host?

  8. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Okay. The other plugins are not involved and the rewrite rules are looking to me.
    I'm still not able to reproduce the problem.
    Would you do a further test?

    If the problem is not limited to podPress then it will probably happen when you add a further Feed with a different plugin.

    The following code snippet is a simple plugin which adds a RSS Feed to a blog. This Feed with the slug name "testfeed" will have the same content as the main entries RSS Feed.

    [Code moderated as per the Forum Rules. Please use the pastebin]

    Create a new file with a text editor and name it e.g. testfeed.php.
    Open the file with the text editor and copy and paste that code into the file.
    Upload this file to your blog and store it for instance in the folder /wp-content/plugins/testfeed/.
    Afterwards head to the plugins page of your blog and activate that plugin ("A Test Feed").
    This will create the Feed /?feed=testfeed (and /feed/testfeed).
    Choose a non-default Permalink scheme and save the Permalink settings.

    Does /?feed=testfeed work?
    Does /feed/testfeed work?

    If /?feed=testfeed is not working while the non-default Permalink scheme is active (and /feed/testfeed is working), deactivate a part of the this plugin by inserting comment characters in one line of the code. You may use the plugin editor of the blog for this action.

    Modify the code like this:
    old:

    function testfeed_do_feed($withcomments) {
    	testfeed_modify_certain_feedelements();
    	do_feed_rss2($withcomments);
    }

    new:

    function testfeed_do_feed($withcomments) {
    	//testfeed_modify_certain_feedelements();
    	do_feed_rss2($withcomments);
    }

    Or you modify the file with the text editor on your computer and upload the file again.

    If this is also not working then you should try this code:
    [Code moderated as per the Forum Rules. Please use the pastebin]

    (This is comparable to the way the podPress versions before version 8.8.9 have added the Feeds.)

    If the /?feed=testfeed URL does not work while /feed/testfeed works (while a non-default Permalink scheme is active) then it is probably a problem which is not limited to the podPress plugin.

    Please, control also the /?feed=rss2 and the /?feed=atom Feed while the non-default Permalink scheme is active.
    Is the RSS and the ATOM Feed working?

    If the ATOM Feed or the /?feed=testfeed Feed is not working then turn off the podPress plugin temporarily and test the ATOM Feed and /?feed=testfeed again (while the non-default Permalink scheme is active).

    This may not bring the solution but it will definitely help to narrow down the number of possible sources of the problem.

  9. toptm
    Member
    Posted 3 years ago #

    I can't activate your simple plugin. I get a fatal error when I try to activate it. Am I doing something wrong? I feel sorry for taking up so much of your time.

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_FUNCTION, expecting T_STRING or T_VARIABLE or '$' in /home/content/41/6826341/html/wp-content/plugins/testfeed/testfeed.php on line 15
  10. raymer
    Member
    Posted 3 years ago #

    @toptm - I'm jumping in here but not sure if I can actually help. I noticed that in your OP you said you were getting a 403 error not a 404. That may indicate a permissions problem?
    Scanning through the thread I gather that you are running wordpress on a shared-hosting server with Apache and some kind of *Nix OS - can you confirm?
    Also, can you confirm that you are running the latest dev version of podpress? If not, what exact version?

    Now for my wild speculation. Do you have an actual physical dir named podcast? Or do you have a wordpress category named poscast? Or a tag named podcast?

    @ntm Tim, is there any possiblity that having a category named podcast could interfere with the default permalink scheme? How about a dir named podcast?

    FWIW, I am using podpress with no problems on a shared host but I have seen some people have problems with permissions. Can't understand why you would get a permission denied (403) error. Maybe you could try (temporariy) setting your podpress dir premissions to 777?

    -Ray

  11. toptm
    Member
    Posted 3 years ago #

    Ray,

    Yes, I was getting a 403 when trying to validate and use my original podcast feed, http://theonlypodcast.com/?feed=podcast (iTunes was also giving me an error when trying to download shows). Trouble is, the feed theonlypodcast.com/feed/podcast validated and worked fine, which Tim has told me before(in another post) should not be the case. According to him "/?feed=podcast" an "/feed/podcast" are essentially the same thing and should not be behaving this way.

    I'm running wordpress on a GoDaddy server and only added Apache after Tim's suggestion to look at my rewrite array. I don't know what a *Nix operating system is; I've been learning most of this on-the-fly.

    I constantly update all of my plugins, whenever I get an alert that one is available. Just to make sure, I went back and checked, and I am running 8.8.9.

    As for your speculation, I do have a category named podcasts, but it never caused any problem, at least not with v8.8.6.3 . Do you think I should remove it anyway?

    -Andrew

  12. raymer
    Member
    Posted 3 years ago #

    If you are on GoDaddy I think you are running Linux (a flavor of Unix = *nix) or possibly Windows. You are also probably installing everything from some kind of control panel interface, right? I'm not sure what you mean when you say you "added Apache after Tim's suggestion to look at your rewrite array." Can you explain how you added Apache?

    Also, can you explain how you installed wordpress (and are you running 3.0.4)? Did you install from the GoDaddy control panel or FTP the files somehow? And how did you install the podpress plugin? From inside the admin page of your wordpress install? Or did you ftp it manually? Can you figure out how to see the permissions on the dirs from your control panel or ftp client? do the permissions for the podpress dir look different from your other plugins?

    One thing you could try it deleting the entire podpress dir and then reinstalling it. Another thing you could try is to revert to 8.8.6.3 and see if the problem disappears. You can checkout 8.8.6.3 with an svn client (like tortoiseSVN for windows). I don't think GoDaddy has svn installed on their shared hosting servers so you'll have to check it out onto your local machine and then ftp it up to your GoDaddy webhost. If you run Linux at home you can simply run this command from the shell prompt to download 8.8.6.3 svn co . http://plugins.svn.wordpress.org/podpress/tags/8.8.6.3/

    My best guess is that either the permissions got messed up on a file or a file is corrupted somehow. A clean install of podpress would be the first thing to try. Also be sure to mention if you see *any* error messages when deactivating and reactivating the plugin or elswhere.

    -Ray

  13. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Plugin could not be activated because it triggered a fatal error.

    Which version of the plugin caused this error? The last one?
    Anyway, now it is hard to say what in line 15 was. I have put the code of plugins into files and uploaded it. You can download the plugins: http://undeuxoutrois.de/downloads/testfeed.zip
    Please, put the folder and the two files into your plugin folder (for instance /wp-content/plugins/).
    At your plugins page you will see two new plugins "A Test Feed - I" and "A Test Feed - II". The first one will add a Feed with the slug name "testfeed1" and the second one the "testfeed" Feed. The difference between both is that "testfeed1" has a customized Feed title and description.

    Please, try this before you start making podPress rollbacks.
    (But when start to do that, you could download an older version podPress also here: http://wordpress.org/extend/plugins/podpress/download/)
    You could also try to change the slug name of the "podcast" Feed for a test. This could maybe rule out problems which could be causes by name similarities with folders or categories.

    @ntm Tim, is there any possiblity that having a category named podcast could interfere with the default permalink scheme?

    The only problem that I know is the case when you have a category with the name "podcast" and this category is a sub category of another category. In such a configuration you would get the category Feed instead of the category page when you would call that page and while a non-default Permalink scheme is active.
    http://undeuxoutrois.de/wp/category/allgemeines/podcast/ is the URL of the WP core category list widget to the category page but it opens the category feed (which would usually be http://undeuxoutrois.de/wp/category/allgemeines/podcast/feed or http://undeuxoutrois.de/wp/category/podcast/feed).
    But this special problem has most likely nothing to do with original problem in Andrews blog where the original URL scheme is not working in one case while the non-default-Permalink-scheme-URL seems to work.

    Try the testfeed plugin and if /?feed=testfeed1, /feed/testfeed1 and /?feed=testfeed, /feed/testfeed are working, try to change the slug name of the podcast Feed for a test.
    These test will show whether this is a problem which happens because of a name similarity with a folder, category or tag. And since HTTP 403 is a permission error, it might be possible that this is problem caused by a folder with the same name or at least a permission definition which has something to do with the name "podcast".
    BTW: the testfeed will look like this: http://undeuxoutrois.de/wp/?feed=testfeed1 or http://undeuxoutrois.de/wp/feed/testfeed1
    (I'm using the "Day and Name" Permalink scheme.)

    Actually, if http://theonlypodcast.com/?feed=testfeed is not working and http://theonlypodcast.com/feed/testfeed is working (at the same time) while you are using a non-default Permalink scheme then it is almost certain that you should it is no problem of podPress. In this case you should turn off podPress and test both Feeds again to control whether podPress is involved somehow or not.

    @Ray:

    "added Apache after Tim's suggestion to look at your rewrite array." Can you explain how you added Apache?

    Andrew did probably meant the
    AskApache RewriteRules Viewer plugin for WordPress.

  14. toptm
    Member
    Posted 3 years ago #

    Tim,

    With podPress active, all of the URLs for both testfeed and testfeed1 work with a non-default permalink scheme.

    When changed to the default scheme, only "?feed=testfeed" and "?feed=testfeed1" worked.

    The same results occurred when I deactivated podPress.

    I deleted my category "Podcasts", just in case, before performing these tests. It made no diffference, as "?feed=podcast" still only works under a default scheme and "/feed/podcast" only works under a non-default scheme.

    @Ray- Yes, my version of wordpress is running on Linux through the GoDaddy server. I was given the URL to the wp-admin login page as soon as GoDaddy confirmed my purchase; I never had to install wordpress. And, yes, I am running worpress' current version.

    All of my plugins have been installed through my wordpress admin page, along with all of their updates.

    As per Tim asking, I have not downgraded podPress. Yet.

    Also, Tim was correct in saying that I installed the AskApache RewriteRules Viewer plugin, not some other program with Apache as its name. Sorry for the confusion.

    Thanks, both of you,
    Andrew

  15. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Andrew,

    thanks for your tests and this report!

    But with this result I need more help of you.

    Please, change the slug name of the "podcast" Feed. For instance you could name it "testfeed3" (nothing with "podcast" in it). Save the Feed settings. Set the Permalink scheme to a non-default scheme and save this setting too.
    Does "?feed=testfeed3" and "/feed/testfeed3" work?

    It would be great if you would do also a further test:
    Deactivate the new option "Include only posts with podPress attachments in this Feed" (since 8.8.9) of the podcast (or testfeed3) Feed and do not use the category and the file type filter of this Feed. After saving the Feed settings, the Feed should contain all blog posts. All Feed filters of podPress which influence the the number of posts in this Feed will be deactive (like in the testfeed plugin). Make sure that a non-default Permalink scheme is active and control both Feed URLs (e.g. "?feed=testfeed3" and "/feed/testfeed3").
    If both Feed URLs are working in this test, the source of the problems is maybe a problem with the filters of podPress. If both Feed URLs are working then make the counter test and make the hook or cross in that checkbox again and control whether the previous behaviour occurs again.

    If the renamed Feed with no filters on shows the same behaviour as the original podcast Feed then it would be interesting to know whether the .htaccess file in the root folder of your blog (the same folder which contains the wp-config.php file) contains more instructions as these

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    (while the non-default Permalink scheme is active)
    Do you know how-to access to the file of your blog via FTP or SSH? This .htaccess file might be not visible by default. If you can not find it in the view of the root folder, check the view settings of your FTP or SSH client program.

    BTW: I have noticed an interesting thing.Some minutes ago I controlled the default podPress Feeds /?feed=podcast, /?feed=enhancedpodcast and /?feed=torrent of your blog. /?feed=podcast and /?feed=enhancedpodcast are not reachable ("Oops, Page Not Found"). But /?feed=torrent works (although it is a <channel> with no <item>s - no posts in the feed).
    What are the filter settings of the other two Feeds?

    Regards,
    Tim

  16. toptm
    Member
    Posted 3 years ago #

    Tim,

    After changing the slug name, both URLs(testfeed3) will validate. They also show all my blog entries when I un-check the "Include only..." option. After changing the slug name back to "podcast", my initial problem resurfaces.

    My .htaccess file does contain the instructions you have listed.

    My enhancedpodcast feed filters are set to M4A and M4V, while my torrent feed is set to Torrent-P2P. I never touched either of these two feeds for as long as I've had your plugin.

    Thanks,
    Andrew

  17. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Andrew,

    After changing the slug name, both URLs(testfeed3) will validate. They also show all my blog entries when I un-check the "Include only..." option.

    This and the fact that at least one of the podcast Feed URLs is working makes me think that the procedures which add the Feeds and populate them with posts are working correctly in podPress 8.8.9.

    What happens with the /?feed=podcast Feed when you un-check the "Include only..." option? Does it work while the non-default Permalink scheme is active and option is un-checked?

    My .htaccess file does contain the instructions you have listed.

    That is good. But are there also other instructions in this file?

    If un-checking the "Include only..." option of the podcast Feed makes no difference, the problem is probably more a problem of the rewrite rules or other redirection techniques. Maybe it helps if you set back all the Permlink rules by following these steps:
    - deactivate the podcast Feed
    - deactivate podPress
    - set the Permalinks back to the default scheme
    - save the Permalink settings
    - activate podPress
    - activate the podcast Feed again
    Does the /?feed=podcast Feed work again after this step?
    - change the Permalink setting to a non-default scheme
    Does the /feed/podcast and the /?feed=podcast URL work after this step?

    If this is not helping then it might be worth it to make test with 8.8.6.3.

    Regards,
    Tim

  18. toptm
    Member
    Posted 3 years ago #

    Tim,

    Because I'm not sure what I'm exactly looking for in my .htaccess file, I only noticed two other things that look like the instructions you showed before. They are these:

    [.htaccess moderated as per the Forum Rules. Please use the pastebin]

    Does this help? If not, I'm going to have to downgrade to 8.8.6.3 because the other method you described does not work either.

    BTW, after following your orders and testing, I've been setting my permalink structure to a non-default. iTunes has been using the /feed/podcast to access my media.

  19. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    The WP forum filter has filtered what you have found in your .htaccess file before I could see it. Please, use pastebin (or a comparable service: http://en.wikipedia.org/wiki/Comparison_of_pastebins ).

  20. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Or maybe you post only the lines which are different here in this thread (in case these two other things are only two lines. Maybe do not mark them as code).
    I have uploaded podPress 8.8.9.1 beta 1 to the repository. That version includes some control points. If you install this version which is the current Development Version and a little helper plugin which I have written ( http://undeuxoutrois.de/downloads/aaaprintphpnotices_v02.zip ) then it might be possible to determine where and when the problem occurs during a call of the podcast Feed.
    If you can activate the helper plugin which has the title "Print PHP notices" without problems then this plugin will create a log file in its folder with the name wp-content/plugins/aaaprintphpnotices/printphpnotices_log.dat
    After you have activated the helper plugin, click on this feed URL http://theonlypodcast.com/?feed=podcast. After that deactivate the helper plugin again. Because it would log not only the calls to this podcast Feed URL.
    Each call in the log file will start with a line of Number signs (hash tags) # .
    The next line would be "podPress class init - before adding the feeds".
    And if the call is success full then last line would be "podPress_do_dyn_podcast_feed".
    What I would like know what last line is if you call that not working feed URL. Or whether there are log entries in that file after you chave called the Feed.
    If the helper plugin produces an error during the activation then it is most likely beacuse the plugin is not able create the log file in the folder of the plugin.
    If you can not activate the helper plugin, maybe downgrade to 8.8.6.3 for a test.
    But I see no point in doing that for more than a test. As you have said the /feed/podcast URL is registered in the iTunes Store and that URL is working in 8.8.9 and the Feed Button plugin uses always the current Feed URL (scheme). So, it is possible to subscribe to your podcast via both ways.

    If the problem exists also when you downgrade to 8.8.6.3 then you may ask your hosting provider for help.

    Regards,
    Tim

  21. toptm
    Member
    Posted 3 years ago #

    Here is the pastebin of what I tried to post in my last comment, in case it makes any difference.

  22. toptm
    Member
    Posted 3 years ago #

    The plugin helper .dat file only shows this:

    [11.01.2011 - 18:20:07] 'plugin installation'

    even after I click the podcast URL.

    Should I still test with 8.8.6.3, even though I didn't receive an error, or should I just contact my host?

  23. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    No. Do not downgrade. It is one (or two) lines in you .htaccess file.

  24. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    I'm not an .htaccess-expert. But i have put all the lines from the pastebin in to the .htaccess file of my blog and could reproduce the behaviour we could observe in your blog. /?feed=podcast was not working while /feed/podcast was working.

    I have also tried to disable some of the lines to find out which one is responsible. I have not tested all. But if you put a hash tag (#) in front of the lines which include this command RewriteRule ^(.*)$ - [F,L] then the /?feed=podcast URL seems to work regardless of the current Permalink scheme.

    But I would recommend to ask the one who has put all these RewriteRules and RewriteConds into your file for their meaning and necessity. Maybe if you disable these two lines something else will not work right (Although, I think that it seems to be not right, that this line is twice in the file).
    If you switch on a non-default Permalink scheme WordPress writes automatically all the rules which are necessary for the blog into this file and it removes them when you switch back to the default scheme. But WP does obviously not overwrite rules which are already in this file. Sometimes other rules might be necessary. Most of the WordPress rewrite rules in the .htaccess file redirecting requests like http://www.example.com/feed/podcast to the PHP files or scripts which create the feed. If these rules are not in place this request would only work if there would be a folder /feed/podcast/ and would lead to this folder.

    Thank you for your reports!

    Regards,
    Tim

  25. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    (Don't forget to deactivate the "Print PHP Notices" plugin.)

  26. raymer
    Member
    Posted 3 years ago #

    @toptm - I'm glad ntm figured out the issue. Assuming you are looking at the .htaccess file in your web root dir, my guess is that those directives were put in place by GoDaddy. They are probably an attempt to secure your site against bots and spammers.

    RewriteRule ^(.*)$ - [F,L]
    seems to be a rule that forbids *everything* and will return a 403 error for all requests. I would guess that it is followed by lines that allow only "acceptable" requests.

    In any case this is an issue that you should take up with your hosting provider. Contact GoDaddy support and hopefully they can advise you on how to modify your .htacess file.

    -Ray

  27. toptm
    Member
    Posted 3 years ago #

    Tim,

    Finally, we have a solution!

    @Ray

    Thank you for "translating" what RewriteRule ^(.*)$ - [F,L] means.

    @both of you,

    This may all lead back to another plugin I have installed. I had added the Bulletproof Security plugin after receiving a 'possible hack attempt' scare. This plugin affects my .htaccess file and could very well be the reason why that Rewriterule exists.

    Thank you, both of you, very much.

    I'm sorry I caused so much confusion and loss of time.

    -Andrew

  28. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Andrew,
    don't be sorry. It was important to find out whether it is a bug of podPress or something else. If it would have been a podPress bug then I would have tried to fix it.
    Sometimes I don't discover bugs myself or only if someone else reports a problem.
    Thanks again for the report.

    -Tim

  29. toptm
    Member
    Posted 3 years ago #

    Tim,

    This is how the process is going with the Bulletproof Security plugin designer:

    Hi Andrew,
    Forget my previous suggestion. I took a look at podPress and it is doing something other than what I had expected. The question mark (?) in the query string is seen as an illegal external request. I am currently testing podPress and will add it to the Compatibilty Testing page tomorrow in pending status. Thanks.

    Thought I would give you an update.

    -Andrew

  30. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Andrew,

    thanks for the update.
    Is this a discussion in a public forum? Or an email exchange?

    -Tim

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic