WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: podPress] RSS feed: Warning: htmlentities() expects ... (1 post)

  1. ntm
    Member
    Posted 4 years ago #

    There is another problem with podPress 8.8.4.

    If you have problems with the RSS feed while you are using podPress 8.8.4 then try to look out for a error message in the source code of the RSS feed.
    To get a look on this source code open the feed in your web browser (e.g. Firefox, Internet Eplorer, Opera, ... ), right-click on the page and choose the option which is called like "view source code" in the menu at the mouse pointer.
    If you discover warnings like this:

    Warning: htmlentities() expects at most 3 parameters, 4 given in /var/www/mywebsite.com/wp-content/plugins/podpress/podpress_feed_functions.php on line 31

    then the PHP version on the server of your weblog is lower than 5.2.3.
    I have used unfortunately in a patch for podPress 8.8.4 a new parameter for the function htmlentities() which is new in PHP since version 5.2.3.
    This problem will be fixed in podPress 8.8.5. But it may take some days until this version can be released.

    A quick fix is to open the file podpress_feed_function.php with a text editor (not MS Word) (or the plugin editor of WP), go to line 31 and remove a comma and the word FALSE:

    old:
    $result = htmlentities($input, ENT_NOQUOTES, get_bloginfo('charset'), FALSE);

    new:
    $result = htmlentities($input, ENT_NOQUOTES, get_bloginfo('charset'));

    That is it.

    http://wordpress.org/extend/plugins/podpress/

Topic Closed

This topic has been closed to new replies.

About this Topic