WordPress.org

Ready to get started?Download WordPress

Forums

podPress
[Plugin: Podpress] Podcast audio plays automatically when page downloaded (6 posts)

  1. asmarkowitz
    Member
    Posted 3 years ago #

    I'm using Podpress v. 8.8.9.1 for my podcast See It Loud (http://www.musicfilmweb.com/category/see-it-loud/). I have been using this version for several months now. Starting today the podcast audio begins playing whenever the post page comes up. This happens when the page is opened, even when the post shows up in a search result on another page - the podcast starts playing automatically. We definitely do NOT want this setting, we want users to be able to listen when they decide to listen.

    As I said, this has not been the case for the many months we've been using Podpress - it just started happening. I cannot find anything in the settings options to fix this. Even when I enable "Enable listen wrapper," the podcast still starts playing as soon as the user mouses anywhere in the relevant page.

    Please tell me how turn off this automatic feature.
    Thanks,
    Andy

  2. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Andy,

    I have visited the linked site with Chromium 12.x and Firefox 5 from a computer with Ubuntu 11.04 and with Chrome 12.0.742.100 and 12.0.742.112, Firefox 5, Internet Explorer 9, Opera 11.11, Safari 5.0.4 from a Win 7 (64bit) computer. But I could not reproduce or experience this behaviour. The player was always inactive until I clicked manually on the play button.
    It seems to me that this is no general problem.

    Which browser do you use? (Which OS?) Did you install a new browser plugin recently? Does this behaviour occur in other browsers on your computer too?

    Regards,
    Tim

  3. asmarkowitz
    Member
    Posted 3 years ago #

    Hi Tim, thanks very much for the extensive check and quick reply and apologies for not getting back sooner. After I posted my question I saw that the Hide/Show player setting had been switched to Show, which I gather enables the auto-play. I believe it was set to hide as the default and I hadn't changed the settings, so don't know how it happened, but once I figured out the problem I switched it back, obviously before you made your checks.

    This was in Firefox on a computer running Windows 7, and I had just installed a new version of the browser ... but my business partner was getting the same effect on a Mac using Safari, so don't think that was the issue.

    In the event the immediate problem is solved. But I would note that it is isn't immediately obvious that the hide/show setting is what controls this - I was looking for a loop or auto-play setting as I've seen with audio in other CMS's. Perhaps the newer versions of Podpress have this - in my view it would make things more clear for the user.

    Best and again, thanks for your help. Really glad to see the forum active.
    Cheers,
    Andy

  4. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Andy,

    thank you for your reply and your help on finding the problem.

    But I would appreciate it if you could be a little more precise about the the name of the option in question.
    Do you mean the "Hide Player/Play Now:" setting in the section Post Content on the General Settings page of podPress?

    This setting should not change the autoplay behaviour of the mp3 player (or any other player). It should only have power over the part of the row below the player which says (by default) "Hide Player" or "Play Now". But it is imaginable that such an effect could occur somehow. Because if this option is set to Show and the player is hidden by a different option and you would click on "Play Now" then the player should become visible and start to play immediately. Since there is a lot Javascript involved, it is possible that any Javascript error interfere and eventually change the autoplay behaviour.
    Since this is no feature and probably a bug I would like to know more about the circumstances.
    Could you change the setting once more and open the blog page again while the error console of your Firefox is open? I would appreciate it if you could post all errors. (Please, clear the error console before you open the blog page.)
    Furthermore I would like to know the "Player:" setting from the Post Content section (general settings of podPress) and your settings in the All Players section of the player Settings page.

    Thanks,
    Tim

  5. asmarkowitz
    Member
    Posted 2 years ago #

    Hi Tim, apologies again for the very long delayed response. To answer your questions:

    >> Do you mean the "Hide Player/Play Now:" setting in the section Post Content on the General Settings page of podPress?

    Yes, that setting. At the time of the problem it was on 'Show' and the audio would auto-play. When I switched to 'Hide,' auto-play stopped.

    Perhaps at the time as you say it was a JavaScript error or bug. As you suggested, I just now switched it back to "Show" and auto-play did not occur. And there were no errors in the error console. The only effect was as you said, the appearance of 'play now'/'hide player' in line below player, and where that line appears in our designed player 'box'.

    However, in the meantime between then and now, we have updated to the newest versions of PodPress (and WP) ... so again, perhaps whatever error was causing the auto-play before has been solved by the update.

    Player in Post Content/general settings is set to 'Enabled' (and was at the time of the problem).
    All Players in Player settings is ticked for Display Player/Preview and Use HTML 5 tags and unticked for show HTML5 players always on page load.

    Hope this information is helpful and again sorry it took me so long to get it to you.
    Cheers,
    Andy

  6. ntm
    Member
    Plugin Author

    Posted 2 years ago #

    Andy,

    thank you for your report.
    (No need to apologize for delayed answers. I was away from the Internet in the last days and could not answer earlier. Something like that happens.)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags