WordPress.org

Ready to get started?Download WordPress

Forums

podPress
Not working on Firefox browser (35 posts)

  1. Nyetah
    Member
    Posted 2 years ago #

    Sometime this week the PodPress player stopped working in Firefox. When I click play it gives the message "buffering" and does not change/play. I've tried with two different computers running FF and disabling any addons and the problem persists. I've seen conversations here about resolving such issues for Chrome but can only guess that this may work for FF. Anyone know for sure?

    http://wordpress.org/extend/plugins/podpress/

  2. ntm
    Member
    Plugin Author

    Posted 2 years ago #

    When I click play it gives the message "buffering" and does not change/play

    This is often a sign that something is not okay with the URL scheme or the availability of the source.
    It may occur if one activates the statistic feature of podPress without proper Permalink settings.

    Have you activated this feature recently?

    Does the player work in Chrome or Safari or IE9?

    Is the option "Use HTML5 tags" (Player Settings page of podPress) activated?

    What is the name of your blog? (May I have a look?)

    Regards,
    Tim

  3. Nyetah
    Member
    Posted 2 years ago #

    Have you activated this feature recently?

    I believe I activated the stats well before the player stopped working. BUT I've been learning so much new stuff setting this up I can't say this for certain...only that I'm 90% sure I turned stats on before this started.

    Does the player work in Chrome or Safari or IE9?

    Yes, it works in both Chrome and IE9 (I haven't tried Safari).

    Is the option "Use HTML5 tags" (Player Settings page of podPress) activated?

    No.

    What is the name of your blog? (May I have a look?)

    Sorry, I should have posted this: http://storiesfromthepoint.com

    Thanks so much for your response. I figured out what the problem was in gathering my response to your questions and I'll put the culprit here in the event others have this same problem.

    I had been playing around with my .htaccess file and had put in some code to discourage hotlinking. Apparently this code stops the player in FF. Specifically:

    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^http://yoursite.com.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.yoursite.com.*$ [NC]
    RewriteRule .*\.(gif|jpg|jpeg|bmp|mp3)$ http://www.yoursite.com/stophotlinking.html [R,NC]

  4. Lee
    Member
    Posted 2 years ago #

    Firefox can be a bit buggy with multimedia content. Does it play when you use a different Firefox user profile?

    http://support.mozilla.org/en-US/kb/Managing-profiles

  5. ntm
    Member
    Plugin Author

    Posted 2 years ago #

    It is most likely not a Firefox bug. The player which has been mentioned above is a Flash MP3 player (1PixelOut) which requires the Flash plugin for Firefox. This Flash player has probably some problems with the measures which Nyetah has used to prevent hotlinking.

    This thread is not about the HTML5 Audio/Video player of Firefox.

    @Nyetah: I guess you have resolved the mystery. But I'm not sure what you could do to use your security setting and this Flash player at the same time. podPress includes a further Flash player which looks a little bit different. Maybe it behaves differently too.

  6. Nyetah
    Member
    Posted 2 years ago #

    @ntm: Yes, taking the code out of the htaccess file resolved the issue but then I can't use the (no) hotlinking code :-/. I tried switching to the other player in podPress and it wouldn't play the files either. But this is only happening in Firefox. Both IE and Chrome played the files fine with the hotlinking code in my htaccess file. So it seems to point back to FF in some way. Thanks for the feedback. I really appreciate the discussion and hopefully we'll come accross an answer eventually. :-)

  7. Lee
    Member
    Posted 2 years ago #

    I can play the files at http://storiesfromthepoint.com without issue. They all play for me. Try playing browsing the page while using a different Firefox profile or disable Firefox addons and extensions one by one to determine which one is preventing you from using the player in Firefox.

  8. ntm
    Member
    Plugin Author

    Posted 2 years ago #

    podPress shows in Firefox browsers a Flash player instead of the browser-own media player. Because the Firefox media player does currently not support mp3 files.
    If you would deactivate the option "Use HTML5 tags" on the player settings page of podPress then Chrome and Safari would also show the Flash player and if you would activate the no-hotlinking settings in the .htaccess file you would see the same behaviour. It is most likely the way these Flash players open the media files.
    On a second thought it may have something to do with the statistic feature of podPress.
    Could you do a further test? Activate the lines in the .htaccess file again and deactivate the statistic feature of podPress. Does this change the situation?

  9. ntm
    Member
    Plugin Author

    Posted 2 years ago #

    @Nyetah: you can find out whether this is a Firefox issue or not by deactivating the option "Use HTML5 tags" and by activating this no-hotlinking rules. If you can observe the problem in Chrome or in Safari, it is definitely no Firefox bug.

    @diondeville: Nyetah has deactivated some restrictive rewrite rules in the in the .htaccess file of her/his blog. That is why you can not observe the problem at the moment.

  10. JohnCDonahue
    Member
    Posted 1 year ago #

    I have been using PodPress on another site and have never had this problem before. I started a new website for podcasting http://www.DisneyParksPodcast and the plugin works on IE, Chrome, Safari, but not Firefox. I have tried all the suggestions here...all to no avail.

    Suggestions?

  11. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi John,

    I have looked into the source code of the podcast post and there is one thing which looks at least unfamiliar. podPress creates a <object> HTML element for the Flash player. But on this particular page inside the code podPress creates is a new line of code which is no product of podPress. I guess a different plugin puts

    <div class="fluid-width-video-wrapper" style="">[...]</div>

    around all <object> elements in a post. I guess this disturbs the player.
    The name of the class attribute suggests that the plugin which pust the code there, has something to do with a different video player or is some kind style helper plugin.
    Do you which plugin could be responsible for this?
    Which other plugin besides podPress are installed?

    Tim

  12. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    I believe this code comes from your theme. You can find this class name in .js files of the theme.

    Maybe there is a theme setting which you can alter. It has probably something to do with audio or video player position or size.

  13. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    I have installed the Responsive theme in one of my test blogs and could observe the same problem.

    The additional <div> container element is probably from the fitvids() functions.

    I'm not sure how to deactivate this safely.

  14. JohnCDonahue
    Member
    Posted 1 year ago #

    I went into the .js folder and played with it until I found a solution. Thanks so much, you put me on the right path!!

  15. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    I have found a way which will deactivate only the FitVids functionality.
    If you don't need this then edit the file /wp-content/themes/responsive/js/responsive-scripts.js.
    Line 4 should start with

    }(function(a){a.fn.fitVids=fun[...]

    Set a comment symbol after the curly bracket:

    }//(function(a){a.fn.fitVids=fun[...]

    and save the changes.

  16. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Yes you could do this but please note that this will "kill" the responsive videos, if you add any of them in the future they will no longer be responsive.

    Another thing, from the couple of URLs above I noticed that you guys are not using a Child Theme, as strongly recommended by http://codex.wordpress.org/Child_Themes and as well as http://themeid.com/forum/topic/505/child-theme-example/ whatever you changed will be lost in next Theme update.

    Thanks for using Responsive Theme,
    Emil

  17. macsilva
    Member
    Posted 1 year ago #

    Hello. I just installed podpress on my WP blog and the 1PixelOut player doesn't show on neither Firefox, Chrome, nor Safari. I'd love to use the podpress 1PixelOut player on my post.

    When I activate "Use HTML5 tags" it shows the play button on Chrome and Safari, but not on Firefox. I also tried Nyetah .htaccess solution. It showed the player on Chrome and Safari almost on top of the download options, but still didn't show on Firefox.

    Could you please help me?

    Podcast example: Embrocast

    I am using the Standard Theme.

    Any suggestion will be much appreciated. Thanks,

    Marcelo

  18. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    @Marcelo: Thank you for looking through older posts!!
    The problem in your case seems to be exactly the same as in JohnCDonahues case. A further plugin wraps all <object> elements into an additional <div> container element (<div class="fluid-width-video-wrapper" style=""> ... </div>). This disturbs the podPres script which loads the player.

    The question remains:
    Do you need the other plugin?
    What is the best way to keep the other plugin from wrapping the podPress objects? - Maybe there is a setting which makes exactly this. The class name fluid-width-video-wrapper lets me conclude that it has something to do with the with of flash videos.

    Maybe there is a further way. I going to think about a solution.

    Tim

  19. macsilva
    Member
    Posted 1 year ago #

    Thanks for the reply, Tim. I've removed all plugins but PodPress. Please let me know if you find any solution.

    Thanks,

    Marcelo

  20. macsilva
    Member
    Posted 1 year ago #

    Hi Tim,

    This is what I found when I looked for "fluid" on the Style of my theme:

    /* Post Format Video */

    .format-video .video-container, .fluid-width-video-wrapper {
    width: 100%;
    margin-left: 0 !important;
    margin-right: 0 !important;
    margin-bottom: 20px;
    }

    .format-video .entry-content {
    padding: 0;
    }

    .format-video .entry-content > * {
    margin-left: 20px;
    margin-right: 20px;
    }

    .format-video .entry-content *:first-child,
    .format-video .video-container,
    .format-video .fluid-width-video-wrapper {
    margin-left: 0;
    margin-right: 0;

    Any help or work-around?

    Thank you so much.

    Marcelo

  21. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    Marcelo this is no CSS problem. A Javascript adds the additional <div> HTML elements dynamically to the code. This script is part of your theme - and not of a plugin. It is in the file /wp-content/themes/standard/js/lib/jquery.fitvids.js. (This file contains also some CSS definitions.)

    This file contains the line:

    if (this.tagName.toLowerCase() == 'embed' && $this.parent('object').length || $this.parent('.fluid-width-video-wrapper').length ) { return; }

    If you modify it to:

    if (this.tagName.toLowerCase() == 'embed' && $this.parent('object').length || $this.parent('.fluid-width-video-wrapper').length || $this.parent().hasClass('podpress_playerspace') ) { return; }

    then should help.

  22. macsilva
    Member
    Posted 1 year ago #

    Thanks for your attention, Tim. I've modified as you suggested, but is still not showing. Should I do anything else? Please help.

    Thanks again,

    Marcelo

  23. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    Marcelo, the script modification is working. The script does not add the additional <div> element if the <object> or <embed> element is one of the podPress elements.

    But a further script is setting a huge values for the height of the player <object>s. That is why it still not visible.
    Maybe videopress.js does that. I will look into it.

  24. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    Okay. The file /wp-content/themes/standard/jstheme.videopress.js contains some lines which adjusts the height of the <object> elements (which may be videos but can be flash audio players like the one of podPress) dynamically to the height of the post content height.
    But the podPress player <object>s have always a height of 24px.

    The lines 37-39 contain the code which is responsible:

    jQuery('object')
    	.attr('height', jQuery('.entry-content').height() + 'px')
    	.attr('width', jQuery('.entry-content').width() + 'px');

    Replace these lines with:

    var objects = jQuery('object');
    objects.each(function(i){
    	var $this = jQuery(this);
    	if ( $this.parent().hasClass('podpress_playerspace') ) {
    		$this.attr('width', jQuery('.entry-content').width() + 'px');
    		return;
    	}
    	$this.attr('height', jQuery('.entry-content').height() + 'px');
    });

    The new code will do the same as the old lines of code. But it will not modify the height of <object> elements inside the container element with the class podpress_playerspace.

    Notice: Every theme update would probably retrograde these modifications. That is why you should ask the support of your theme to create the possibility to exclude certain elements or classes of elements from the dynamic theme adjustment processes.

  25. macsilva
    Member
    Posted 1 year ago #

    It fixed the issue! THANK YOU!!!

    Question: Is it going to affect anything else or is it just an exception to exempt podpress?

    Thank you so much again!

  26. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    Question: Is it going to affect anything else or is it just an exception to exempt podpress?

    The modifications are designed to affect only the podpress elements. These are adjustments to exclude only podPress elements from the Javascripts. They will not limit the scripts regarding any other elements like video which were not embedded with podPress.

  27. cjwelle
    Member
    Posted 1 year ago #

    I am now having issues with my podpress plugin. The HTML5 player plays in Chrome & Safari, but podcasts plays in firefox and none play in IE9.

    Website: http://www.talkradiooone.com

    Any help would be appreciated.

  28. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    @cjwelle:
    I visited the Talk Radio One blog and browsed through the Marc Germain Shows with the following browsers: Safari 5.1.5, Chrome 22.x, Opera 12.x, IE9 and also Firefox 16.0.1. I have no problem with the player(s). It worked in all the browsers. The blogs works.

    Since you are using a Cache plugin I guess that the problemsis a Cache issue. I'm not sure how you can resolve this. But maybe clearing the browser cache helps. There is probably also the possibility to clear the cache memory of the blog cache plugin.

  29. cjwelle
    Member
    Posted 1 year ago #

    Thank you for your quick response. For some reason the MarcGermain Show posts are all working. Other podcasts are not currently. Only thing I can see differentiating them is the files are stored on another url, but these podcasts work under HTML5 players.

  30. cjwelle
    Member
    Posted 1 year ago #

    I have emptied the caches as suggested and disabled the plugin to see if that would solve the issue as well, but no luck still.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic