WordPress.org

Ready to get started?Download WordPress

Forums

podPress
Not working on Chrome browser (5 posts)

  1. BibleStudyRadio
    Member
    Posted 2 years ago #

    It works with IE and Firefox but does not work with Chrome.

    e.g. http://chinese.biblestudyradio.org/

    http://wordpress.org/extend/plugins/podpress/

  2. ntm
    Member
    Plugin Author

    Posted 2 years ago #

    podPress embeds by default on requests with IE9, Safari 5.x and Chrome 9.x or newer versions the mp3 files with the HTML5 <audio> tag. The player which can see and which does play your episodes in Chrome is the Chrome-own audio player and is not part of podPress.
    Safari 5.1.x and IE 9 are playing your episodes fine. Only Chrome makes trouble.

    I downloaded one of your last episodes and posted it for test purposes temporarily on my test blog. The result was that Chrome had no longer a problem with the file. I added the same episode again. But this time I used the URL of the file on your blog. That lead to the same problem as in your blog.
    It seems to me that this is a very Chrome-specific problem with a condition on the server of your blog.
    Maybe you need to add the mp3 mime type to the .htaccess file:
    http://www.htaccess-guide.com/adding-mime-types/
    The correct line for mp3 files would be

    AddType audio/mpeg mp3 MP3

    Eventually it might help if you would edit the ID3 information of the mp3 files and add the name of the author etc. (see http://www.google.com/support/forum/p/Chrome/thread?tid=5e4dd580c55cd600&hl=en). But I'm not sure about that because uploaded to my server the problem did not occur.
    Furthermore if you open the URL of the episode (e.g. http://chinese.biblestudyradio.org/messages/gen_148.MP3) directly with Chrome then it does also not play. That makes it very clear that this is no bug of podPress and points also to the idea to add the mime type to the .htaccess file on the server of your blog. You can find this file usually in the root directory of your blog or the main domain. If you can not find it or don't know how to edit or create it then ask your hosting provider for help. There is also the possibility that your web server uses a different method and not .htacces files. In this case it would also a good idea to ask your hosting provider for help.

    If you want to do the test have done with your episode yourself see http://undeuxoutrois.de/wp/allgemeines/chrome-audio-test . I will remove this post in two days or after you have visited it.

    Tim

  3. ntm
    Member
    Plugin Author

    Posted 2 years ago #

    btw: If you add

    .podPress_content {
    clear:left;
    }

    to the style.css of your theme then the Play button in Chrome, Safari and IE 9 will be visible superiorly.

  4. debrasimpson
    Member
    Posted 2 years ago #

  5. ntm
    Member
    Plugin Author

    Posted 2 years ago #

    @debrasimpson: Do you suggest to deactivate the option "Use HTML5 tags:"?
    If you do that one of the Flash players which come with podPress will be displayed in all browsers with the Flash plugin. That would of course be one solution for BibleStudyRadio too. But it would not solve the original problem. Furthermore note that iPads, iPod Touch and iPhones do not support Flash.

    You say "how I got PodPress to show up". Does this mean that there was no player or player icon visible while you watched your blog with Chrome or Safari?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags