WordPress.org

Ready to get started?Download WordPress

Forums

podPress
[resolved] iTunes Only Shows 1 second of audio (3 posts)

  1. arickrol
    Member
    Posted 3 years ago #

    I updated to WP 3.1.1 and also to PodPress 8.8.10.2 . I did not change any of the settings in PodPress or WordPress. But, ever since I did those two updates there is a problem in iTunes with my recordings.

    The two most recent shows, uploaded after I did the above mentioned update, only have 1 second of audio in iTunes. On my blog, http://www.wargamingforums.com, the full length of the audio is shown in the post. Downloading the audio directly from the post also provides the full length.

    For some reason, either PodPress is not sending the full file to iTunes or iTunes is not receiving the full file. Only 1 byte of the file is sent to iTunes.

    http://itunes.apple.com/us/podcast/cwf-game-cast/id273121833 is a link to my iTunes listing. CWF Game Cast Episode 50 and CWF Game Cast Episode 51 are the two files in question. The first was uploaded on 4/3/11 and the second on 4/12/11.

    http://wargamingforums.com/2011/04/04/cwf-game-cast-episode-50-wwpd-news-from-the-front-and-steven-maclauchlan/ is a link to my post corresponding with CWF Game Cast Episode 50.

    http://wargamingforums.com/2011/04/12/cwf-game-cast-episode-51-black-powder-explosion/ is a link to my post corresponding with CWF Game Cast Episode 51.

    Has anyone experienced this, or a similar, problem? What is the recommended course of action for fixing this problem?

  2. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    podPress does not send the files to the iTunes Store server. It adds only the duration and file size besides other meta data to the feeds of a blog. The iTunes Store page interprets the feed you have registered there and displays the information in its own format. The listeners of your podcast which subscribe via the iTunes Store to your podcast download always the files from your blog. Because the files stay always on your blog.

    But your observation is right the file size of the last two episode in the feed is 1 byte and the duration is 1 second.

    <enclosure url="http://wargamingforums.com/wp-content/uploads/2011/04/CWF-51_-Black-Powder-Explosion.mp3" length="1" type="audio/mpeg" />
    <itunes:duration>0:00:01</itunes:duration>

    But if you look into the source code of your podcast feed then you can see that this is also the case for episode 49 and 48.
    The values of the older episodes in the feed is right. That shows that it is probably not a bug of the function which produces the feed entries.
    Are you sure that you have clicked on the "Auto Detect" buttons for the file size and the duration of these last episodes?
    If you have not done this and if you have not entered the value of the duration and the file size manually for each of these episodes then podPress adds only these minimal values.

    Open the last posts in the post editor and control whether or not you have inserted proper duration and file size values of these episodes.
    If the auto detect button does not work then try to insert values manually.

    Regards,
    Tim

  3. arickrol
    Member
    Posted 3 years ago #

    Hi Tim. Sorry my delay in posting. Spent the weekend on the shore for my wife's birthday and just got back. I think you deduced the problem. The iTunes Store shows Episode 51 Fixed and Episode 50 Fixed with the proper information. I didn't alter anything with the Fixed versions. I just uploaded them before we left. Not sure I waited for the auto detecting of the file size and duration but I must have.

    I took a peek at the original Episode 50 and Episode 51 postings. No information is listed for the length of either episode. Both episodes list the file size as 1 byte. So, I am re-auto-detecting that information. Very surprised that it is taking so long for the files. Several minutes in fact.

    Must be a lot of traffic or perhaps a setting with my host. Other files are equal sizes, or larger, than these two episodes and I never encountered the auto-detect taking this long.

    Thank you very much for your help. I really appreciate you taking the time to respond to my original posting and for your invaluable help. I'll give you a shout out in the next episode that we record.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic