WordPress.org

Ready to get started?Download WordPress

Forums

podPress
[resolved] itunes feed not updating - transfer from another webservice (7 posts)

  1. chriscoops
    Member
    Posted 1 year ago #

    So I have a few problems with my itunes feed, and podpress, after transferring to wordpress from another podcasting service elsewhere on the internet.
    So I was using podbean, which I have discovered over time is rubbish. So I decided to move my blog and podcast to wordpress and my own server.
    Domain name is still the same (http://allhailtheale.co.uk), but obviously with podpress the RSS feed has changed (http://allhailtheale.co.uk/?feed=podcast).
    After posting a new podcast the site itself is working perfectly, but itunes hasn't updated in over 24 hours...
    So, first thing I checked was that I had enabled the new-feed-url option in podpress, check. However, the RSS feed doesn't appear to show <itunes:new-feed-url> as you can probably see.
    Secondly, I checked the feed validator, and I get 2 errors (although it says it's valid, just that couple of recommendations that the realname is missing under managingeditor and webmaster.

    So 2 questions, really. What might be the problem with the new feed URL? Secondly, how do I add the information that's recommended in the feedvalidator?

    and the last one; will doing either of them actually work?

    TIA
    Chris

    http://wordpress.org/extend/plugins/podpress/

  2. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    After posting a new podcast the site itself is working perfectly, but itunes hasn't updated in over 24 hours...

    Is the old feed still working? It would be better if it would be working.

    The iTunes Store server probably still tries parse the the old podcast feed and only knows the URL of the old feed. Via the <itunes:new-feed-url> tag the server will notice that the podcast has been moved and learn and take over the new address. The point is that you need to activate the <itunes:new-feed-url> tag in the old feed. Both feeds need to be active at the same time for at least 24h.
    If you activate such a tag in the new feed then it has no effedct because iTunes does not know the URL of the new feed.

    So, first thing I checked was that I had enabled the new-feed-url option in podpress, check. However, the RSS feed doesn't appear to show <itunes:new-feed-url> as you can probably see.

    You have activated the function for all non-podPress feeds like the regular post feed of the blog. But the /?feed=podcast (or /feed/podcast) feed is one of the additional podPress Feeds. You would need to activate this function in the podPress Feeds section on the Feeed/iTunes Settings page of podPress (for each of these separately if necessary).

    Secondly, I checked the feed validator, and I get 2 errors (although it says it's valid, just that couple of recommendations that the realname is missing under managingeditor and webmaster.

    Well, these notices or recommendations are no errors. They are recommendations (nice to have but not required by the specification).
    Currently you can alter these values by modifying the admin email address. But one of the next versions of podPress will includes possibilities to adjust those values better.

    Tim

  3. chriscoops
    Member
    Posted 1 year ago #

    Hi Tim,
    thanks very much for your response.

    Is the old feed still working? It would be better if it would be working.

    The iTunes Store server probably still tries parse the the old podcast feed and only knows the URL of the old feed. Via the <itunes:new-feed-url> tag the server will notice that the podcast has been moved and learn and take over the new address. The point is that you need to activate the <itunes:new-feed-url> tag in the old feed. Both feeds need to be active at the same time for at least 24h.
    If you activate such a tag in the new feed then it has no effedct because iTunes does not know the URL of the new feed.

    Yes the old feed is still working, I didn't realise that both feeds had to be updated with the <new-feed-url>. Now I've just got to figure out how to do that over at Podbean. It seems I have to upgrade to an advanced account! Grrr, just another reason why I hate that service!

    You have activated the function for all non-podPress feeds like the regular post feed of the blog. But the /?feed=podcast (or /feed/podcast) feed is one of the additional podPress Feeds. You would need to activate this function in the podPress Feeds section on the Feeed/iTunes Settings page of podPress (for each of these separately if necessary).

    I have definitely set this option to Enable on the Feed/iTunes settings... It's the first thing in the list after the iTunes ID, so I definitely haven't missed it. The feed URL is http://allhailtheale.co.uk/?feed=podcast, but it's not showing up there. I haven't even bothered setting up any other feeds at this point, priority is to get itunes working.
    I've flicked the option to Disabled, and then back to Enabled and it still hasn't worked... Any other suggestions appreciated.

    Well, these notices or recommendations are no errors. They are recommendations (nice to have but not required by the specification).
    Currently you can alter these values by modifying the admin email address. But one of the next versions of podPress will includes possibilities to adjust those values better.

    That's nice to know then, I was hoping that wouldn't be the thing that's stopping it, but you never know!

    Cheers
    Chris

  4. chriscoops
    Member
    Posted 1 year ago #

    OK, so I've managed to set the new feed url in my old podcast location, but I still can't get it to work on the podpress plug-in on wordpress, any ideas, as I'm all out!?

    thanks

  5. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    I didn't realise that both feeds had to be updated with the <new-feed-url>

    No, this tag needs be only in the old feed.

    I have definitely set this option to Enable on the Feed/iTunes settings... It's the first thing in the list after the iTunes ID, so I definitely haven't missed it.

    For the Feed http://allhailtheale.co.uk/?feed=podcast this option is not the one after the input field for the iTunes ID. You may set this option for this particular feed in the podPress Feeds section on the Feed/iTunes Settings page (you need scroll down a little bit). If you set this option there then you will see it in the http://allhailtheale.co.uk/?feed=podcast feed. It definitely works (but so far you have not found the correct setting).

    (If you can not set the <itunes:new-feed-tag> in your podbean feed then there is maybe an alternative: http://www.apple.com/itunes/podcasts/specs.html#errors )

  6. chriscoops
    Member
    Posted 1 year ago #

    hey, thanks very much mate, managed to sort it out now. I had to pay $50 to crappy podbean to update the field into the original podcast feed.
    And, found the right one in podpress the end. I don't really understand why it had to be entered and enabled twice, still got it sorted, now so don't care!

    Thanks for being so much help

  7. ntm
    Member
    Plugin Author

    Posted 1 year ago #

    I don't really understand why it had to be entered and enabled twice,

    The first one, at the top of page, is not for the feed with the URL http://allhailtheale.co.uk/?feed=podcast. The first setting is for all default feeds which WordPress produces without a plugin. But podPress offers the possibility to add additional feeds like .../?feed=podcast.
    The settings for those additional feeds are in the section podPress Feeds.
    The other settings at the top of feed settings page - the ones in the section "Settings for the default Feeds" are as the itunes:new-feed-url setting for the default feeds. These settings don't effect the podPress Feeds and vice versa. (a default feed would be e.g. http://allhailtheale.co.uk/?feed=rss2)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags