WordPress.org

Ready to get started?Download WordPress

Forums

podPress
iTune feed incorrect (13 posts)

  1. BibleStudyRadio
    Member
    Posted 3 years ago #

    The iTunes:Subtitle field was entered in the Feed/iTune Setting, however the content within <itunes:subtitle></itunes:subtitle> in the feed was not what was entered in the field. It took part of the <itunes:summary> as the subtitle.

    http://wordpress.org/extend/plugins/podpress/

  2. BibleStudyRadio
    Member
    Posted 3 years ago #

    After updating to the newest version, the <itunes:category> are incorrect and the RSS Feed no longer works. Please fix ASAP.

  3. UULosAlamos Webmaster
    Member
    Posted 3 years ago #

    Yes. Our iTunes:category was Religion and Spirituality and the "&" breaks the RSS. Had to turn category off for now to get it to work.

  4. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Thank you for reporting the problems!

    The current Development Version includes already a bug fix for the problem with the "&" characters.

    But so far I could not find the wrong behaviour of the <itunes:subtitle>. But I will make some more tests.
    @BibleStudyRadio: Which <tunes:subtitle> element did you wrote about? The one of the <channel> or the ones of the <item>s?

    Regards,
    Tim

  5. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    @BibleStudyRadio: Now I have controlled the <itunes:subtitle> of the channel and the channel items.
    If you insert something in the field for the <itunes:subtitle> of the main feeds or the podPress Feeds then that value shows up in the feed. If you leave that blank then the <itunes:subtitle> element in the feed stays empty, too.

    The <itunes:subtitle> element of the <item>s behaves differently. You can choose in the post specific itunes settings (while you are editing a post) "Use the excerpt" or "insert a custom value".
    If you choose "Use the excerpt" (it is also the default setting) then podPress tries to use the manually written excerpt of the post. If there is no manually written excerpt, it takes the first words of the content of the post and if the content is also empty (or something went wrong) then it takes the post title as the itunes:subtitle.
    If you choose "insert a custom value" then you can enter a custom value. But if you leave that input field empty, then setting will be set automatically to "Use the excerpt" again.

  6. BibleStudyRadio
    Member
    Posted 3 years ago #

    The new fixed version still not working. I had to revered back to the 10.2 again. With the 10.4 I got an error when verifying with feed validator:

    line 145, column 1: 'utf8' codec can't decode bytes in position 7320-7322: invalid data (maybe a high-bit character?) [help]

    <itunes:block>no</itunes:block>
    ^

    Also version 10.2 and the new 10.4 both has issue (not error):

    line 31, column 58: title should not contain HTML: » [help]

    <title>Chinese Bible Study Radio » Podcast Feed</title>
    ^

  7. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    @BibleStudyRadio: Have you tried 8.8.10.6?
    If there are still problems then please, post besides the error message at least the two lines from the XML code which are above the line with error. The line which is in the error message is sometimes not helping me (like the message with the itunes:block element. It is fine as it is. The cause for the error message was in a different line). Or don't switch back to 10.2, so that I can see myself what the problem is. I'm the next 2 hours in front of the computer (until 0:00 UTC+2).

    Regards,
    Tim

  8. BibleStudyRadio
    Member
    Posted 3 years ago #

    I just upgraded to 10.6, same error. Here is the feed validator link that you will see the error:

    http://www.feedvalidator.org/check.cgi?url=http://chinese.biblestudyradio.org/?feed=podcast

  9. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Thank you. I could see what the problem is. (The method which limits the number of characters in the <itunes:subtitle> cut off a part of last Chinese symbol and the validator (and probably some feed readers) has trouble to interpret that.

    This particular problem is probably limited to blogs with languages with multibyte characters.

    I will think about a solution.

    Thanks,
    Tim

  10. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    You may try the current Development Version (8.8.10.7 beta 1). it uses a multi-byte safe function (mb_substr instead of substr) to limit the number of characters in the <itunes:subtitle> (in fact not only in the subtitle).

    I would appreciate it very much if you could test this Development Version.

    Regards,
    Tim

  11. BibleStudyRadio
    Member
    Posted 3 years ago #

    Why 10.2 did not have this problem?

  12. BibleStudyRadio
    Member
    Posted 3 years ago #

    The beta seems to work.

    http://www.feedvalidator.org/check.cgi?url=http://chinese.biblestudyradio.org/?feed=podcast

    But still have the issue in line 30

  13. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    But still have the issue in line 30

    Yes, I know. I will think about that too.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags