WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: podPress] "Click to Play" preview player and m4a files (7 posts)

  1. VadimS
    Member
    Posted 3 years ago #

    Hi,

    I found two problems using m4a format as an audio podcast:

    1. I am not able to get rid of "Click to Play" preview player, even if its disabled
    2. When you click on it, the player appears 1 pixel width unless i change it to some common dimensions.

    Is there any way to get rid of "Click to Play" picture and to play m4a files in regular 1PixelOut or Podango player as it happens with mp3 for example?

  2. ntm
    Member
    Posted 3 years ago #

    One possibility to hide player preview of the m4a files is to remove the cross or hook from the "Display Player/Preview" checkbox at the podPress > Player Settings page. But that would hide all players and player previews.
    For such a use case more suitable option is to use the "Disable Preview Player: [ ] (Use this to disable the "Click to Play" preview player.)" option in the podPress box below the post editor.

    If the last option does not work then there might be a Javascript error on your page. Please, open the error console of your browser, clear it and reload the page with the m4a post while your are using the "Disable Preview Player:" option. Are there Javascript errors?
    Another possibility is that your theme has some kind of special CSS.
    The second point seems related to the CSS of your theme.

    If you would post the URL to one of these m4a posts, I could take look myself and maybe help you.

  3. VadimS
    Member
    Posted 3 years ago #

    Thanks for the quick reply

    Here what i have: "Display Player/Preview" is unchecked in the player settings and "Disable Preview Player" is checked, but when you press "play" the preview image appears instead of the player anyway.

    As for Javascript - cant find any, so seems to be ok.

    Here how it looks at this moment:
    http://www.vadimsoloviev.com/ver3/en/category/podcast/

    One post contains m4a file (the latest one)
    And the second is with mp3

  4. ntm
    Member
    Posted 3 years ago #

    but when you press "play" the preview image appears instead of the player anyway

    That is right and it is how it should be. Because podPress contains no m4a Flash player like the 1PixelOut or Podango player. These two players can only play mp3 files and I don't know a free flash player which plays also m4a file.
    (There are flash players which are capable of playing m4a files but one shows advertisement or you have to buy a license if you want to use the player on a commercial web site. But the new browser versions will support the HTML5 <audio> and <video> tag and I think that is the way to go for future versions of podPress.)
    The Player which appears after you click on the player preview is the browser plugin which is designated to play m4a files (often QuickTime) or the audio elements of the browser if the browser is capable of playing m4a without a plugin. In other words what happens after the click on the player preview depends totally on the browser and its plugins.

    When I click on the preview player of your m4a episode after some seconds the QuickTime player elements appear as they should and they have also in the right size. That all works very well (You are right no Javascript errors or other problems).

    At the moment there is no option which prevents that the preview player is going to be displayed first.

    I have discovered that the images which are parts of the preview player have a white and not a transparent background colour. I'm going to change that for the next podPress version.

    Regards,
    Tim

  5. VadimS
    Member
    Posted 3 years ago #

    Thanks for the detailed reply Tim,

    All correct, its quick time and as for some reason in Safari it displays in 1 px width, so just need to change the dimension in the settings.

  6. ntm
    Member
    Posted 3 years ago #

    Vadim, I have used IE8, FF 3.6.10, Safari 5.0.2 and Opera 10.63 (all on a Win 7 PC) to visit this m4a post and all browser show the Quicktime object with a 320px width and 18px height.
    But this is maybe another example of the different standard implementations of the browsers.
    I don't know where you want to change the width. But changing it in the podPress box below the post editor will probably not work.

    But you could try to add some additional CSS to the style.css file of your theme:

    .podpress_playerspace object, podpress_playerspace embed {
    	display:block;
    }

    maybe with an !important;:

    .podpress_playerspace object, podpress_playerspace embed {
    	display:block!important;
    }

    The <object> resp. the <embed> element of the player has an absolute width of 320px and a height 18px.
    I hope that this helps. However, it should most likely do no harm.

    Regards,
    Tim

  7. VadimS
    Member
    Posted 3 years ago #

    I`m on Mac OS, may be thats the reason. Anyway, decided to use mp3 for now, less headache :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags