WordPress.org

Ready to get started?Download WordPress

Forums

podPress
[resolved] 1 pixel out player not showing in IE 8 and Windows 7 (16 posts)

  1. jersnav
    Member
    Posted 4 years ago #

    Hi,

    I just updated to 8.8.5.2 and in IE8 and Windows 7 I cannot get the 1 pixel out player to display in a post.

    It shows ok in Firefox on same machine.

    Site i'm working on is http://www.aapsonline.org/newsoftheday
    Thank you!

    UPDATE: I uninstalled 8.8.5.2 and reinstalled 8.8.5.1 and now IE8 works ok.

  2. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    Thank you for the report and the hint that 8.8.5.1 seems to work better.

    There is going to be a new release very soon.

  3. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    For all who read this and have not rolled back to 8.8.5.1: This problems is eventually related to the version of the Adobe Flash Player which installed on your machine.
    I have tested 8.8.5.2 with IE8 and Windows 7 with Flash 10.0.32.18 and again with 10.1.53.64. I had no problems with both Flash versions.
    But as I have written above: I'm going to release the next version soon.

  4. ntm
    Member
    Plugin Author

    Posted 4 years ago #

    I have uploaded some changes to the repository. Basically I added some elements again which seemed to me unnecessary.

    If you like to test the changed version then please, download the current Development Version of podPress. This version is to find among the Other Versions.

    It would be a great help if you could test the Development Version because I can not reproduce the error you have described above, although I have tested on different operating systems with different browsers and Flash versions.

  5. jersnav
    Member
    Posted 4 years ago #

    Hi,
    Thank you!
    I installed the development version as you suggested. and it appears to have fixed the problem in my particular situation.
    Appreciate the help.

  6. mikehcg
    Member
    Posted 3 years ago #

    Hi Dan,

    I am having the same problem. Index shows, post doesn't. There is a difference between Chrome and Firefox. I have posted screenshots so you can see what I mean.

    These are the versions I have on my pc:
    Adobe Flash 10.1.82.76
    Windows XP Service Pack 3
    Chrome 6.0.472.36 beta
    Firefox 3.6.8
    Podpress 8.8.6 RC 1

    Of course, I have a whole pile of plugins, which may or may not have any influence on Podpress.

    Here the screenshots:

    Chrome Index
    http://sofortmassnahmen.eu/hcimage/chrome-index.png
    Chrome Post
    http://sofortmassnahmen.eu/hcimage/chrome-post.png
    Firefox
    http://sofortmassnahmen.eu/hcimage/podpress-ff3.png

    Michael

  7. mikehcg
    Member
    Posted 3 years ago #

    Oh, I forgot I am using Mandigo theme, version 1.41, soon to be updated to 1.42

    Michael

  8. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Hello Michael,

    I have installed the v1.42 of the Mandigo theme and I was not able to reproduce this problem. The version 1.42 with nearly default settings is not causing the problem. I have tested with both browsers and both show the same result: the player and the download links are visible on the main blog page and in the single post view.

    But I can confirm the problem on your page: both browser are showing also the same results: the player and the download links are visible only on the main blog page and not in the single post view.
    That is why I don't understand what the FF screen-shot shows. Is it the main blog page or the single post view?
    Either way, the fact that only the player is not visible is most likely related to the many Javascript errors which are occuring on your page. The player is inserted via JS and if there are JS errors then the browser may not execute all scripts and halts on the first error.
    The cause of the completely invisible podPress elements in the single post views is a different one. These elements (like the download links) will be inserted via the the_content filter hook of WP (via PHP). Other plugins are using this hook, too to filter the post content.

    Does the Firefox screen-shot show a single post view?

  9. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    Does it make a difference if you would change the setting of the position of the podPress elements to 'End'?

    Regards,
    Tim

  10. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    @Michael: BTW: an update to 4.0.8 of the Google Analytics for WordPress plugin will probably help with the not working "Play in Popup" links.

  11. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    @Michael: The problem you have had should be resolved with podPress v8.8.6.3.

  12. missmoxie
    Member
    Posted 3 years ago #

    I'm actually having a similar problem with a client's podpress player.

    We've got it displaying in posts, but it won't display on the homepage within posts. it shows the text beneath the player, but not the player itself. I can't seem to find anything on it and it's a little out of my realm.

    http://howshereallydoesit.com (note the top box on the right has the little player text, but no actual player. But it does have it in the interior posts.

    We are using 8.8.6.3 and WP 3.01 with multisite.

    Thanks!
    Joelle

  13. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    @Joelle: Actually the player does not appear on your site for a different reason than in the other cases in this thread (and in your case the player does also not appear if you are using FireFox or Safari).

    But I have probably an easy solution for your case:

    Please, add to the style.css of your theme or to the podpress.css file the lines

    .podpress_mp3player object, .podpress_mp3player embed {
    	display:block;
    }

    alternatively you could try:

    div.podpress_mp3player object, div.podpress_mp3player embed {
    	display:block;
    }

    or add "!important" like this:

    display:block !important;

    Regards,
    Tim

  14. missmoxie
    Member
    Posted 3 years ago #

    Hi Tim! Thanks so much. I'll give those a go and see if I can't get it working. :) I appreciate your quick reply!

  15. missmoxie
    Member
    Posted 3 years ago #

    Awesome! Adding the !important; fixed the issue. Much obliged.:)

  16. ntm
    Member
    Plugin Author

    Posted 3 years ago #

    I'm glad that I could help! Thanks for reporting back.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags