WordPress.org

Ready to get started?Download WordPress

Forums

PiwigoMedia
[resolved] Unable to see Piwigo button (11 posts)

  1. AnniM
    Member
    Posted 3 years ago #

    Running Piwigo 2.16 and a localhost install of WordPress 3.1 (until I can finish customizing it) on Windows 7 - after activating the plugin (and having told it that my actual site is at http://www.annisworld.us) and going to write a post, I don't see the piwigo button anywhere in the Visual field. All that shows is the standard upload/insert menus.

    Thanks :)
    Anna McCullough

  2. plegall
    Member
    Posted 3 years ago #

    Hi Anna,

    Did you configure PiwigoMedia? I mean the screen Administration > Settings > PiwigoMedia. You have to set at least one "Piwigo Site". On my local copy (WordPress 3.0.1), I set "Piwigo Site" as http://www.annisworld.us/piwigo and it works fine.

    --
    Pierrick

  3. AnniM
    Member
    Posted 3 years ago #

    Yes, thanks - I did do that. I'm not running 3.01, though - I'm running WP 3.03 on my site (that's the version provided by my webhost) and 3.1 at localhost at home - not seeing the Piwigo icon on either of them. It SHOULD be right there in the formatting bar, correct, along with the standard bold/italic/etc. items?

  4. plegall
    Member
    Posted 3 years ago #

    Yes the button should be in the formatting bar, see screenshots on a recent blog post I wrote : http://piwigo.wordpress.com/2011/02/15/insert-your-photos-from-piwigo-into-wordpress/

  5. AnniM
    Member
    Posted 3 years ago #

    Yes, that's where I read about the plugin for the first time - (nice blog, by the way!!!) I couldn't wait to try it as I've just set up a new site for myself. Unfortunately, it only seems to like the 3.01 version. I've just posted a query to the plugin author' website.

  6. johnnyfive
    Member
    Plugin Author

    Posted 3 years ago #

    Hello Anna.
    I've upgraded WP from 3.0.4 to 3.1 and hadn't any problems with PiwigoMedia.

    Make sure file and directory permissions are correct inside /wp-content/plugins/piwigomedia. The webserver must be able to read and execute on this directory.

    Cheers

  7. AnniM
    Member
    Posted 3 years ago #

    Johnnyfive - permissions are the same as the other plugins - user has all, group and world read and execute. The plugin shows as activated, but will not appear on the toolbar. I've just updated the blog to 3.1 also, with no difference. I have the Piwigo Media site set to http://www.annisworld.us/piwigo (and yep, I hit "save changes").

    Dunno...I'm at a loss :)

  8. johnnyfive
    Member
    Plugin Author

    Posted 3 years ago #

    Anna, I suggest you check your webserver error logs (eg. Apache).
    You could also try to:
    - make a clean install of WP
    - disable all plugins except PiwigoMedia

    Also make sure you're using Visual editor mode, as HTML mode is not yet supported.

    Cheers

  9. AnniM
    Member
    Posted 3 years ago #

    To all - the issue has been resolved to my satisfaction. It appears that the one thing that was causing it to NOT work is not mentioned anywhere - Evidently one can't use this with Internet Explorer. As soon as I downloaded Chrome and Firefox, the Piwigo button immediately appeared and works perfectly fine with WP 3.1 when accessing my WordPress site via those browsers - but nothing I do makes it appear in IE (Running IE 8 on Windows 7).

    Thanks to all the folks who posted suggestions - I was indeed doing it right as far as installing or configuring EXCEPT I used the wrong browser.

  10. johnnyfive
    Member
    Plugin Author

    Posted 3 years ago #

    Great! In fact I haven't tested this plugin with IE, ever. It is, very likely, related to javascript. I'll further investigate this issue.
    Thank you for your efforts.

    Cheers

  11. johnnyfive
    Member
    Plugin Author

    Posted 3 years ago #

    Hi.

    There are updates to PiwigoMedia regarding Internet Explorer support.
    Read more.

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic