WordPress.org

Ready to get started?Download WordPress

Forums

Pinterest RSS Widget
[resolved] Problem by using plugin in a page (11 posts)

  1. saschawalk
    Member
    Posted 2 years ago #

    When I'm using the plugin in a page, I get this Error:

    Fatal error: Call to undefined method WP_Error::get_item_quantity() in "PLUGIN DIRECTORY"/pinterest-rss-widget/pinterest-rss-widget.php on line 53

    Even if I'm only use [prw username="myuser"]

    Could you help?

    http://wordpress.org/extend/plugins/pinterest-rss-widget/

  2. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    Can you give me a link to your site where this is happening, and also the link to your Pinterest account?

  3. saschawalk
    Member
    Posted 2 years ago #

    It's on this page: http://www.blog-in-orange.de/pinterest-2/

    My Pinterest account is: http://pinterest.com/saschawalk/

    I'm using this code on the page:
    <p>[prw username="saschawalk" maxfeeds="20" divname="myList" printtext="1" target="newwindow" useenclosures="yes" thumbwidth="180" thumbheight="180" showfollow="medium"]</p>

  4. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    The same shortcode works fine on my test site. What version of WordPress are you using?

  5. saschawalk
    Member
    Posted 2 years ago #

    I'm using 3.3.1-de_DE the official German Version.

  6. saschawalk
    Member
    Posted 2 years ago #

    The Widget works fine, as you can see on my site.

  7. saschawalk
    Member
    Posted 2 years ago #

    May it's a PHP Problem. I'm using PHP Version 5.2.17

  8. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    I hadn't noticed that the widget was working fine. That makes it more confusing to me as to why the shortcode would not be working, since obviously they use the same function. The fact that the error is related to the get_item_quantity() function makes me think it's an issue with the RSS feed from Pinterest, but I can't replicate the error you're getting on your site so that is strange too. I wonder if it might have to do with the German version of WP?

    I'm sorry I am not able to help more - this is very confusing.

  9. saschawalk
    Member
    Posted 2 years ago #

    No problem. I keep trying it.
    I've seen the error also in the wigdet, but only one time.
    Thanks for your help.

  10. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    Just checked and it seems to be working fine now. Do you know how it was resolved? I'm going to mark this discussion as resolved.

  11. untruthseeker
    Member
    Posted 2 years ago #

    I came accross this same problem and I think it happens when the plugin is unable to get as many items as the maxfeeds parameter demands.

    You probably solved this by now on your own but I hope this helps somehow.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic