WordPress.org

Ready to get started?Download WordPress

Forums

Pinterest RSS Widget
[resolved] Pins only display in a straight vertical line, not next to each other (21 posts)

  1. melissaaggie98@gmail.com
    Member
    Posted 2 years ago #

    For some reason, when I installed this widget, the pins won't line up next to each other as shown in the screenshot. They would simply make a vertical line and stack up one on top of the other.

    http://wordpress.org/extend/plugins/pinterest-rss-widget/

  2. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    Let me know where you have it installed and I can help you get it set up right. It's likely an issue with the theme you're using and easy to fix.

  3. stomperk
    Member
    Posted 2 years ago #

    I am having the exact same issue, all the pins are just in one column. Did anyone resolve this issue?

  4. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    If you give me the URL for your site I can troubleshoot. Usually this is an issue with the theme CSS and can be fixed easily.

  5. stomperk
    Member
    Posted 2 years ago #

    Thanks for the quick reply, here is the site in question - http://www.healthycarrot.com/

  6. jadan
    Member
    Posted 2 years ago #

    I think your plugin is perfect for my needs, but I too am experiencing this issue with the line. If I do more than 3 the next row will start with this unselectable line. I'm also not getting any data thru firebug, not sure where its coming from. Please let me know when you have a solution.
    here is the site: http://shopmoderngypsy.com/

  7. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    @stomperk: you need to add the following code to the end of your theme's style.css file:

    .rightwidget ul li.pins-feed-item { width: auto; }

    @jadan: you need to add the following code to the end of your theme's style.css file:

    .sidebar-widget li.pins-feed-item { background:none; }

    These are conflicts with your themes' CSS and the plugin. Let me know if the fixes work for you.

  8. stomperk
    Member
    Posted 2 years ago #

    @bkmacdaddy - thanks, worked like a charm!

  9. jadan
    Member
    Posted 2 years ago #

    @bkmacdaddy, Thank you for the help! I was able to remove the line, but I'm still getting the hole where a thumbnail would be. I appreciate the help on this!

  10. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    @jadan: Here you go. Add this to your style.css file as well. Sorry I missed that before.

    .sidebar-widget li.pins-feed-item:first-child { padding: 0; }

  11. jadan
    Member
    Posted 2 years ago #

    @bkmacdaddy - Works perfectly! Thank you so much for the help!

  12. webdesigner69
    Member
    Posted 2 years ago #

    I have the same problem. It's probably my theme but when i change the css, (hight and width), the pins stays in line. Could you look furtively please ?
    This is the url:http://www.3cubes.fr/audrey-wp/

  13. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    @webdesigner69: Here's the CSS you need to add to your theme's CSS file.

    .widget ul.pins-feed-list li {
      clear: none;
      margin: 5px;
    }

    Let me know if that solves your issue.

  14. webdesigner69
    Member
    Posted 2 years ago #

    @bkmacdaddy You're the best !!! Thank you so much !!

  15. carolinekempf
    Member
    Posted 2 years ago #

    You were so helpful to the other guys. Could you check out why I have the same issue? I tried both suggestions on css, but they didn't change the single column of images.

    http://www.ckc411.com/411-2/

  16. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    @carolinekempf: your sidebar is only 160 pixels wide and you have the thumbnails set at 75px wide (plus 5px margins all around), so they will only fit one thumbnail per row because 2 is too wide for the sidebar. You could try making the thumbnails/pins 70px wide and that should give you 2 per row.

  17. carolinekempf
    Member
    Posted 2 years ago #

    I had actually started out with them much smaller, I think 25px. But when they were in a single column I made them larger to keep it from looking odd. I did just try it again so you can see.

    Thanks for the super quick response, btw.

  18. bkmacdaddy
    Member
    Plugin Author

    Posted 2 years ago #

    @carolinekempf: They are still set at 75px, as far as I can see when looking at your source code. There also looks like something else is going on - possibly a conflict with another plugin. Or have you edited the plugin's source code?

  19. carolinekempf
    Member
    Posted 2 years ago #

    I reduced them to 55 and that worked. Thanks!

    And no, I didn't edit the source. I might have considered it because the text under the pictures was so large that it went underneath the pictures below it. That's why I turned off the text. I put it on so you could see for a second what I mean.

  20. gmccarter
    Member
    Posted 2 years ago #

    I upgraded the plugin version this morning and I am having the same issue with it all in one column. Can you take a look and let me know what I can do to fix this??

    http://acropolisinc.com

  21. ahanna84
    Member
    Posted 2 years ago #

    Having the same problems, it isn't showing up on my home page and on the other pages its in a single file row. Intoxicology.net if you could help. Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic