WordPress.org

Ready to get started?Download WordPress

Forums

Pinterest Pin It Button For Images
[resolved] Working Randomly? (18 posts)

  1. Lisa {Sweet 2 Eat Baking}
    Member
    Posted 2 years ago #

    Hi,

    I've been using this plugin for the past 2 weeks since I moved to WordPress. I'm not sure if it's a plugin issue or conflict but it only works randomly.

    I have a Lightbox plugin too so my images enlarge in such a way rather than opening to just the photo and the user having to go back (some non-techy people don't know how to go back!)

    I've tried disabling the lighbox plugin but sometimes it just add a # to the address bar and nothing pops up. Sometimes it does. It's been the same whether or not the Lightbox plugin is activated or not.

    I love this plugin [when it was working] and it definitely increased people pinning on my site so I'd love to work through a way to get it back up and running again, if possible?

    My blog address, if you need it, is Sweet 2 Eat Baking

    Thank you,
    -Lisa.

    http://wordpress.org/extend/plugins/pinterest-pin-it-button-for-images/

  2. Sean
    Member
    Plugin Contributor

    Posted 2 years ago #

    The new version of the plugin (1.0) should work with Lighbox. Update it and let me know if it worked.

    Cheers!

  3. Lisa {Sweet 2 Eat Baking}
    Member
    Posted 2 years ago #

    Hi, thanks for replying. I've updated the plugin and still no luck. Now the Pin It icon isn't even showing on any of my images (unless they're not linked, it appears). But even if I try to pin any of the images that aren't linked, clicking pin it still does nothing.

    I've tried this with both the Lightbox plugin enabled and disabled.

    I link my photos to their image URL as my theme only allows 640px so I like to enlarge them that way using Lightbox.

    Here's an example: http://www.sweet2eatbaking.com/2012/08/monster-cookies/
    If you hover over the first 2 (large) photos, you'll see they're linked to their image URLs and that no Pin It icon appears.
    However, if you go to the recipe area (after the 1st 2 photos), there's a small 150x150px image on the right, if I hover over that, the Pin It icon appears but does nothing when clicked.

    I appreciate you looking into this for me and for your time. I really hope this can be resolved.

    Thanks again,
    -Lisa.

  4. Sean
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hi Lisa,

    Can you do a quick test for me? Check out your media settings in "Settings > Media". Write down the current value somewhere down (it should read 1024). Set the "Large" image width to the width of your content (in your case, 640px). You can leave the "height" as 0 or whatever other value it is using.

    Now upload an image with at most 640px wide as a test. See if the plugin works then.

    If it does, that means I've found the problem and can easily fix it. If it doesn't, well...I guess I'll just have to try harder ;)

    After, please go back to "Settings > Media" and change the "Large" value back.

    Cheers.

  5. Lisa {Sweet 2 Eat Baking}
    Member
    Posted 2 years ago #

    Hi Sean,

    Under Image sizes, both the largest settings were set at 1024. Under Embeds, the width was empty and the height was 0. I changed both widths to 640 then uploaded a photo at 500x500px to the end of my last post.

    With the Lightbox Plus plugin enabled, it opens it in Lightbox. The Pinterest icon shows too but still opens in Lightbox when clicked (over the Pinterest icon). Therefore, I removed the link to the image URL and refreshed page and still shows the icon but does nothing when clicked on.

    I guess this means there's not the easy fix you were hoping for. Sorry.

    Also, not sure if this is possible (if you can get it working again) but I'd love to use my own Pinterest image. If you can get it working again, is there a URL I can edit in the coding to link it to my own image?

    Thanks again,
    -Lisa.

  6. Sean
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hi Lisa,

    I'll run some tests locally to see if I can reproduce the problem. It will be one step towards solving it ;)

    Regarding the image, you can upload a PNG file named "ppibfi_button.png" to the plugin folder. Make sure it's exactly 80 x 50 pixels in size (if not, you'll have to edit the ppibfi_pinterest.css file - It's marked down where to change). I'm still working on a way to enable easy image changing.

    Make sure you keep an eye out on updates.

    Cheers

  7. IAMTHELAB
    Member
    Posted 2 years ago #

    Hi Sean - I'm having the same problem. As soon as I updated the plugin, it stopped working.

  8. IAMTHELAB
    Member
    Posted 2 years ago #

    Just fixed it. Didn't realize you added it to the settings. Thanks for a great plugin.

  9. Lisa {Sweet 2 Eat Baking}
    Member
    Posted 2 years ago #

    Thanks Sean. I've uploaded my own image and changed the dimensions as stated and got it looking a perfect fit for my blog.

    Just hope you are able to replicate the issue and work towards a fix.

    Thanks for your time and effort.

  10. Lisa {Sweet 2 Eat Baking}
    Member
    Posted 2 years ago #

    Any luck on replicating the problem, Sean?

    I just thought of something that 'may' be causing my error. I set-up my blog on a different server that it is now as I knew I was switching over to WordPress at the time. So I got everything just right then transferred the files, database etc. as per instructions on WordPress for moving servers.

    Everything else other than scheduling a post is fine (that doesn't work for me). I'm wondering if it could be this that's causing it?

    If there's anything else I could check in the meantime, let me know.

    Thanks

  11. Sean
    Member
    Plugin Contributor

    Posted 2 years ago #

    Try the new 1.0.1 update. Let me know if this works.

  12. Lisa {Sweet 2 Eat Baking}
    Member
    Posted 2 years ago #

    No, still not working. :( I've set the max image size to 640px on both large image size and in the plugin settings. I've even tried deactivating all my plugins other than yours to see if there is a conflict and still no joy.

    I can't understand why it's not working for me yet seems to be working for others. It used to work, albeit randomly before the 1.0 update but since then, not at all.

    Could it be from what I said above about changing servers? Is there anything I can check? File permissions or anything else? There has to be something funky blocking it from working. Could it be a database issue because I changed servers?

    I'm willing to check anything if it gets it up and running again.

    Thanks
    -Lisa.

  13. Sean
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hi Lisa,

    Odd. It shouldn't be anything related to the database, as the plugin doesn't change any of the content directly (only when it's printed out / whenever the user opens your blog).

    Try commenting the following code from your CSS file (remember to backup your CSS file in case this is not the problem):

    .pinterest-button {
        position:relative;
        width: auto;
        float: left;
        overflow: hidden;
    }
    .pinterest-button img {
        display: block;
    }
    .pinterest-button .pin-it {
        display: block;
        width: 105px;
        height: 105px;
        background: url('images/pinterest-button.png');
        z-index: 9999;
        bottom: 25px;
        right: 25px;
        position: absolute;
    }
    .pinterest-button .pin-it {
        display:none;
    }
    .pinterest-button:hover .pin-it {
        display: block;
    }
  14. Lisa {Sweet 2 Eat Baking}
    Member
    Posted 2 years ago #

    Try commenting the following code from your CSS file (remember to backup your CSS file in case this is not the problem):

    I'm not sure what you mean by commenting?

    I've checked my themes CSS file and that set of CSS for the Pinterest button is in there. It's the same as you quoted above too.

  15. Lisa {Sweet 2 Eat Baking}
    Member
    Posted 2 years ago #

    Hi Sean,

    I fixed it! Can you believe that? It's working again.

    Thanks so much for all your help you've provided so far and for the great plugin.

    I'm super duper happy now.

    -Lisa.

  16. Sean
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hi Lisa,

    Sorry for the long delay. Can you tell me what was done for it to work? I'm curious. :)

    Congratulations, by the way ;)

  17. Lisa {Sweet 2 Eat Baking}
    Member
    Posted 2 years ago #

    Absolutely. I removed all the Pinterest CSS from the theme settings page, then deleted the plugin and removed all the files and reinstalled then it seemed to work.

    I've tried numerously deleting the plugin and reinstalling before trying the above, so it must've been something in the CSS. Glad it's working now again.

  18. bcr8tive
    Member
    Posted 1 year ago #

    Hi

    I'm having a different issue. All of the social media features are displaying as they are intended to however, the Pinterest button opens to a page that is displaying a 1 pixel image.

    I thought perhaps this feature is buggy so I disabled this and installed Share This. Pinterest button works on Share this BUT only displays the logo from the site and not the images from the post.

    I've also tried the Pinterest "Pin It" Button, Pinterest Image Pin, and Pinterest Pin It Button For Images. NONE work.

    The other odd thing is that I normally use a Pin it add on for my browser and I can right click any image and have a "Pin Image" option. On this WordPress version/template I am using (per the clients requests) that option is NOT available to me on this particular blog.

    I am pulling my hair out - Please help.

    bcr8tive~

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic