WordPress.org

Ready to get started?Download WordPress

Forums

PHPEnkoder
Problem with accents (4 posts)

  1. Shannon Smith
    Member
    Posted 2 years ago #

    I'm having a problem with a French-language site and the php-enkoder plugin.

    When the mailto address contains accents, php-enkoder strips the accents, and puts in gibberish characters.

    For example, if I have the following:

    <a href="mailto:info@example.com">André Tremblay</a>
    Montréal, Québec

    What will show on the site is the following:

    André Tremblay
    Montréal, Québec

    This only occurs for mailto links that contain accented characters and that are encoded using php-enkoder. Regular links that are not encoded (that have accents), and text that is not contained in a link (that has accents) work just fine.

    Thanks

    http://wordpress.org/extend/plugins/php-enkoder/

  2. michael_greenberg
    Member
    Plugin Author

    Posted 2 years ago #

    I've just updated PHPEnkoder, so perhaps that fixes your problem. If not, I would bet that I'm inadequately dealing with character encodings. Can you tell me if 1.10 works for you?

  3. Shannon Smith
    Member
    Posted 2 years ago #

    I'm using version 1.11, but I'm having the same problem.

  4. michael_greenberg
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm. I'm almost certain it's something to do with the way I handle character encodings---some of the obfuscation passes convert characters to their codes, which aren't stable across different encoding schemes. I'll look into it---please ping me if I haven't responded within a week.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic