WordPress.org

Ready to get started?Download WordPress

Forums

PHPBB Single Sign On
Cant activate pluin anymore (27 posts)

  1. heredia21
    Member
    Posted 3 years ago #

    I am getting this
    Fatal error: Cannot redeclare include_for_eval() (previously declared in /home/bbempire/public_html/wp-content/plugins/phpbb-single-sign-on/module.phpbb.php(45) : eval()'d code:19) in /home/bbempire/public_html/wp-content/plugins/phpbb-single-sign-on/module.phpbb.php(45) : eval()'d code(87) : eval()'d code on line 25

    http://wordpress.org/extend/plugins/phpbb-single-sign-on/

  2. AJenbo
    Member
    Posted 3 years ago #

    This could happen if your common-orig.php is the one from the plugin instead of the original common.php from phpBB.

  3. heredia21
    Member
    Posted 3 years ago #

    Hmmm i dont get it. I didnt know i had to mess with phpbb files. So what do i do?

  4. heredia21
    Member
    Posted 3 years ago #

    But it was that. I dont know why i had common-orig.php in my forum folder i removed it it works now. But the install instructions are not clear to get this mod working.

  5. AJenbo
    Member
    Posted 3 years ago #

    I think the problem is that the developer didn't test it with a brod range of setups and the permissions on your server are more restricted then what he has.

  6. heredia21
    Member
    Posted 3 years ago #

    Im following the manual installation

  7. AJenbo
    Member
    Posted 3 years ago #

    So it's fully working now?

  8. heredia21
    Member
    Posted 3 years ago #

    Not yet. I am still figuring out what common.php to copy and what to change it to

  9. heredia21
    Member
    Posted 3 years ago #

    When i go to forums i am getting this:
    SQL ERROR [ mysqli ]

    Table 'bbempire_bbe.wp_ads_in_positions' doesn't exist [1146]

    SQL

    SELECT ad_id, position_id, ad_priority FROM wp_ads_in_positions WHERE ad_enabled = 1 ORDER BY ad_priority DESC

    BACKTRACE

    FILE: includes/db/mysqli.php
    LINE: 163
    CALL: dbal->sql_error()

    FILE: ads/functions.php
    LINE: 160
    CALL: dbal_mysqli->sql_query()

    FILE: ads/functions.php
    LINE: 61
    CALL: get_ads()

    FILE: includes/functions.php
    LINE: 4380
    CALL: setup_ads()

    FILE: index.php
    LINE: 182
    CALL: page_header()

  10. AJenbo
    Member
    Posted 3 years ago #

    Download the phpBB from http://www.phpbb.com/downloads/index.php rename common.php to common-orig.php and move it to your forum folder.

  11. AJenbo
    Member
    Posted 3 years ago #

    Do you run phpBB and WordPress from different databases? This plugin still dosn't fully support that.

  12. AJenbo
    Member
    Posted 3 years ago #

    If that isn't the case then disable some of the plugins in WP, they might be causing conflict.

  13. heredia21
    Member
    Posted 3 years ago #

    No same database

  14. heredia21
    Member
    Posted 3 years ago #

    http://www.blackberryempire.com/forum i just replace it with regular common file.
    How do i get it to work?

  15. heredia21
    Member
    Posted 3 years ago #

    I think i got it no more errors how do i test

  16. heredia21
    Member
    Posted 3 years ago #

    ahh same error SQL ERROR [ mysqli ]

    Table 'bbempire_bbe.wp_ads_in_positions' doesn't exist [1146]

    SQL

    SELECT ad_id, position_id, ad_priority FROM wp_ads_in_positions WHERE ad_enabled = 1 ORDER BY ad_priority DESC

    BACKTRACE

    FILE: includes/db/mysqli.php
    LINE: 163
    CALL: dbal->sql_error()

    FILE: ads/functions.php
    LINE: 160
    CALL: dbal_mysqli->sql_query()

    FILE: ads/functions.php
    LINE: 61
    CALL: get_ads()

    FILE: includes/functions.php
    LINE: 4380
    CALL: setup_ads()

    FILE: index.php
    LINE: 182
    CALL: page_header()

  17. heredia21
    Member
    Posted 3 years ago #

    Ok i turned off adds and it works now. No errors. time to test

  18. heredia21
    Member
    Posted 3 years ago #

    Members are created both forum and wp.But when i try to login in forum i get a blank screen

  19. AJenbo
    Member
    Posted 3 years ago #

    Set PHP to show all errors and warnings. Theres no need to e-mail me when you post something, I'm already subscribed. And just so you know I'm going to bed now so I won't respond for the next 10 hours.

  20. heredia21
    Member
    Posted 3 years ago #

    Theres no more errors. Just a blank screen when i try to login through forum

  21. AJenbo
    Member
    Posted 3 years ago #

    Have you set PHP to show all errors and warnings? If you have then you must debug the file that the url is pointing to by either deleting sections of it or adding a die(); and then move down the code untill you find the line that is breakning it.

  22. heredia21
    Member
    Posted 3 years ago #

    No error justs a blank screen

  23. AJenbo
    Member
    Posted 3 years ago #

    Yes you sort of said that a few times, but have you configured PHP to show all errors?

    in the php.ini you need to set
    display_errors = on
    error_reporting = E_ALL | E_STRICT

    If you do not have access to the php.ini then ask your host provider how to change this.

  24. heredia21
    Member
    Posted 3 years ago #

    Where would php.ini be located

  25. AJenbo
    Member
    Posted 3 years ago #

    In the php installation folder, if you don't know it's a good bet that you need to talk to your host provider.

  26. heredia21
    Member
    Posted 3 years ago #

    obviously this plugin needs work ill just wait to see what the issue is..

  27. AJenbo
    Member
    Posted 3 years ago #

    The issue might be conflicts on your server, and if you don't report the error then the chances that it will be fixed is low

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic