WordPress.org

Ready to get started?Download WordPress

Forums

Photoswipe for NextGEN Gallery
[resolved] Very Nice!! One minor glitch (12 posts)

  1. ejb5oh
    Member
    Posted 1 year ago #

    This is exactly what I have been looking for. I had to create code to tell my pictures which album to show depending on the os of the user, cause the lightbox feature messes up on mobile devices.

    The problem I am seeing, is that the lightbox still pops up when viewing a gallery. Can you cause your plugin to disable the lightbox feature and force the swipe to view feature?

    Thanks,

    http://wordpress.org/extend/plugins/photoswipe-for-nextgen-gallery/

  2. Guillermo Seņas
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin should be already disabling the lightbox effect.

    Have you changed the "Link Code Line" setting in the "Effect" tab? Can you send me a URL to check it?

    Thanks!

  3. ejb5oh
    Member
    Posted 1 year ago #

    rel="themeblvd_lightbox[%GALLERY_NAME%]"

    http://ap-police.com/crime/gangs/

    Pictures at the bottom.

  4. Guillermo Seņas
    Member
    Plugin Author

    Posted 1 year ago #

    Easy one :)

    The Link Code Line its not the default. To solve your issue, you can do one of these two things:

    a) Change the "Link Code Line" to its default value: rel="lightbox[%GALLERY_NAME%]"

    b) In my plugin, change the line 22 of ngg-photoswipe.js from

    jQuery('a[rel^="lightbox"]').attr("rel","");

    to

    jQuery('a[rel^="themeblvd_lightbox"]').attr("rel","");

    Option a is way easier.

    What about rating the plugin? ;)

  5. ejb5oh
    Member
    Posted 1 year ago #

    Actually that did work great!! Just dont mess me up when you update your plugin :o)

    Definitely will rate you five stars!!

  6. Guillermo Seņas
    Member
    Plugin Author

    Posted 1 year ago #

    Did you try the first option?

    Your page is still showing the rel="themeblvd_lightbox[set_6]" attribute...

  7. ejb5oh
    Member
    Posted 1 year ago #

    Yes, I meant to say it worked just great. I was stupid and employed both fixes without reading your entire post. I had to go with plan B. Just rated the plugin, thanks!!

  8. Guillermo Seņas
    Member
    Plugin Author

    Posted 1 year ago #

    I'm glad you've got your website ready! :)

  9. ejb5oh
    Member
    Posted 1 year ago #

    You do not realize how much a life saver this plugin is. I was writing code that doubled my work until you came out with this. Thanks so much!!

  10. Guillermo Seņas
    Member
    Plugin Author

    Posted 1 year ago #

    I had the same problem, and took me some time to figure out how to solve it. So, why don't make a plugin to help others?

    I'm happy to see it's useful.

    Enjoy!

  11. ejb5oh
    Member
    Posted 1 year ago #

    I see you added a disable fancybox. You should do that for this issue as well so it don't keep popping up on me when I update. :o))

  12. Guillermo Seņas
    Member
    Plugin Author

    Posted 1 year ago #

    I decided against it because your theme (I guess) is not using the standard markup.

    I'm pretty sure that if you use option A, it should work as well, and you can keep updating the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.