WordPress.org

Ready to get started?Download WordPress

Forums

PDW Media File Browser
Thumbnails Not Rendering (3 posts)

  1. grosner55
    Member
    Posted 1 year ago #

    In thumbnail view, the thumbnails do not properly render. Instead of seeing image I see a thumbnail note to "Read Usage comments for details" Using php 5.4 (i did rename the phpthumb folder to use the latest version). Using hosted server. Documentroot is correctly determined. $uploadpath is correct.

    http://wordpress.org/extend/plugins/pdw-file-browser/

  2. ulken
    Member
    Posted 1 year ago #

    Since I spent half a day trying to fix a thumbnail issue myself (and considering what a superb plugin this is otherwise), I'd like to reveal what did the trick for me.

    First of all, my issue wasn't exactly the same as your's, since I never got any error message in place of the supposed-to-be thumbnail, but just a broken image-icon. Nevertheless, I searched through the plugin folders and located a README-file which stated what you suggested above. Using the newer version didn't make any difference, though. Simply because it wasn't new enough.

    Instead, I headed over to phpthumbs repository at sourceforge to check if any even newer versions existed. I never found out if it was in fact newer, but I gave it a try anyhow. All the same files are in there, plus a config-file (don't forget to rename it – remove the "default"-part).

    Refreshed the file browser page, and voilà, there they were.

    Can't guarantee it'll fix your problem (or if it's still relevant to you), but it might be worth a shot. If not, it might be of worth to somebody else.

    PS. Other customizations I've made to this plugin:

    • Allow international characters in filenames (åäö in this case): Simply add the wanted characters to the regexp expression stating which characters are allowed in filenames in config.php
    • Increase the upload size limit: Change the max_file_size_in_bytes variable accordingly (1MB = 1024 * 1024 B) in config.php (NOTE: I read somewhere in the code comments that 2GB is max for the flash uploader used. NOTE-2: The amount of increase allowed depends on which host you use, but you should at least be able to mirror the default uploader's limit (which's limit can be increased too using a custom php.ini file)
    • Allow bigger batch uploads (default: 100): Change the file_upload_limit parameter in index.php (0 = unlimited)
  3. kc22033
    Member
    Posted 1 year ago #

    @ulken

    Thanks! This definitely fixed my problem. Saved me many hours of research, I'm sure!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic