WordPress.org

Ready to get started?Download WordPress

Forums

PDO (SQLite) For WordPress
Does not give the password on install in 3.0.1 (4 posts)

  1. johnnyWP
    Member
    Posted 3 years ago #

    Hi, when I install the plugin, which means I put the files in the correct places and adjust the config.php (I do nothing in the WP app itself like activating a plugin), and I go to the install with wp-admin/install.php. I get the regular install prompts but when I submit the next page is filled with php code and create table statements.

    At the bottom it says success and to use the random password it created even though I put in a password. However, the password is blank. Nothing is there. When I try an login with admin and my password I typed in, I get denied. Blank password is denied also.

    I checked and the sqlite database is being created and looking at the tables it appears all the wordpress tables were made. I just can't login to the blog. The actual blog works just no admin.

    I don't know what password it is creating. The database has one in the column of wp_users but it is encrypted. Thanks for any help. Using Apache. Maybe there's a way to input a new password?

    http://wordpress.org/extend/plugins/pdo-for-wordpress/

  2. websign
    Member
    Posted 3 years ago #

    I had the same problem. The changes had to be done in pdo/wp_install.php Firstly I copied some code from wp-admin/includes/upgrade.php (code for creating user was slightly different) but it didn't help. Finally I add extra parameter ($user_password) to function wp_install in pdo/wp_install.php :

    function wp_install($blog_title, $user_name, $user_email, $public, $deprecated='', $user_password = '')

    and now it works!

  3. metalot
    Member
    Posted 3 years ago #

    works fine, just a generated password is used in all cases.
    I did display it and then used for initial login by: editing file:
    wp-content/pdo/wp_install.php

    $message = __('Note that password:' . $random_password . ' carefully! It is a random password that was generated just for you.');

    added this ' . $random_password . ' part in the middle. Otherwise it was not displayed and no login.

    wp301 works fine with sqlite, good luck, Giedrius

  4. quantum7
    Member
    Posted 3 years ago #

    The php and sql statements should not be displayed, but appear to be benign. There are a bunch of echo statements in driver_sqlite/schema.php which were probably intended for debugging during development and were never removed.

    As for the password, a random password was emailed to me at the email address I gave in step 1. This worked fine, and I was able to change my password from within wordpress. However, it is clearly a bug that the password input in step 1 is not actually used when creating the account.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic