WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: pb-embedFlash] v1.5.1 Shadowbox mode, NO parameters show in XHTML with p={NAME;VALUE} ! (5 posts)

  1. manududu3
    Member
    Posted 5 years ago #

    Hi Pascal,

    Thanks for your great plug-in developed, it's a fantastic work!

    My problem: I can't get the full screen to work with an embed FLV inside an shadowbox overlay. It is not working as it should be.
    You can check it at this link:

    Here the test link:
    Click here

    I use:
    Wp v2.7
    pb-embedflash 2.5.1

    Here my code:

    [flash http://www.liberation3d.com/content/videos/age-des-glace.flv mode=3 p={allowfullscreen;true}]

    I check my XHTML page, it seems NO parameters <param/> shows to allow the full screen as it should by default like
    <param value="true" name="allowfullscreen"/>:

    My XHTML page content:

    <div id="shadowbox_body_inner" style="height: 395px; display: block;">
    
    <object id="shadowbox_content" height="395" width="502" data="http://www.liberation3d.com/wp-content/plugins/pb-embedflash/swf/mediaplayer.swf?width=500&height=395&file=http://www.liberation3d.com/content/videos/age-des-glace.flv&searchbar=false&transition=fade&thumbsinplaylist=true" type="application/x-shockwave-flash" name="shadowbox_content">
    
    <param value="http://www.liberation3d.com/wp-content/plugins/pb-embedflash/swf/mediaplayer.swf?width=500&height=395&file=http://www.liberation3d.com/content/videos/age-des-glace.flv&searchbar=false&transition=fade&thumbsinplaylist=true" name="movie"/>
    
    </object>

    I can't have any <param/> show in the XHTML like it should be below even if I add p={allowfullscreen;true}:

    <object id="shadowbox_content" height="470" width="600" data="flvplayer.swf" type="application/x-shockwave-flash" name="shadowbox_content">
    
    <param value="flvplayer.swf" name="movie"/>
    <param value="file=http://file.flv" name="flashvars"/>

    <param value="true" name="allowfullscreen"/>

    </object>

    Any ideas why the tag p={} doesn't show in the posted XHTML as
    <param value="true" name="allowfullscreen"/>?

    -WP loaded Plugin or interference?
    -Version compatibility?
    -Many load of FLV by different plug-ins?
    -Syntax coding error?

    Thanks a lot for help, I'm desperate tried for many days..

    http://wordpress.org/extend/plugins/pb-embedflash/

  2. pasber
    Member
    Posted 5 years ago #

    The box itself is generated by the Shadowbox script and it's content changes by the data given with the rel attribute.

    As of one box is used for any content loaded in it (html, flash, pictures, etc.) and the box only changes width and height, adding/modifying/deleting information is quite impossible without changing the Shadowbox script from scratch.

    So I'm sad to tell you p={} and o={} are not available for Shadowbox. :/

  3. manududu3
    Member
    Posted 5 years ago #

    Hi Pascal thanks for reply,

    Is there any ways we can get the fullscreen to work with pb-embedFlash v1.5.1 in shadowbox mode and JW player v3.16 you provide? So that the JW player is embedded in shadowbox and the fullscreen button can work like in the Official shadowbox plug-in demo or your website Widgets?

    Here an example link:
    Official shadowbox plug-in demo
    (on the page go to and click Demos>Flash>Flash video)

    How did you get your shadowbox to work fullscreen?

    Is my only option is to go for a direct script in Html with the official shadowbox plug-in?

    Thanks for your support

  4. pasber
    Member
    Posted 5 years ago #

    The latest Shadowbox version is "2.0", pb-embedFlash still uses an earlier version (1.x). pb-embedFlash v1.6 should be finished in February and will contain the latest JW FLV Media Player and Shadowbox versions.

    Until then, I don't think there will be an easy way of adding the fullscreen parameter to the Shadowbox.

  5. manududu3
    Member
    Posted 5 years ago #

    Good point you bring on the different version used, it makes sense now. I wasn’t aware of it… =(
    I'm greatly looking forward on your next release v1.6. =)
    In the mean time, knowing how much time and efforts it takes for a new release, I’d like thank you very much for your great plug-in and sharing it.
    Your work is fantastic and really inspired me in my own project.

    So please, keep it run, you’re the best and thanks again!! =)

Topic Closed

This topic has been closed to new replies.

About this Topic