WordPress.org

Ready to get started?Download WordPress

Forums

Participants Database
[resolved] The delete function on main fields page doesn't seem to work (32 posts)

  1. remittancegirl
    Member
    Posted 2 years ago #

    I'm trying to delete fields in the Main Fields page, but the X button doesn't work.

    http://wordpress.org/extend/plugins/participants-database/

  2. quartney
    Member
    Posted 2 years ago #

    I'm having the same problem; I just installed Participants Database and am trying to edit fields. None of the red "X"s work.

  3. xnau
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    This question pops up a lot. These functions rely on Javascript to work, and it often happens that other plugins interfere with this plugin's javascript. The best way to troubleshoot this is to disable plugins until you find the culprit. Start with the ones that add admin functionality.

  4. quartney
    Member
    Posted 2 years ago #

    Turns out, it was my theme that wasn't allowing it to work! thanks!

  5. donnacrupi
    Member
    Posted 2 years ago #

    I have a couple of issues:
    1. The response email to my signup has the wrong id #. How do I change this?
    2. What is the difference between [pdp_record] and the wp-content/uploads/participants-database? When I set up my page, does it matter which one I use for the location?
    3. I deactivated all of my plugins and am still not able to delete fields. Can I go around this with pdb_record, selecting only the fields I want?

    Thank you and I greatly appreciate all of the advice you offer. I've read so many of your responses and they are extremely helpful.

  6. xnau
    Member
    Plugin Author

    Posted 2 years ago #

    donnacrupi,

    1. make sure the "Participant Record Page" setting is correct.

    2. use the shortcode [pdb_record] on the page where your users can edit their own record.

    3. Are you using a theme that changes the appearance of the admin? You may need to switch themes to get it working.

  7. xnau
    Member
    Plugin Author

    Posted 2 years ago #

    For those who are experiencing problems with the delete fields function not working, try uploading this new file:

    http://plugins.svn.wordpress.org/participants-database/tags/1.3.7/js/manage_fields.js

    it goes into the plugin js directory, overwriting the file of the same name:

    wp-content/plugins/participants-database/js/manage_fields.js

  8. donnacrupi
    Member
    Posted 2 years ago #

    Thanks for getting back to me. I feel like i'm ready to quit and trust me, it's killing me. I've spent two solid days without moving from the computer and the phrase never say die goes a long way with me, but...

    i don't even see where my csv loaded to. it did upload. i input 3 sets of data and have my page with wp-content/uploads/participants-database/ address.

    I received a response to the signup I filled out and the address sent me to another page on my website - not to where the form was. http://donnacrupi.com/?page_id=139&pid=00LFZ is what was sent and the actual page is http://donnacrupi.com/?page_id=153. I changed the id# in the url and it brought me to the page that said 'Participants Database' but there was no questionnaire. Just 'Leave a Reply'.

    I would love to stick with your site and send a donation. I've put a lot into this. If you help (can help) i'm happy not to give up.

    Also, I've made no changes to the theme and i deactivated all of the plugins.

    Thanks,

    Donna

  9. donnacrupi
    Member
    Posted 2 years ago #

    I copied and pasted over the old code. It said it was successful, but nothing changed in pdb. clicking on the red x still brings the page to the top.

    did anyone else have different results?

  10. xnau
    Member
    Plugin Author

    Posted 2 years ago #

    donnacrupi,

    At this point, you'll need to debug the Javascript to find out what's happening. If you use Chrome you can use the developer tools to see what kind of Javascript errors hare happening when you click on the delete red x.

    Did you try changing to the default WP theme to see if the plugin will work then? Might be your theme not allowing the plugin JS to function.

    It sounds like you need to check your setting for the "Participant Record Page" to make sure you've got the right page selected.

    The [pdb_record] shortcode won't show anything unless a valid "pid" value is included in the URL.

  11. quartney
    Member
    Posted 2 years ago #

    did anyone else have different results?

    The new file did not work for me, either. Still can't delete. Clicking the red X does absolutely nothing.

    Failed to load resource: the server responded with a status of 404 (Not Found) http://s410995807.onlinehome.us/wp-content/plugins/participants-database/pdb-record.css
    Uncaught TypeError: Object [object Object] has no method 'propAttr' load-scripts.php:370
    2
    Uncaught TypeError: Object [object Object] has no method 'propAttr' load-scripts.php:370

  12. xnau
    Member
    Plugin Author

    Posted 2 years ago #

    quartney,

    You probably have another plugin that is conflicting with the Javascript. Try turning other plugins off and see if it helps.

  13. tadleyrunners
    Member
    Posted 1 year ago #

    Hi,
    I have the same problem with red X and Signup Form Settings Record Form Settings also not working.

    I've disabled all plugins and this does not fix the problem.

    I've also tried two browsers (IE and Firefox) and still don't seem to be able to get it to work.

    Any ideas?

  14. quartney
    Member
    Posted 1 year ago #

    change your theme back to the default wordpress theme. delete what you need to, and change the theme back to the one you're using.

  15. tadleyrunners
    Member
    Posted 1 year ago #

    quartney,

    Thanks for the quick response!

    I have installed themes; twenty ten, twenty eleven, Weaver, Bloglife (various versons). Which one of these is the default?

    Sorry to sound ignortant, but I didn't setup the page originally so don't know what was the default.

  16. quartney
    Member
    Posted 1 year ago #

    going to twenty eleven will work.

  17. tadleyrunners
    Member
    Posted 1 year ago #

    I've tried that, still the same (ie not working).

    Any other ideas?

  18. quartney
    Member
    Posted 1 year ago #

    no other ideas. I can use the red X if I use IE or if I change themes to the default ...

  19. tadleyrunners
    Member
    Posted 1 year ago #

    Very odd, I've deactivated all other plugins, changed theme to default, tried in IE and FF, but stilll no joy.

    I'll try again in the morning from a different PC, just in case there's something odd with this one.

    Thanks again for your help.

  20. rodleir1963
    Member
    Posted 1 year ago #

    I have the same problem: I changed the theme, I uninstalled all the plugins, I install the js that recomend Xnau, I changed the browser (IE, Chrome, Moxilla, Opera) but it´s impossible to delete the fields... Nobody tried to see this problem?

  21. tadleyrunners
    Member
    Posted 1 year ago #

    I have been able to resolve the issue. Basically my server security was set too high. Once this was relaxed I was able to delete fields and update configs with no problem at all.

  22. rodleir1963
    Member
    Posted 1 year ago #

    About permissions perhaps?

  23. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    rodleir1963,

    Try this: using Firefox with FireBug installed, you'll be able to see any errors that occur in the console. That will probably tell you what the problem is. Permissions will definitely affect this function because it uses an AJAX call.

    If you see an error when you try to delete a field (you can also use Firebug Lite or developer tools in Chrome) report it here, and I'll see if I can find a solution for you.

  24. rodleir1963
    Member
    Posted 1 year ago #

    I installed FireBug in Firefox and when I made click on the X to delete de field, the console gave me this error: "TypeError:a.cookie is undefined" and the error is on line 29. Well... I can´t tell you any more because I´m not a programmer... What do you think? Do you like to enter in the WordPress site, with the Administrator password, to see the problem? The blog is empty and I´m only trying to install your plugin...

  25. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    As usual, the problem is most likely another plugin. Did you try disabling other plugins? Especially any that add functionality to the admin?

  26. rodleir1963
    Member
    Posted 1 year ago #

    Xnau: thanks for you answer. No, I haven´t any problem with another plugin. By the way, I installed an empty WordPress system in a directory, to prove it, without themes and plugins and the problem still exists. The URL is http://www.fsgallegas.org.ar/cre. I have no problem to give you the user and password but via email... If you like it... Thanks for your answer.

  27. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    Yes send me a log in, I'd like to see what the problem is. You can email it to my business email: webdesign@xnau.com

  28. rodleir1963
    Member
    Posted 1 year ago #

    The data was sent to you email...

  29. xnau
    Member
    Plugin Author

    Posted 1 year ago #

    OK, for anyone who is experiencing this problem, I've found that if your web server has mod_security enabled, it can block the jQuery plugin I'm using.

    Here's how to get around the problem:

    In your FTP, change the name of this file: wp-content/plugins/participants-database/js/jquery.cookie.js to jquery_cookie.js

    Then, open wp-content/plugins/participants-database/participants-database.php in an editor. On lines 367 and 382 change:

    wp_register_script( 'cookie', plugins_url( 'js/jquery.cookie.js', __FILE__ ) );

    to:

    wp_register_script( 'cookie', plugins_url( 'js/jquery_cookie.js', __FILE__ ) );

    This will allow the script to load. I will be incorporating this change into the next update.

  30. sridhar14
    Member
    Posted 1 year ago #

    XNAU : how to use this (orderby - order the list by one of the columns)

    i tried this code

    [pdb_list fields="private_id, first_name, email" orderby="private_id"]

    plz help me

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic