WordPress.org

Ready to get started?Download WordPress

Forums

Participants Database
[resolved] Modify database to use Spanish characters (9 posts)

  1. joseagarmon
    Member
    Posted 2 years ago #

    Hello. I'm spanish and I have problems when I download csv file. Spanish language has different characters to English language like "ñ" o "á" for example.

    How can I change this plugin to get these spanish characters from the database?

    http://wordpress.org/extend/plugins/participants-database/

  2. xnau
    Member
    Plugin Author

    Posted 2 years ago #

    joseagarmon,

    Try it, you'll find the plugin is quite happy with all kinds of character sets. The database uses "UTF-8" encoding.

  3. joseagarmon
    Member
    Posted 2 years ago #

    I have tried it but it doesn't work fine with these spanish characters.

  4. xnau
    Member
    Plugin Author

    Posted 2 years ago #

    joseagarmon,

    The plugin is not the problem here. You need to make sure your web pages have UTF-8 encoding.

  5. joseagarmon
    Member
    Posted 2 years ago #

    Where can I check UTF-8 encoding in my website?

  6. xnau
    Member
    Plugin Author

    Posted 2 years ago #

    Easiest way is to open a page in Firefox, then look under View/Character Encoding the encoding of the page will be indicated with a check mark. Other browsers have the same kind of thing.

    If the pages are not encoded as UTF-8, this is set in the web page header, so you'll be looking for a setting in your theme or you'll need to edit the header template to get the correct character set.

  7. joseagarmon
    Member
    Posted 2 years ago #

    I checked it. It's fine, text/html; charset=UTF-8. Could it be a problem with Spanish keyboard?

  8. xnau
    Member
    Plugin Author

    Posted 2 years ago #

    joseagarmon,

    I'm very sorry. I didn't notice you were asking about downloading a CSV. In this case, it's all on the spreadsheet or editor you're opening the CSV with. For instance, in Excel, when you are opening the file, you must specify that the format of the CSV is UTF-8.

  9. joseagarmon
    Member
    Posted 2 years ago #

    Ok. I'll try it. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic