WordPress.org

Ready to get started?Download WordPress

Forums

Paid Memberships Pro
No guest checkout for Paypal Express? (3 posts)

  1. musicsites
    Member
    Posted 2 years ago #

    I absolutely love this plugin, but I can not figure out how in the world I can allow guest checkouts via Paypal Express. I'm sure there's a way. I tried using Paypal Help, and I'm left confused and extremely frustrated. I don't like S2Members, and don't want to give up on PMPRO. Is there anything I can do to get this to work? My site is http://www.HitsTree.com Please help! Thank you in advance!

    Note: I'm using 3.31

    http://wordpress.org/extend/plugins/paid-memberships-pro/

  2. strangerstudios
    Member
    Plugin Author

    Posted 2 years ago #

    First, I'm glad you like our plugin.

    By "guest checkout" I assume you mean checking out without creating a PayPal account? I don't believe this is possible with "PayPal Express".

    If you use PayPal Website Payments Pro, then users can checkout on your site without a PayPal account, but you'll need to purchase that feature through PayPal and also account for the PCI compliance issues onsite checkout brings.

    It seems that Website Payments Standard now support recurring payments/subscriptions like you need. We would have to integrate this into the plugin... which will take some time... maybe a few weeks. Also, this requires a paid upgrade on your PayPal account: https://merchant.paypal.com/us/cgi-bin/?cmd=_render-content&content_ID=merchant/erp_overview

    How exactly were you setup with s2Members? Which PayPal version?

    Thanks.

  3. musicsites
    Member
    Posted 2 years ago #

    Yeah guest checkout. I remember reading something about it in my account but couldn't figure out how to get it to work. S2Members has too many setting elements, it looks intimidating and complicated, so I uninstalled it. Your plugin was pretty simple and straight forward. That's what I needed. I do have issues every now and again with "Can't connect to remote server" error messages, but it could has something to do with my plugins. I believe I have a few installed that aren't 3.31 compatible, but they work. Like JShortcodes is like 2.82 but I need it to make columns, buttons, and text boxes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic