WordPress.org

Ready to get started?Download WordPress

Forums

Paid Memberships Pro
[resolved] (Error code: ssl_error_rx_record_too_long) (9 posts)

  1. luschdesigns
    Member
    Posted 2 years ago #

    I have 2 plans set. One is free and one is paid. The free plan, when clicked, brings up the registration page.

    The paid plan when clicked, brings up: (Error code: ssl_error_rx_record_too_long)

    I'm not sure what I need to change to make it work properly. Paypal is set up with live API.

    Hosted on a managed server through 1&1 hosting.

    Thanks!

    http://wordpress.org/extend/plugins/paid-memberships-pro/

  2. luschdesigns
    Member
    Posted 2 years ago #

    I switched to Paypal Express Checkout and it works now.

  3. strangerstudios
    Member
    Plugin Author

    Posted 2 years ago #

    Hi, Lusch.

    Sounded like you needed to have the SSL certificate installed for the server. PayPal Express doesn't require an SSL so you're okay now.

  4. Caps
    Blocked
    Posted 2 years ago #

    I have PayPal Express selected and I am receiving "(Error code: ssl_error_rx_record_too_long)," when I click on myAccount /Edit.

    Is my PayPal API key interfering?

  5. strangerstudios
    Member
    Plugin Author

    Posted 2 years ago #

    It sounds like your site is still trying to load the page through SSL/HTTPS, but your server is not setup for that.

    When you choose PayPal Express, it shouldn't load the page over HTTPS.

    Do you have another plugin that may force SSL/HTTPS? If so, disable or alter them.

    Do any of your pages still have the "besecure" custom field? If so, remove that custom field.

    Try the above. If you still have issues, you can absolutely tell PMPro to always use HTTP by adding something like:

    function my_pmpro_besecure($besecure)
    {
    $besecure = false;
    return $besecure;
    }
    add_filter("pmpro_besecure", "my_pmpro_besecure");

    However, if something else on your site is loading HTTPS, you will still have problems.

  6. Caps
    Blocked
    Posted 2 years ago #

    Hi strangerstudios,

    I deactivated all but PMP. Still I get this error. This server has PHP 6.0.

  7. Caps
    Blocked
    Posted 2 years ago #

    When trying to create a new membership level and click on Add New Member, I get this:

    Warning: Creating default object from empty value in /homepages/26/d395080616/htdocs/talkingmanuals.com/wp-content/plugins/paid-memberships-pro/adminpages/membershiplevels.php on line 223
    ID:

  8. strangerstudios
    Member
    Plugin Author

    Posted 2 years ago #

    I haven't tested our plugin on PHP 6.0.

    Thanks for the heads up on the warning. I've fixed that warning of yours in the next update (not sure when it will go out). If you want to patch it yourself, you can add this line above line 223 of /adminpages/membershiplevels.php:

    $level = new stdClass();

    Or you can lower your PHP settings to hide warnings and notices.

    I can't tell anything else about your SSL error without more information. Did you try the fixes I suggested?

    If you sign up for support at http://www.paidmembershipspro.com, I can get your server details and login to look around and fix this for you.

  9. Caps
    Blocked
    Posted 2 years ago #

    Ok, that code worked - thank you. I am happy to support your work rather I had a problem or not.

    Again, thank you,

    Caps

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic