WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Page.ly MultiEdit] Not rendering shortcodes with cforms (5 posts)

  1. charlesmx
    Member
    Posted 2 years ago #

    Using cforms II and page.ly multiedit with short code support setting enabled (yes), however any time the cforms shortcode is added to the multiedit region it only renders html as below:

    <span title="Default Form" class="mce_plugin_cforms_img">Default Form</span>

    the shortcode is
    <!--cforms name="Default Form"-->

    When that same shortcode is in the Main Content region the content will render the actual form as expected.

    If I append a maul string after the apply_filters line #129 of multiedit.php file I can see that the setting is getting picked up and the apply_filters is being called. Example modification for confirmation of line #129:

    $me_str = apply_filters('the_content',$GLOBALS['multiEditDisplay'][$index][0]).'[AF]';

    Any thoughts or direction to get this to render cforms correctly?

    Page.ly MultiEdit version: 0.9.8.1
    CFORMS II version: 12.2
    WordPress: 3.2.1

  2. charlesmx
    Member
    Posted 2 years ago #

    bump, any one experienced this?

  3. charlesmx
    Member
    Posted 2 years ago #

    found a work around by changing the view to html prior to setting the setMetaContent call in the .js file.

  4. Ashton.Sanders
    Member
    Posted 2 years ago #

    hmmm. I wouldn't say this is resolved. I would recommend the plugin maker to add do_shortcode() to his function so it is automatically done.

    Can that be done?

  5. joshua strebel
    Member
    Posted 2 years ago #

    shortcode support is already there, only tested with [gallery].

    The latest version has an options panel to enable shortcode support.

Topic Closed

This topic has been closed to new replies.

About this Topic