WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Page Links To] Removing the page link (7 posts)

  1. RickA99
    Member
    Posted 5 years ago #

    I use page-links-to in all my WP websites. I consider it an essential part of every installation but there is one thing it doesn't do that I think would be a very valuable and useful addition. adding an option that removes the default WP page link.

    Imagine the situation where a particular page is a parent with several child pages. Using a plugin such as Multilevel Navigation, the parent page appears as a main menu item and the child pages within a dropdown menu below the parent. There are many times when i want the parent item to not link to a page so that when the user hovers over it, he can't click it to go to another page but must choose from the dropdown menu choices.

    I have seen many people searching for such a solution, including myself, and not finding one.

  2. allshookup
    Member
    Posted 5 years ago #

    I have had the same problem on several sites I have with the latest 1.8 version of "Page Links To".

    What I have done is download the older version "Page Links To 1.4"
    Then in the custom field NAME put "links_to" and in the VALUE put "#".
    That's is it now your page will not have a link. This is what I use on my parent pages.
    The only draw back is that if you use Google XML Sitemaps it will give you an error for that page, you can fix that by adding the parent page ID to the list of pages not to add to the XML site map in the Google XML Sitemaps setting. BAM there you go everything you want!

  3. elbalazo
    Member
    Posted 5 years ago #

    Hi,
    Do you have a link for Page Links To 1.4? I can't find one.
    Thanks

  4. viceng
    Member
    Posted 5 years ago #

    page links to 1.8 works fine for me

  5. elbalazo
    Member
    Posted 5 years ago #

    I found 1.4 and got it to work. I also tries 1.8, but I got no results. What did you do?

  6. Technokinetics
    Member
    Posted 4 years ago #

    Another option for this is Page Lists Plus.

    (1) Install and activate.
    (2) On the Settings > Page Lists Plus page in the dashboard, check the "Unlink" checkbox in the "Page-Specific Options" section, and "Save Changes".
    (3) On the edit screen of each Page that you want to unlink, scroll down to the "Page Lists Plus" box and uncheck the "Link" checkbox, then "Update Page".

    Note that this will remove the link's anchor tags, which can affect styling. If that's a problem:

    (4) Fix your styling in your style.css theme file.
    or
    (5) On the Settings > Page Lists Plus page in the dashboard, check the "Unlink using javascript" checkbox in the "Global Options" section, and "Save changes".

    - Tim

  7. Mark Jaquith
    WordPress Lead Dev
    Posted 4 years ago #

    Version 1.8 should have fixed this. The current version is 1.9

Topic Closed

This topic has been closed to new replies.

About this Topic