WordPress.org

Ready to get started?Download WordPress

Forums

P3 (Plugin Performance Profiler)
[resolved] There was an error processing your request. (13 posts)

  1. carolewalsh
    Member
    Posted 2 years ago #

    I am using the Atahualpa theme with WP 3.3.1. When I try to autoscan, it appears to be scanning for quite a while, then it says: "There was an error processing your request. Please reload the page and try again. [-1]". When I reload the page, I get the same message. When I try to manual scan, no matter what page I click on, it doesn't go to the page or do anything. When I go back to autoscan, it says that scanning is paused. When I resume it, I get the same error message.

    http://wordpress.org/extend/plugins/p3-profiler/

  2. carolewalsh
    Member
    Posted 2 years ago #

    Oh I forgot to mention, website is http://www.carolewalsh.com
    Please help.

  3. Kurt Payne
    Member
    Posted 2 years ago #

    Hi carolewalsh,

    Does this happen in all browsers, repeatedly?

    The code -1 means there was an invalid nonce detected.

  4. carolewalsh
    Member
    Posted 2 years ago #

    Interesting question Kurt.

    This all started when I updated to WP 3.3.1. The pages on my site and the admin pages slowed to a crawl. (Even timing-out before page loading). I tried a few suggestions offered in the forum (which didn't make any difference), including running P3.

    All this was done on a Mac running OS 10.6.8 in Firefox 11.0.

    So I tried it using Safari 5.1.2. The pages on my site and the admin pages came up super fast. (What's the deal with that?) But I still get the same error message with P3, except I also get the same message when I try the manual scan.

  5. Kurt Payne
    Member
    Posted 2 years ago #

    Do you have any errors in your javascript console (Safari / Chrome) or firebug console (Firefox)?

  6. carolewalsh
    Member
    Posted 2 years ago #

    No, I don't get any errors in the Safari javascript console or in Firefox firebug.

    I was able to speed up the web pages and admin panel by installing W3 Total Cache. But I still get the same errors when trying to scan with P3.

  7. Kurt Payne
    Member
    Posted 2 years ago #

    Can you e-mail a screenshot of each step along with a list of plugins to kpayne -at- godaddy -dot- com?

  8. msartori
    Member
    Posted 1 year ago #

    Hi Kurt,

    I saw that this thread had been resolved but I don't see an answer here. Is there something I can do to resolve the -1 error?

    I've tried it on FF 12 Mac and Chrome 19.0.x Mac and receive the same error message. There are no error messages in the Firebug console.

    Thanks!

  9. Kurt Payne
    Member
    Posted 1 year ago #

    Hi msartori,

    In this case, the -1 issue was traced back to file permissions.

    Please go into your FTP client and find your wp-content/uploads/profiles folder. Change the permissions on that folder so that it's writable by the web server. Here's a quick step-by-step:

    1.) Set the folder to 755, try P3. If it works, stop here. If it doesn't work, try the next step.
    2.) Set the folder to 775, try P3. If it works, stop here. If it doesn't work, try the next step.
    3.) Set the folder to 777, try P3. If it works, stop here. If it doesn't work, then folder permissions aren't the problem (and reset the permission to whatever they were originally).

  10. carolewalsh
    Member
    Posted 1 year ago #

    To Kurt & Msartori -

    I had success when I set the folder to 777. But make sure than when you're done, you change the permissions back to what they were before. Otherwise your directory is wide open to hackers.

  11. msartori
    Member
    Posted 1 year ago #

    Hi Kurt,

    I set the permissions to 777 on the folder (and used recursion) but still got the error.

    If you have any other ideas I'd love to try them because I really dig the plugin. No worries if you can't think of anything. Thanks for your help.

  12. Kurt Payne
    Member
    Posted 1 year ago #

    In your wp-contents/uploads folder, do you see a profiles folder?

    If so, do you see any *.json files in the profiles folder?

    If you go to Settings -> Media, is your "Store uploads in this folder" field empty? This is the default value.

  13. msartori
    Member
    Posted 1 year ago #

    Brilliant! The profiles folder was 755 so I changed it to 777 and everything started working.

    To answer your questions, there were json files that had copied over from the server the site was previously on. My "store uploads in this folder" value was empty.

    Thanks again for helping me solve this.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic