WordPress.org

Ready to get started?Download WordPress

Forums

P3 (Plugin Performance Profiler)
[resolved] Does this plugin work while caching plugins are running? (10 posts)

  1. Eric Rasch
    Member
    Posted 2 years ago #

    I ran this plugin on a local version of my WP install and then ran it on a live site version. The results were totally different.

    On the local version, the plugin seemed to work fine and identified the speeds & queries of the other active plugins.

    On the live site, P3 only identified itself as the offending plugin. I have WP-Super Cache running on the live site (but not the local). Is this causing the mis-reporting?

    http://wordpress.org/extend/plugins/p3-profiler/

  2. Kurt Payne
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hi Eric,

    Are you using WP Super Cache on your local site as well?

  3. Eric Rasch
    Member
    Posted 2 years ago #

    Nope. Not running it on the local.

  4. Kurt Payne
    Member
    Plugin Contributor

    Posted 2 years ago #

    Eric,

    Are you using varnish or nginx in your production environment?

    When you're looking at the profile, if you go to advanced metrics, how many visits do you see?

  5. Eric Rasch
    Member
    Posted 2 years ago #

    No, nothing like that. Just a normal LAMP stack.

    I upgraded the plugin and re-ran the test today and I'm basically getting the same results. Here's a screenshot of the P3 report (between today/yesterday after removing 1 active plugin): https://skitch.com/ericrasch/ghf76/p3-er-test

  6. Kurt Payne
    Member
    Plugin Contributor

    Posted 2 years ago #

    Eric,

    If you go to advanced metrics, how many visits do you see?

    What version of WordPress is this on?

  7. Eric Rasch
    Member
    Posted 2 years ago #

    WP v.3.3.1 and 14 visits in the Adv. Metrics.

  8. Kurt Payne
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hi Eric, I've e-mailed you about this.

  9. Kurt Payne
    Member
    Plugin Contributor

    Posted 2 years ago #

    Eric,

    After some trial and error, I've tracked this down to eaccelerator's optimizer. This is not due to WP Super Cache. Here's how to keep eaccelerator's opcode cache running and turn off the optimizer temporarily:

    If you're using mod_php (Your phpinfo page says "Apache 2.0 Handler")
    Edit your wordpress/.htaccess file and put this at the top:
    php_flag eaccelerator.optimizer 0
    Run P3, and when you're done, just remove that change.

    If you're using another handler and php 5.3 (Your phpinfo page says "CGI/FastCGI")
    Edit wordpress/.user.ini (create this file if it doesn't exist) and put this content at the top:
    eaccelerator.optimizer = 0
    Run P3, and when you're done, just remove that change. This file is cached by PHP, so it will take ~5 minutes for the optimizer to be re-enabled depending upon your system configuration.

    If you're using another handler and php 5.2 (Your phpinfo page says "CGI/FastCGI")
    If you have configure eaccelerator to include your P3's plugin folder as an admin folder, then the latest development branch can automatically disable the optimizer.
    https://eaccelerator.net/wiki/Settings (FYI: this page has an out of date security certificate)

    If you're using litespeed (Your phpinfo page says "LiteSpeed")
    Use the .htaccess instructions from above.

  10. keeleydavis
    Member
    Posted 2 years ago #

    Hello Eric, So sorry to hit you up on an unrelated topic but you seemed to be having the same issue I have been pulling my hair out over. http://wordpress.org/support/topic/custom-posts-type-with-custom-taxonomy-wp_query-1/page/2. Is there anyway you could hit me up and let me know if you figured that issue out?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic