WordPress.org

Ready to get started?Download WordPress

Forums

Ozh' Admin Drop Down Menu
[resolved] Broken with WordPress 3.3 "Sony" (13 posts)

  1. solitary1510
    Member
    Posted 2 years ago #

  2. doc4
    Member
    Posted 2 years ago #

    Recommended quick fix which should straighten out the menu being in a bit of an awkward spot. I would expect the next release will make better corrections. We are also using: add_filter('admin_notices' on line: 129 of the file: "wp_wp_ozh_adminmenu.php" as the hook. The previous hook is apparently depreciated, I wasn't aware of this either.

    The hooks in their entirety should look like this:

    if ( is_admin() ){
    	global $wp_ozh_adminmenu;
    	require_once(dirname(__FILE__).'/inc/core.php');
    	add_action('admin_init', 'wp_ozh_adminmenu_init', -1000);	// Init plugin defaults or read options
    	add_action('admin_menu', 'wp_ozh_adminmenu_add_page', -999); // Add option page
    	add_action('admin_head', 'wp_ozh_adminmenu_head', 999); // Insert CSS & JS in <head>
    	add_action('in_admin_footer', 'wp_ozh_adminmenu_footer'); // Add unobstrusive credits in footer
    	add_filter('plugin_action_links_'.plugin_basename(__FILE__), 'wp_ozh_adminmenu_plugin_actions', -10); // Add Config link to plugin list
    	add_filter('ozh_adminmenu_icon_ozh_admin_menu', 'wp_ozh_adminmenu_customicon'); // This plugin will have its own icon of course
    	add_filter('admin_notices', 'wp_ozh_adminmenu', -9999); // Add the new admin menu right after the header area. Make sure we're first.
    }

    After the hook has been changed do the following:
    1. Open file "inc/adminmenu.css"

    2. Change the following CSS styles:

    #ozhmenu_wrap {
       z-index: 43000;
       overflow: hidden;
       width: 100%;
       clear: both;
       position: relative; /* NEW */
       top: -23px; /* NEW */
       }

    3. Add the following CSS style:

    #screen-meta-links {
       position: relative;
       top: 25px;
       }
  3. doc4
    Member
    Posted 2 years ago #

    Revision to the above CSS. Take out that relative position and replace it with a negative margin:

    #ozhmenu_wrap {
       z-index: 43000;
       overflow: hidden;
       width: 100%;
       /*clear: both; REMOVED */
       margin: -1px 0 0; /* NEW */
       }
  4. solitary1510
    Member
    Posted 2 years ago #

    I updated to 3.6.2 but long list not break. I also try to fix with above way, but it isn't work :(. I'm very like plugin.

  5. doc4
    Member
    Posted 2 years ago #

    Thanks for updating so quickly Ozh. Can you add a z-index for the pop up bubbles, they're getting caught behind the new WordPress bar.

    #ozhmenu li a #awaiting-mod span, #ozhmenu li a .update-plugins span {
    	color: #444;
    	top: -0.4em;
    	<?php echo $opdir; ?>: -0.5em;
    	position: absolute;
    	display: block;
    	height: 1.3em;
    	line-height: 1.4em;
    	padding: 0 0.8em;
    	background-color: #bbb;#2583AD;
    	-moz-border-radius: 4px;
    	-khtml-border-radius: 4px;
    	-webkit-border-radius: 4px;
    	border-radius: 4px;
            z-index: 999999;
    }
  6. solitary1510
    Member
    Posted 2 years ago #

    I added but problem with long list not solve.

  7. popwireless
    Member
    Posted 2 years ago #

    I'm not a programmer so this probably won't mean much but I also noticed after 3.3 that the pop-up box to display raw data in WASSUP also broke in all of my blogs. That last time that happened it had to do with the version of a jquery file WP used. When the later file was substituted the function came back to life. I thought it was strange both of these pop up functions quit at the same time.

    I bring it up just in case it might make sense to someone that understands the knobs, dials, bells, whistles, inner workings and hidden mechanisms better than I do.

    I too prefer my OZH tool bars.

  8. doc4
    Member
    Posted 2 years ago #

    popwireless,

    What are you referring to when you say "WASSUP"?

  9. doc4
    Member
    Posted 2 years ago #

    solitary1510,

    You have adjusted the list length in the settings right? Settings > Admin Menu > Break Long Lists

  10. popwireless
    Member
    Posted 2 years ago #

    The plugin Wassup. The fix there was to change a line in thickbox.css. I'm still using the OZH bar because the side menus drive me crazy. I cope with the settings menu issue. ;)

  11. Ozh
    Member
    Plugin Author

    Posted 2 years ago #

    .

  12. popwireless
    Member
    Posted 2 years ago #

    My break has always been set at 10. It doesn't, hasn't, doesn't look like it will ever break again. It is not resolved.

  13. popwireless
    Member
    Posted 2 years ago #

    Not resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic