WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Our Progress] Fails to save settings on 3.0 (12 posts)

  1. Every time I tried to save settings, it blew up on fopen(ourprogresssettings.txt)

    Also, shortcodes would be AWESOME for this instead of demanding people use PHP in their posts, which I don't want to activate on MU :)

    http://wordpress.org/extend/plugins/fundraising-thermometer-plugin-for-wordpress/

  2. To create shortcodes, add this to ourprogress.php:

    add_shortcode('show_ourprogress','show_ourprogress');
    add_shortcode('show_ourprogress_graphic','show_ourprogress_graphic');

    Then you can use [show_ourprogress] and [show_ourprogress_graphic]

    Fixing the ourprogresssettings.txt issue is to edit line 45 from
    $myFile = "ourprogresssettings.txt";
    to
    $myFile = "../ourprogresssettings.txt";

    And then put a file ourprogresssettings.txt in the same folder as your wp-config.php file.

    At this rate, I may end up forking this to use the database instead of a text file.

  3. christopherross
    Member
    Posted 4 years ago #

    Ipstenu, thanks! I'm not able to replicate this on either on my test servers but I've see the error before.

    I'm in the process of removing the settings file altogether and should have it fixed up by the 1.0 release.

    I've included the shortcodes in the 0.6.7 update, thanks.

  4. _jordy_
    Member
    Posted 3 years ago #

    Hi.

    Your plugin is great and the only one in its kind. I just updated to 0.7.0 and now I can't update te settings anymore. I tried to follow the instructions above, but I can't find any $myFile refference.

    Please help! Our fundraising is running right now, so I would love to give visitors of our site an insight in what's going on.

    Thanks in advance.

  5. Ryguy3499
    Member
    Posted 3 years ago #

    I'm having the same problem. Would love some help!

  6. christopherross
    Member
    Posted 3 years ago #

    Sorry guys, I tried to fix one problem and created another. My bad.

    I've tested the 0.7.1 update and just uploaded a new version for you. If there is a problem, please let me know right away.

    Chris

  7. Ryguy3499
    Member
    Posted 3 years ago #

    thanks ... that fixed it. What is the default text for the "Currency Format" field?

  8. Ryguy3499
    Member
    Posted 3 years ago #

    nevermind ... figured it all out. Just going to change the background colour, centre it and it'll look great.

  9. Ryguy3499
    Member
    Posted 3 years ago #

    okay ... so the amounts will save, but the style will always convert back to the default colour.

    Any thoughts?

  10. _jordy_
    Member
    Posted 3 years ago #

    Thanks for the fast response! It solved the problem for mee. Keep up the good work.

  11. christopherross
    Member
    Posted 3 years ago #

    @Ryguy3499 I'm taking a look right now and will see if I can work it out today for you.

  12. mclanea
    Member
    Posted 3 years ago #

    @Ipstenu

    Thanks for this fix. I couldn't figure out where to stick that txt file.

    @christopherross- Thanks for the plugin. I'm looking forward to an update. :)

Topic Closed

This topic has been closed to new replies.

About this Topic