WordPress.org

Ready to get started?Download WordPress

Forums

Plugin Organizer
[resolved] Plugin organizer not working with s2member (9 posts)

  1. Deyson
    Member
    Posted 1 year ago #

    Hello and thank you for such a great plugin.

    I have been using plugin organizer nicely with s2members, but after the last update to plugin organizer my s2members plugin stopped working when my members had to download.

    It also seems others are having the similar trouble and s2member requested that we speak to the developer of plugin organizer.

    Here is the link to another user of s2member having trouble: http://www.s2member.com/forums/topic/mebership-level-doesnt-upgrade-automatically/

    Thank you very much for your time.

    http://wordpress.org/extend/plugins/plugin-organizer/

  2. Jeff Sterup
    Member
    Plugin Author

    Posted 1 year ago #

    I'm having a hard time understanding the problem from that post. Can you give me a better explanation of the problem? I'm also running s2members on a few sites so I will probably be able to track it down. Example urls and any javascript or php errors you are seeing would be helpful.

  3. Deyson
    Member
    Posted 1 year ago #

    Thank you for the quick response.
    When I activate your plugin members are not able to download the protected content. When they click on a download instead of starting the download it redirects them to another page.

    For example if they click on the download Lap_Open.dmg it instead redirects them to http://motion-master-templates.com/?s2member_file_download=Laptop_Open.dmg
    Without the download happening.

  4. Deyson
    Member
    Posted 1 year ago #

    It even happens if a person is not logged in I just discovered, so if you go here:
    http://motion-master-templates.com/category/all-templates

    And click on any of the non-free thumbnails and then click on member download it should re-direct you to the join page but it instead redirects to /?s2member_file_download=product.dmg

  5. Deyson
    Member
    Posted 1 year ago #

    Please let me know when you have viewed it so I can disable it, so my members can download. Thank you :)

  6. Jeff Sterup
    Member
    Plugin Author

    Posted 1 year ago #

    I have just released version 2.3.3. This should fix your issue. I think it is because of an update I made to the logic around the request URI in version 2.3.1. Please install this version and let me know if it fixes your issue.

  7. Deyson
    Member
    Posted 1 year ago #

    YEA!!! That did it. Thank you very much!

    Have an awesome and beautiful day! :)

  8. Jeff Sterup
    Member
    Plugin Author

    Posted 1 year ago #

    No problem. If you like the plugin please give it a star rating on the plugin page.

  9. Deyson
    Member
    Posted 1 year ago #

    I shall and I will :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags