WordPress.org

Ready to get started?Download WordPress

Forums

oQey Gallery
[resolved] [Plugin: oQey-Gallery] Error installation on wp 3.1 rc 3 (21 posts)

  1. abmcr
    Member
    Posted 3 years ago #

    When i try install i get an error

    Fatal error: Class 'ZipArchive' not found in /Applications/MAMP/htdocs/wptrunk/wp-content/plugins/oqey-gallery/oqeygallery.php on line 56

    http://wordpress.org/extend/plugins/oqey-gallery/

  2. guillermogoya
    Member
    Posted 3 years ago #

    Yes me too

  3. Piet305
    Member
    Posted 3 years ago #

    Yep, me too!
    "Fatal error: Class 'ZipArchive' not found in /Applications/MAMP/htdocs/wordpress/wp-content/plugins/oqey-gallery/oqeygallery.php on line 56"

    please fix it. I look forward to trying it.

  4. cissdm
    Member
    Posted 3 years ago #

    Guys, you all have same problem... your server is not configured to use Zip archiver with ZipArchive class... you can fix this by contacting your server admin.

  5. oQeySites
    Member
    Plugin Author

    Posted 3 years ago #

    oQey, please don't worry ab. that. We have an update coming up, which is meant to solve this issue for everyone that had troubles installing ZipArchive...
    Please, be patient, the update will be released within a few hours.
    Thank you!

  6. kookamonga
    Member
    Posted 3 years ago #

    Is .4 the version that will fix this? I just installed .4 and get the same error. This thread says resolved so I'm not sure.

  7. John
    Member
    Posted 3 years ago #

    The update should be .4.1. Send 'em an email or twitter to request beta version. They r still working on that... I've got .4.1 last night, it works awesome!

  8. melanie bund
    Member
    Posted 3 years ago #

    have 4.1 and get - Plugin could not be activated because it triggered a fatal error

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/15/d244336518/htdocs/wordpress/wp-content/plugins/oqey-gallery/oqey-functions.php on line 82

  9. kookamonga
    Member
    Posted 3 years ago #

    i can't find 4.1 anywhere and am not really comfortable asking the developer for an advance copy.

  10. oqeysites
    Member
    Plugin Author

    Posted 3 years ago #

    Please, reinstall your photo galleries with the current 0.4 version from http://wordpress.org/ We have updated it, but didn't upgrade to 0.4.1 yet. We are still adding some new features which require some time to be properly tested. Thank you.

  11. oqeysites
    Member
    Plugin Author

    Posted 3 years ago #

    P.S.: Please make sure your server runs php5 before reporting any "bugs".

  12. melanie bund
    Member
    Posted 3 years ago #

    My server 1and1 runs php 5. have reinstalled oQey-Gallery 0.4 - get same message

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/15/d244336518/htdocs/wordpress/wp-content/plugins/oqey-gallery/oqey-functions.php on line 82

    Any ideas?

  13. oqeysites
    Member
    Plugin Author

    Posted 3 years ago #

    Melanie, that is coming from PHP 4. You have to install php 5.2 to make oQey Gallery run on your wordpress. If you don't know how to do that, send us an e-mail.

  14. science_music
    Member
    Posted 3 years ago #

    using 1and1, how do you update PHP?

  15. oQeySites
    Member
    Plugin Author

    Posted 3 years ago #

    In your .htaccess file, add the following line:
    AddType x-mapp-php5 .php

    This should solve the issue with your server configuration.

  16. melanie bund
    Member
    Posted 3 years ago #

    hi thanks for the question - i dont have a .htaccess file within wordpress - could this be why the slideshow does not work?

  17. oqeysites
    Member
    Plugin Author

    Posted 3 years ago #

    This file can be created manually. Use notepad or any simple text editor, save it as a text file and just rename it after.

  18. Emmti
    Member
    Posted 2 years ago #

    I'm having a problem with the oqey gallery. I Have installed the plugin, and everything seems to work fine until I upload images, which I manage fine, it registers the image and adds it to the gallery, but the thumbnail is blank, and I keep getting this error: Error creating the gallery folder (might be a server restrictions issue). Please create this folder manually (wp-content/oqey_gallery/galleries/privathus) and set permissions to 755.

    My server runs Php 5, so that shouldn't be the problem. But in the error message it says I need to create the folder manually, however it refers to the wrong folder, as I have installed the plugin in the plugins folder (wp-content/plugins/oquey_gallery) and not directly in the wp-content folder...

    Any ideas on what has gone wrong here?

  19. WaldenPondDesign
    Member
    Posted 2 years ago #

    Emmti,
    Did you ever get it work. I am getting the EXACT same error message.

    Andrew

  20. melanie bund
    Member
    Posted 2 years ago #

    Sort of i created a ".htaccess" file in notepad with text "AddType x-mapp-php5 .php", and uploaded - stopped the error messages but its still giving me probs as thumbnails wont show...

  21. me912345
    Member
    Posted 2 years ago #

    Also keep getting this message when creating a gallery:

    Error creating the gallery folder (might be a server restrictions issue). Please create this folder manually (wp-content/oqey_gallery/galleries/privathus) and set permissions to 755.

    Do I need to create this .htaccess file and where do I need to put it?

    Thanks Gilles

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic