WordPress.org

Ready to get started?Download WordPress

Forums

OptionTree
Theme options not accessible anymore after Option Tree update (53 posts)

  1. jorishol
    Member
    Posted 2 years ago #

    Hi,

    I'm using WordPress 3.4.1, with GraphPaperpress's Widescreen theme. I've just updated to Option Tree 2.0.3.

    After this update the "Theme Options" under "Appearance" (where the Option Tree options reside) does not open properly anymore. The options for Fonts, Custom CSS, and Slideshow are inaccessible (there seems to be no link under them), and the General option (which is the landing page, so it's open when I access the Theme Options) is garbled.

    I've not changed anything but this Option Tree update.

    Other active plugins are "HumansNotBots" v3.1 and "WP Google Fonts" v2.7

    Is there any way to downgrade to the previous Option Tree version?
    Or is there a solution for this problem?

    Kind regards,
    Joris

    http://wordpress.org/extend/plugins/option-tree/

  2. fewixree
    Member
    Posted 2 years ago #

    Hi

    I'm having problem with the latest update of OptionTree as well (2.0.3). I'm using WordPress 3.4.1 and the theme I'm using is MiniFolio By designmd.

    I've been working on the website all week and going so well, as soon as I updated OptionTree the whole site broke.

    http://lydiaphillips.com.au/staging/

    All the settings are still in OptionTree, but they don't work anymore. Slider images disappeared, logo is back to the default logo, css styles are all gone.

    I have also tried doing a clean install of WordPress in a seperate folder in my root that were suppose to be there for that theme are not showing up.

    I wanted to try downgrading OptionTree but I can't find an older version anywhere.

    Please can someone show me the way to fix this?

    Regards

    Felix

  3. Breece
    Member
    Posted 2 years ago #

    I'm having the same troubles with Option Tree 2.0.3 on my site http://pillarandpost.com.au

    This is very disappointing, as my Highrise Theme from ThemeForest is entirely reliant on this plugin.

  4. Carine77
    Member
    Posted 2 years ago #

    I'm having the same trouble since I just downloaded the new version of Option Tree. I think there's a problem with the new version, please tell us what to do. Or how downgrading Option Tree

    Thank You

  5. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    I'm fixing this now, I found the problem and it's being patched immediately. The issue is that the old data has slashes in it and has not been ran through validation, v2.0.4 fixes this it will be available shortly.

  6. Breece
    Member
    Posted 2 years ago #

    Good man, thank you Derek

  7. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    It's been patched and 2.0.4 is available for download. Unfortunately, it only works when you first activate the plugin or include it in your theme and the 'option_tree_settings' array has not yet been created. So this may not help you unless you have access to your phpMyAdmin and can delete that option from the wp_options table. It should however help people who have not yet upgraded. I apologize to you for the issue, I told the authors to test the plugin and I only got a handful of people to submit issue on github. I wish they had been more active as it would have saved people like you from having this issue.

  8. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    For those of you wanting to downgrade you can download the 1.1.8.1 version here http://downloads.wordpress.org/plugin/option-tree.1.1.8.1.zip

  9. Carine77
    Member
    Posted 2 years ago #

    Thank you for your help. I just downloaded the previous version. And now my blog is like it was after the upgrated. But now I can't insert my logo. Is it normal ?

  10. Carine77
    Member
    Posted 2 years ago #

    Sorry ! I would like to say that my blog is like it was before the upgrated ...

  11. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    So you are getting good results other than the fact you can't upload or insert your logo?

  12. Carine77
    Member
    Posted 2 years ago #

    Yes

  13. hpp
    Member
    Posted 2 years ago #

    Derek, once downloaded how do i upload the older version replacing the newer version that doesn't work?

  14. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    You need to use ftp.

  15. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    @Carine77 Yes to upload or insert? They are two different things. Also send me login access to your site derek[at]valendesigns.com and I'll take a look.

  16. Carine77
    Member
    Posted 2 years ago #

    Thank you, I just sent you a mail

  17. garramey
    Member
    Posted 2 years ago #

    Hi
    I've installed the updates for optiontree (using with Cudazi Mono)and lost my logo and the ability to change settings (logo, colors). I've ftp and activated version 1.1.8.1 but am still having the same problem. Says changes have been saved but not displaying on site.

    Is this the same issue?

  18. karenchia
    Member
    Posted 2 years ago #

    Hi ,

    I have access to phpadmin which row am I suppose to delete? I cannot locate the option that you mentioned? what line am I suppose to delete?

    wp-option table only have option_id, option_name, option_value and autoload or am I to drop the whole wp-options table?

    I am using 2.0.4

  19. garramey
    Member
    Posted 2 years ago #

    Downloaded 2.0.5 and still not working with Cudazi Mono. Is this now an issue with the theme compatibility rather than the plugin itself?

  20. karenchia
    Member
    Posted 2 years ago #

    tried to use 2.0.5 and also tried the 'option_tree_settings' delete not working.. what's the sequence in doing so?

  21. gatorfantom
    Member
    Posted 2 years ago #

    Upgraded to 2.0.5 and getting the same problem (all the settings under Appearance > Theme Options are being ignored.)

    Derek - just an FYI in case it helps troubleshoot --- I'm also seeing a yellow notice at the top of the admin screens that reads:

    "Wait! You need to install and activate the OptionTree plugin! (See Help Files)"

    Can you give a little more information about the PHPMyAdmin workaround? (From what I can gather, this is the only way to fix it if we've already upgraded to 2.0.5.?)

    Thanks for you quick troubleshooting on this.

  22. karenchia
    Member
    Posted 2 years ago #

    Please check the theme options and settings too something is not right...

    I tried to delete the rows related to options settings, activation from the WP-options table as well as dropping the option tree table. Delete the plugin... to emulate fresh install.

    Which process is suppose to create the Option_tree table?

    Because I realise that when I import the "settings" data it deleted my theme's options...

  23. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    For people using any Cudazi themes, there is a code compatibility issue with what I assume is all their themes. I'm not exactly sure what's causing this yet but I'm looking into it. So far I've gleaned some insight into the problems but for now downgrade to 1.1.8.1 and hold off on upgrading until I know it will work or the author decides to update their themes.

    http://downloads.wordpress.org/plugin/option-tree.1.1.8.1.zip

  24. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    @gatorfantom the yellow notice is one authors implementation of the old OT and whatever function or class they were testing for no longer exists so the notice will not go away until they update their code.

  25. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    @karenchia you were not suppose to delete the wp_option_tree table that is were the plugin would have gotten your settings from when you upgrade. If you have an XML settings file that came with your theme you can import that.

    Also when you deleted the 'option_tree' and 'option_tree_settings' options from the DB you basically set everything back to zero.

  26. fewixree
    Member
    Posted 2 years ago #

    Thanks Derek

    Everything is back to normal now for me after I downgrade it back to 1.1.8.1

    Cheers

  27. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    @fewixree I'm working on figuring out the theme compatibility issues. When I know more I'll update this post.

  28. wafcross
    Member
    Posted 2 years ago #

    Derek! I desperately need your help!

    The latest updates to your plugin do not allow you to have more than 100 options in your options tree.

    I have lost a huge number of options and its breaking a lot of functionality on my site :/

  29. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    @wafcross Weird, I've not imposed an arbitrary 100 option limit so I don't know why that would be the case other than your DB is limiting the amount of characters you can save in an single option inside the wp_options table. Can you send the XML export from 1.1.8.1 so I can import it to a local install and see what's happening? derek[at]valendesigns.com

    Also, WOW! Why do you have 100+ options? That doesn't sound a bit excessive to you? No theme should have that many options IMHO. It's just making it hard for users to setup, they don't want to do that much work to setup a theme.

  30. gatorfantom
    Member
    Posted 2 years ago #

    Thanks for the update Derek.

    Just to confirm, is there a certain protocol for downgrading -- or is it safe to just delete OT v2.0.5 (in admin > Plugins page) and then reinstall OT v1.1.8.1?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic