WordPress.org

Ready to get started?Download WordPress

Forums

OptionTree
After upload plugin, could not activate (7 posts)

  1. MyCelestial
    Member
    Posted 2 years ago #

    Hi Derek,

    I tried several times for trying activating this plugin, but do not know why it failed all the time.

    I tried 1.1.4, 1.1.5, 1.1.6 and after activate, the content of the Documentation, Theme Options and Settings all went blank, there was nothing I could do.

    I tried 1.1.7 and 1.1.8 and it said the following fatal errors when I tried to activate it:

    Could you help me on them, thanks so much!!!!

    Warning: require_once(/services/webpages/h/a/hangsuite7739.site.aplus.net/public/wp/wordpress-content/plugins/services2/webpages/util/h/a/hangsuite7739.site.aplus.net/public/wp/wordpress-content/plugins/option-tree/functions/functions.load.php) [function.require-once]: failed to open stream: No such file or directory in /services2/webpages/util/h/a/hangsuite7739.site.aplus.net/public/wp/wordpress-content/plugins/option-tree/index.php on line 26

    Warning: require_once(/services/webpages/h/a/hangsuite7739.site.aplus.net/public/wp/wordpress-content/plugins/services2/webpages/util/h/a/hangsuite7739.site.aplus.net/public/wp/wordpress-content/plugins/option-tree/functions/functions.load.php) [function.require-once]: failed to open stream: No such file or directory in /services2/webpages/util/h/a/hangsuite7739.site.aplus.net/public/wp/wordpress-content/plugins/option-tree/index.php on line 26

    Fatal error: require_once() [function.require]: Failed opening required '/services/webpages/h/a/hangsuite7739.site.aplus.net/public/wp/wordpress-content/plugins/services2/webpages/util/h/a/hangsuite7739.site.aplus.net/public/wp/wordpress-content/plugins/option-tree/functions/functions.load.php' (include_path='.') in /services2/webpages/util/h/a/hangsuite7739.site.aplus.net/public/wp/wordpress-content/plugins/option-tree/index.php on line 26

    http://wordpress.org/extend/plugins/option-tree/

  2. Derek Herman
    Member
    Plugin Author

    Posted 2 years ago #

    That file exists, you may want to download a clean copy of the latest version and activate it. If you can't see the documentation, go to Users->Your Profile and check "Show Settings & Docs".

  3. MyCelestial
    Member
    Posted 2 years ago #

    No... it still does not work. I don't know why now..

  4. therogermag
    Member
    Posted 2 years ago #

    Derek,
    Having the same issue and my hosting/domain provider will not help me. I am trying to install the Reaction theme from Themeforst and when I try to activate OptionTree I get the following fatal error:

    Warning: require_once(/services/webpages/t/h/therogermag.com/public/WP/wordpress-content/plugins/services5/webpages/util/b/a/baggio.site.aplus.net/therogermag.com/public/WP/wordpress-content/plugins/option-tree/functions/functions.load.php) [function.require-once]: failed to open stream: No such file or directory in /services5/webpages/util/b/a/baggio.site.aplus.net/therogermag.com/public/WP/wordpress-content/plugins/option-tree/index.php on line 26

    Warning: require_once(/services/webpages/t/h/therogermag.com/public/WP/wordpress-content/plugins/services5/webpages/util/b/a/baggio.site.aplus.net/therogermag.com/public/WP/wordpress-content/plugins/option-tree/functions/functions.load.php) [function.require-once]: failed to open stream: No such file or directory in /services5/webpages/util/b/a/baggio.site.aplus.net/therogermag.com/public/WP/wordpress-content/plugins/option-tree/index.php on line 26

    Fatal error: require_once() [function.require]: Failed opening required '/services/webpages/t/h/therogermag.com/public/WP/wordpress-content/plugins/services5/webpages/util/b/a/baggio.site.aplus.net/therogermag.com/public/WP/wordpress-content/plugins/option-tree/functions/functions.load.php' (include_path='.') in /services5/webpages/util/b/a/baggio.site.aplus.net/therogermag.com/public/WP/wordpress-content/plugins/option-tree/index.php on line 26

  5. benjibuls
    Member
    Posted 2 years ago #

    Hi Derek,
    I'm having the same error above on a fresh copy of WordPress 3.3.1
    I've tried re-installing a fresh copy after deleting the plugin from both the "Install Plugins" tool inside wordpress and manually downloading the ZIP from wordpress.org, neither worked. Any ideas why this would be?

  6. benjibuls
    Member
    Posted 2 years ago #

    Have discovered the issue, the plugin is using an old method to define the plugin directory and url global vars. In the plugin index on line 18 & 19 change the following:

    Replace:

    define( 'OT_PLUGIN_DIR', WP_PLUGIN_DIR . '/' . dirname( plugin_basename( __FILE__ ) ) );
    define( 'OT_PLUGIN_URL', WP_PLUGIN_URL . '/' . dirname( plugin_basename( __FILE__ ) ) );

    With:

    define( 'OT_PLUGIN_URL', plugins_url( '', __FILE__ ) );
    define( 'OT_PLUGIN_DIR', plugin_dir_path( __FILE__ ) );

    And then the plugin behaves. I guess wordpress have finally deprecated the old methods.

  7. benjibuls
    Member
    Posted 2 years ago #

    OK, so good and bad news...

    Good news
    The plugin doesn't cause a fatal error when activating now.

    Bad news
    It doesn't work properly as none of the settings changed within an OptionTree based theme stick. Nothing gets saved.

    Any help would be greatly appreciated, or I may have to discontinue using OptionTree all together, sigh.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic