WordPress.org

Ready to get started?Download WordPress

Forums

Optimize Database after Deleting Revisions
[resolved] $Tables_in_DB_NAME?> => Msg_text?> (10 posts)

  1. axedesign
    Member
    Posted 2 years ago #

    I get this error when using the plugin:

    $Tables_in_DB_NAME?> => Msg_text?>

    http://wordpress.org/extend/plugins/rvg-optimize-database/

  2. cageehv
    Member
    Plugin Author

    Posted 2 years ago #

    Hey axedesign!

    Weird... does you database tables have strange names with strange ASCII characters in it?

    Which version of WP are you using?

    Rolf

  3. cageehv
    Member
    Plugin Author

    Posted 2 years ago #

    And, did you try to reinstall the plugin?
    Maybe it got corrupted in some way.

    Rolf

  4. axedesign
    Member
    Posted 2 years ago #

    Running WP 3.3.2 and my database has a "normal" name... I tried reinstalling the plugin and I still get the same message.

    I think it does delete the revisions but I'm not sure whether it's optimizing the DB or not.

    My site is hosted on an Amazon EC2 instance, could that be causing the issue somehow?

  5. cageehv
    Member
    Plugin Author

    Posted 2 years ago #

    Hey axedesign!

    I think I found the problem...
    The PHP installation on your server is probably not using 'short_open_tag's
    (short_open_tag = Off in php.ini)
    I just released versie 1.0.4 of my plugin and I hope that fixes your problem.
    Please let me know if it did!

    peace,
    Rolf

  6. axedesign
    Member
    Posted 2 years ago #

    Yes I just saw your update, I tried again and now see this:

    => Table does not support optimize, doing recreate + analyze instead

    So it looks like it's a server issue on my end.

    Thanks and great plugin!

  7. cageehv
    Member
    Plugin Author

    Posted 2 years ago #

    Cool!

    Thanks for helping me to improve the plugin and thanks for the kudo's ;-)

    peace,
    Rolf

  8. axedesign
    Member
    Posted 2 years ago #

    Well, I set short_open_tag = On (and restarted httpd) and the plugin still gives the same message it did earlier. Any ideas or other settings I should change?

  9. cageehv
    Member
    Plugin Author

    Posted 2 years ago #

    The table giving that msg is probably an 'innoDB' table (instead of 'MyISAM').
    innoDB tables cannot be optimized using the standard MySQL method.

    Hope that helps!

  10. axedesign
    Member
    Posted 2 years ago #

    I am using innoDB so that explains it. Thanks again for the great plugin and support!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.