WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: OpenID] Cannot Login (5 posts)

  1. dee
    Member
    Posted 5 years ago #

    What steps will reproduce the problem?

    1. Visit http://beta.void-star.net/wp-login.php
    2. Log in with another OpenID provider.
    3. Redirects to provider site, asks for confirmation.
    4. Returns to site, error message: OpenIDloginfailed:Serverdeniedcheck_authentication.

    The same occurs when attempting to post comments with an OpenID or associate OpenIDs with user accounts.

    What is the expected output? What do you see instead?
    I expect to be able to authenticate with an OpenID provider, however the process fails with the error OpenIDloginfailed:Serverdeniedcheck_authentication.

    What version of the product are you using? On what operating system?

    [INFO] PHP version: 5.2.5
    [INFO] PHP memory limit: 32M
    [INFO] Include Path:

    * /home/xxxxxx/public_html/beta/wp-admin
    * /usr/lib/php
    * /usr/local/lib/php

    [INFO] WordPress version: 2.7.1
    [INFO] PHP OpenID Library Version: 2.1.2
    [INFO] MySQL version: 5.0.51a
    [INFO] WordPress' table prefix: xxxx_
    [OK] Curl Support: Version 7.18.1. SSL: OpenSSL/0.9.7a. zlib: 1.2.3. Supports: tftp, ftp, telnet, dict, ldap, http, file, https, ftps.
    [OK] Big Integer support: BCMath is installed (though GMP is preferred).
    [INFO] Plugin Revision: 519
    [INFO] Plugin Database Revision: 24426
    [INFO] XRDS-Simple: XRDS-Simple plugin is installed.
    [OK] Overall Plugin Status

    Please provide any additional information below.
    The workaround detailed here does not help.

    I've also successfully used the plugin on a standalone, local install of WordPress, while it fails on other domains hosted on the same provider as void-star.net (Surpass Hosting).

    I was originally blocking all requests made with empty browser agents via .htaccess (the error logs were throwing 403s on the verification check), however this has now been removed and the Apache logs look "normal".

    Downgrading to the previous version of the plugin didn't help, nor has uninstalling it, clearing the cache, et cetera.

    Authentication against a LiveJournal OpenID worked once, however I've never been able to replicate the behaviour.

    Any and all assistance is appreciated.

    http://wordpress.org/extend/plugins/openid/

  2. Jehy
    Member
    Posted 5 years ago #

    Try this.

  3. dee
    Member
    Posted 5 years ago #

    Nope. :(

    If I understand what's going on correctly, that fix is for the server rather than the consumer. My issue is, I think, with the consumer constantly failing even though it's getting return data back from the various servers it's hitting up.

  4. dee
    Member
    Posted 5 years ago #

    This problem is still driving me nuts, but I've found two more things.

    #1. Dumping the variables from _httpResponseToMessage in Consumer.php shows that it seems to run twice per OpenID request. The first returns a body with assoc_handle and so forth, the second returns with a body of error:bad_handle.

    #2. Enabling WP_DEBUG throws a bunch of "MySQL server has gone away" errors during the calls to update openid_idnetities and openid_associations!

    Hrm...

  5. dee
    Member
    Posted 5 years ago #

    Whee, double-post.

    Anyway, I think I've tracked it down to being a problem with the BCMath library used for session_type:DH-SHA1. The workaround is forcing the script to run in "dumb mode" by changing lines 106-108 in OpenID.php to:

    //if (Auth_OpenID_getMathLib() === null) {
      Auth_OpenID_setNoMathSupport();
    //}

    I still have no idea how or why this causes/fixes the issue (and it's kinda more of a problem with the PHP OpenID library than the plugin), but... yeah.

    At least I can log in now.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags