WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] Plugin only works on homepage and no where else (4 posts)

  1. nkorni1
    Member
    Posted 1 year ago #

    Hi Everyone

    I'm using the wordpress twenty-ten theme and I've installed the Google language translator plugin (pasted code on sidebar widget) and while it works on the homepage, it doesn't work anywhere else on the blog. In fact it only shows on the homepage. And as soon as you click on a blog title the translation disappears and reverts back to the English language.

    Is there anyway to keep the plugin working after one clicks on the blog? I've read all the threads and it seems someone had the same issue but they were using another theme and were advised to place the code under php.header. When I tried following that advice with the twenty-ten theme it still didn't work. Any help will be greatly appreciated here is my blog.

    http://www.nkornitankwa.com/

    http://wordpress.org/plugins/google-language-translator/

  2. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi nkorni1,

    Thanks for your message friend! I see that there is no translator code showing at all on your regular pages, even though it's placed in the sidebar - interesting. There could be some type of condition that only allows the translator to show on the homepage sidebar, and I would need to see for myself to help you.

    If you can create an administrator login and provide access to your site, I will help you fix this quickly. You can contact me first on this page here if you want to discuss:

    http://www.studio88design.com/get-in-touch/

    I have been helping others as well with good results. Thanks!

  3. nkorni1
    Member
    Posted 1 year ago #

    Thanks for getting back to me, the seem to be some kind of delay responds, not being technically savvy, I'm not sure if the issue is the twenty-ten theme or the plugin but when I posted the problem, the plugin was only working on the homepage but now it works on every page except the "books" and "contact me" pages...also I noticed that, while it translate recent posts, it doesn't translate the older posts. Please send me an email so I can create an admin login for you...

  4. nkorni1
    Member
    Posted 1 year ago #

    Hi M2773, I figured out that the reason it wasn't working on every page was due to my cache plugin which I was suppose to disable before installing the translating pluging. Everything now works perfectly...thanks again for responding...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic