WordPress.org

Ready to get started?Download WordPress

Forums

Online Backup for WordPress
SSL3_GET_SERVER_CERTIFICATE:certificate verify failed (2 posts)

  1. creativegb
    Member
    Posted 2 years ago #

    Error while trying online backup to 100MB space (courtesy: Backup Technology):
    <<The following error(s) occurred: http_request_failed
    SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed>>

    I contacted my server host, it says: “We do not support 3rd party applications.”

    Approached the architect of the backup-plugin, and was advised to post the Query here.

    I did some online research and found that similar Error had occurred in respect of another plugin -- whose architect advised all its users:
    Please try changing line 40 of the gcalendar-wrapper.php from this:-

    $result = $request->request($calUrl);

    to this:-

    $result = $request->request($calUrl, array('sslverify' => false));

    And its users reported that it works! Chivalrous Volunteers required to document as to which file(s) of wpbackupplugin should be modified and precise details of the workable modification, please!

    http://wordpress.org/extend/plugins/wponlinebackup/

  2. Online Backup
    Member
    Plugin Author

    Posted 2 years ago #

    Hi creativegb,

    Information on this can be found on our FAQ here:
    https://wordpress.backup-technology.com/FAQ#sslcert

    Here is what it says to save you looking:

    This error occurs because the web server that WordPress is running on was unable to validate our backup vault server. Security features in place mean that if the web server is not sure the backup vault server it is talking to is actually Backup Technology's backup server, it will not send the backup data.

    So far, we have discovered two reasons why this error may occur. The first is that somebody is trying to intercept the backup data, and is pretending to be our backup server. The other is that the web server is extremely out-of-date and does not have the means to validate server identities - the information required to do this changes gradually over a period of years and if a server does not update this information for several years it can cause problems.

    In both cases, you should contact your web host for help with this, as the error is returned from their server when we attempt to contact https://wordpress.backup-technology.com/ from within the plugin.

    However, in the latter case, it has been known for web hosts to be unhelpful, unwilling or just unaware of the issue and not fix it. Some users have switched providers in this instance. If you are still stuck with the issue and cannot switch, feel free to contact us through our support channels (visit our website for details.)

    If you absolutely need to disable this security, you can use the following instructions. But please do remember that this makes the backup communication insecure and vulnerable to man-in-the-middle attacks - and just remember even if you have your backups encrypted before transmission - it is still less secure than if the server problem is fixed so that it can establish secure transfer.

    Please go to General Settings in the plugin.
    Then in the address bar of your browser, edit the address so that it ends in "section=advanced" instead of "section=settings".

    This will open the advanced settings page - best to leave everything here alone as the plugin handles it all and it is just for fixing rare issues. Actually modifying things here can break things.

    On here you see at the bottom the option to disable SSL verification, ignore_ssl_cert. You will need to TICK the box next to this option, and then choose Yes. The checkbox enables the override and then you choose what to override it with.

    Hope this helps,

    Jason

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic