WordPress.org

Ready to get started?Download WordPress

Forums

Online Backup for WordPress
[resolved] Schedule is not working (17 posts)

  1. zfed
    Member
    Posted 3 years ago #

    hi there, after plugin update daily Schedule via e-mail is not working.
    +I got msg;
    Warning: realpath() [function.realpath]: open_basedir restriction in effect. File(/usr/var/tmp) is not within the allowed path(s): (/home/ogsiste/domains/autoaudio.lv/public_html/:/usr/local/lib/php/:/home/tmp/) in /usr/home/ogsiste/domains/autoaudio.lv/public_html/wp/wp-content/plugins/wponlinebackup/wponlinebackup.php on line 907

    how to solve this?!
    thanks

    http://wordpress.org/extend/plugins/wponlinebackup/

  2. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi zfed,

    Go to the plugin General Settings, then in your address bar, at the end of the URL where it says "section=settings", change this to "section=advanced", then hit enter.

    Should load the advanced settings. Then next to gzip_tmp_dir, click the checkbox, and change the value to /home/tmp and then click Save Settings.

    This should work! Basically the plugin is trying to automatically pick the path, but at the moment the order it checks certain places isn't the best - so its found the system one, and thought it could use it, but obviously not! Going to be fixed in next version.

    Jason

  3. zfed
    Member
    Posted 3 years ago #

    ok, thanks. I'll try it tomorrow. +if I'm doing manual backup it is not sending db to email (@gmail.com). ok, waiting for next version. thanks!

  4. zfed
    Member
    Posted 3 years ago #

    I still have the same warning msg. I think I'll wait for new version.. if it is not possible to roll back to previous version. thanks

  5. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi zfed,

    The error message should be different if you applied the above change, as the code that produces that error no longer runs.

    Can you double check you ticked the checkbox when editing the value? And post the new error if there is one?

    Jason.

  6. zfed
    Member
    Posted 3 years ago #

    error msg:
    Warning: realpath() [function.realpath]: open_basedir restriction in effect. File(/usr/var/tmp) is not within the allowed path(s): (/home/ogsiste/domains/autoaudio.lv/public_html/:/usr/local/lib/php/:/home/tmp/) in /usr/home/ogsiste/domains/autoaudio.lv/public_html/wp/wp-content/plugins/wponlinebackup/wponlinebackup.php on line 907
    I think it's the same.. line 907.

    here is screenshot of advanced ettings:
    pic

  7. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi zfed,

    We've found the problem - conflicting with the open_basedir restriction. Fixing it in next version.

    I assume this message appears on the dashboard?

    For the failing backups, can you go to Activity Log and provide a snapshot of that screen?
    Also, can you click View Events on one of the failed backups in the Activity Log screen, and provide a snapshot of that?

    You can email to support at backup-technology.co.uk if you don't wish to post a link.

    Jason.

  8. zfed
    Member
    Posted 3 years ago #

    Hi, Jason!

    Yes, message comes up in dashboard when I enter in plugin's settings.

    here are snaps:

    http://www.bildites.lv/images/d4gbsq7szlf75ihb4b0.jpg

    http://www.bildites.lv/images/3f09i3cyav8q72d846r.jpg

    http://www.bildites.lv/images/cvdfscy7djc8v18naqto.jpg

    + on august 6th I did not receive back up email (with db only). I checked spam folder as well. but in event log you can see that mesg was sent.

  9. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi zfed,

    I presume you managed to fix the Failed backups by creating the full directory? Everything successful for the past week or so.

    Not sure why the email didn't receive. We pass it through phpMailer and it tells us the email sent OK so not much to go on here. On the other successful backups did you receive an email?

    Jason.

  10. zfed
    Member
    Posted 3 years ago #

    Hi, Jason,

    no I did not receive e-mails this week, I did not receive them since new version came out :))

    today I tried to make manual backup but here is log.

    http://www.bildites.lv/images/w976dkixwl27zgquryj.jpg

    On Monday I'll try to set back previous version.. and let's see how it will work.

  11. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi zfed,

    Running the steps on my first response to change the gzip_tmp_dir should fix that error. Somehow it's reverted. Make sure you do tick the box when you change it too or it ignores it.

    As for the emails trying the previous version would be a good check but the email behaviour should be the same we haven't changed it. Let me know how it goes with previous version and we'll do more testing to see if we can find a cause for this.

    Jason

  12. zfed
    Member
    Posted 3 years ago #

    hi,

    yes, i fixed gzip_tmp_dir.
    but there is still e-mail issue. I even changed email address.

    also, there was some problems with previous version, I even couldn't make manual back up.

    I guess you are tired of my email issue :)

    strange, I changed my gmail email address to different service - ga at inbox.lv and I received email. something with gmail targets.. I tried all my 3 gmail accounts and no emails. I tried 2 times and @inbox.lv it's working. where is problem, how do you think?

  13. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi zfed,

    I'm wondering if the gmail target isn't accepting the attachment. Maybe it is looking at the ZIP file and not liking it and rejecting it. Maybe try database only and see if the email works? Quite possibly, you have an EXE file or something somewhere in your website, and this is being backed up to the ZIP file, and when gmail sees this ZIP file containing the EXE file it rejects the email - most likely gmail will refuse to receive EXE. Try encrypting the backup? gmail won't be able to read the file then and it would rule out this kind of thing.

    If its working with the @inbox.lb account though then it must be the plugin is sending the email OK (as the phpMailer is saying is sent OK) and it is just gmail refusing to receive.

    Can't really suggest anything else I'm afraid. But hopefully the above will help you. If anything, after encryption if gmail still won't receive, least you can receive to the inbox.lv account now!

    Jason.

  14. zfed
    Member
    Posted 3 years ago #

    no, due the size I'm doing only db backup.. files I'm backuping once a week and saving on my home PC.

  15. zfed
    Member
    Posted 3 years ago #

    yes, encrypting helped, thanks!!! I'm now receiving on gmali.com

    but i'm still have this on dashboadr:

    Warning: realpath() [function.realpath]: open_basedir restriction in effect. File(/usr/var/tmp) is not within the allowed path(s): (/home/ogsiste/domains/autoaudio.lv/public_html/:/usr/local/lib/php/:/home/tmp/) in /usr/home/ogsiste/domains/autoaudio.lv/public_html/wp/wp-content/plugins/wponlinebackup/wponlinebackup.php on line 907

    `

  16. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi zfed,

    Must have been something in the file gmail didn't like! Glad you got it sorted :)

    Just ignore that warning about realpath - it will be resolved in the next version, and won't affect the plugin as you've done the gzip_tmp_path override.

    Jason.

  17. zfed
    Member
    Posted 3 years ago #

    ok, thanks for support :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic