WordPress.org

Ready to get started?Download WordPress

Forums

One-Time Password
[resolved] No prompt for passcode (7 posts)

  1. Orakel78
    Member
    Posted 3 years ago #

    Plug in version: 2.23

    Hi.
    After one of the last updates there seems to be something wrong with the plugin / javascript.

    On my installation I don't get the prompt with the pass code ID any more.
    In the source I see the javascript but it doesn't seem to get executed.

    I've tested in Opera 11.5, IE 9 and 4.0.1

    Anyone else that has seen it ?

    It might have been broken for a while since I only use this login when traveling, so I haven't noticed until now.

    http://wordpress.org/extend/plugins/one-time-password/

  2. Marcel Bokhorst
    Member
    Plugin Author

    Posted 3 years ago #

    The last updates were mostly bugfixes, not something that could stop the plugin from working. My best guess is that another plugin is conflicting. So, try disabling other plugins to see if the problems goes away.

  3. Orakel78
    Member
    Posted 3 years ago #

    I've tried disabling the plugins that I saw might impact the login page but still nothing.

    I even see the javascript if I look at the source but it doesn't seem to be triggered properly.

    As I said I'm not exactly sure when it "broke" but I have had it working earlier.

  4. Orakel78
    Member
    Posted 3 years ago #

    Found the problem, seems if SexyBookmarks (by Shareaholic) breaks something.

  5. Orakel78
    Member
    Posted 3 years ago #

    Seems the One Time Password JavaScript code isn't executed when SexyBookmarks is installed. I guess both uses jQuery so the problem might be there ?

    I get no JavaScript errors but when I debug the page using Opera Firefly it doesn't seem the in line JavaScript used by One Time Password is not executed.

  6. Marcel Bokhorst
    Member
    Plugin Author

    Posted 3 years ago #

    OTP does enqueue jQuery as should be done. If SexyBookmarks does this too, it should work:

    wp_enqueue_script('jquery');

    Did you see jQuery loaded more than once while debugging?

  7. Orakel78
    Member
    Posted 3 years ago #

    Hmm seems to be loaded twice, and Sexybookmarks doesn't seem to use wp_enqueue_script('jquery');

    I'll toy bugging the Sexybookmarks people some more.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic