WordPress.org

Ready to get started?Download WordPress

Forums

OGraphr for WordPress
[resolved] [Plugin: OGraphr] So close but Blip embeds not working! Help! (6 posts)

  1. rickrey
    Member
    Posted 1 year ago #

    Hi yathosho,

    Fantastic plugin - thank you. I almost have it working but it appears the link generated from Blip embeds isn't working, though I can see the thumbnail w/play button icon when sharing the post URL on Facebook.

    See example here: http://blippery.com/demo1/episodes/vlog-126-online-dating/

    Enter that URL in the Facebook debugger:
    https://developers.facebook.com/tools/debug

    You'll see the og:video link looks a little funky:

    http://blip.tv/scripts/flash/stratos.swf?#file=http://blip.tv/rss/6151777&skin=rss&referrer=blippery.com&frontcolor=0x666666&lightcolor=0x000000&backcolor=0xE7E7E7&brandname=TheNetwork&brandlink=http://blippery.com/demo1

    Blip is suggesting a tag structure that would follow a format like this:
    <meta property="og:video" content="http://blip.tv/play/h818gvuDUwI?p=1">

    Or this, for the new Blip embedded player:
    <meta property="og:video" content="http://blip.tv/play/h818gvuDUwI.x?p=1">

    Any thoughts? Thanks in advance!!

    http://wordpress.org/extend/plugins/meta-ographr/

  2. idleberg
    Member
    Plugin Author

    Posted 1 year ago #

    thanks rickrey, will take a look once i get home on tuesday!

  3. idleberg
    Member
    Plugin Author

    Posted 1 year ago #

    ok, of course i couldn't resist but doing a quick test. this is the embed code i used.

    <iframe src="http://blip.tv/play/AYL3vUUC.html?p=1" width="480" height="300" frameborder="0" allowfullscreen></iframe><embed type="application/x-shockwave-flash" src="http://a.blip.tv/api.swf#AYL3vUUC" style="display:none"></embed>

    the plugin successfully retrieved the thumbnail-url for the video

    http://a.images.blip.tv/Sexynerdgirl-Vlog126OnlineDating930.jpg

    there's currently no support for og:video tags, but it sounds like something i might wanna add in future. will look into it on tuesday!

  4. rickrey
    Member
    Posted 1 year ago #

    Hi yathosho! Thanks so much for looking into this. Yes, it appears that the thumbnail is being pulled properly, which is great. Do you know if there's anything I can do on my side so the embed works on Facebook when the permalink URL is posted?

  5. idleberg
    Member
    Plugin Author

    Posted 1 year ago #

    i did some research and came across this

    Custom video player on Facebook (+working example)

    this seems to work and is easy to implement (to ographr as well), however i'm not sure if this will work with (all) video platforms. gonna play around with this for sure!

    also take note of these links:
    How to embed my own video player in Facebook?
    How to do a Facebook Video Embed Whitelist Request?

  6. idleberg
    Member
    Plugin Author

    Posted 1 year ago #

    just wanted to let you know, that ographr 0.8 supports playing videos directly on facebook (twitter is still a beta feature). doesn't work yet with all supported services, but i'm working on it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.