WordPress.org

Ready to get started?Download WordPress

Forums

Wiki
[resolved] Plugin not working for my site (13 posts)

  1. rafilathif
    Member
    Posted 7 months ago #

    hi there
    it's grade plugin for my education site
    i planing to buy this plugin. before buy this i test your demo plugin here but its not working for me.

    may be i made mistake but i hope i follow your instruction to create new wiki

    when i see my published wiki post it' ok view looking good but when i click
    page nothing happen
    Discussion there is a blank page
    History is coming without wiki tabs
    Edit is going above the header
    create new also same
    Advanced going to the editor dashboard

    i hope if you want to try the edit option you need an account my site
    just try the
    [redacted]
    visit here

    http://wordpress.org/plugins/wordpress-wiki-plugin/

  2. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @rafilathif,

    Thank you for your question.

    Don't share the site credentials on the forum as this is public forum and anybody can misuse the credentials.

    I checked your published wiki post

    when i click page nothing happen

    When you click on page tab nothing happens because by default it is active wiki tab.

    Discussion there is a blank page

    The discussion tab will only show if you enable comments on this specific wiki article. This utilizes the WordPress comments system to enable discussions so all those same rules apply here too.

    You will find more information about the wiki tabs on the following page.

    http://premium.wpmudev.org/project/wordpress-wiki/#usage

    History is coming without wiki tabs

    Yes history and some other tabs are coming without wiki tabs which is known issue in the current free Wiki plugin, it's not present in pro wiki plugin and it will be fixed in the next plugin release.

    In the meanwhile to fix it you can just edit the free Wiki plugin file

    wordpress-wiki-plugin/wordpress-wiki-plugin.php

    In the above file move code from line number 697 to 700 on line number 702

    Edit is going above the header
    create new also same
    Advanced going to the editor dashboard

    I think these are theme specific issue as it's working fine on my test site using default WordPress twenty twelve theme.

    Can you please just test it using default WordPress twenty twelve theme and without translating the theme?

    I will find out why it's conflicting with the theme you are using.

    Just want to make sure are you using the following theme?
    http://theme-fusion.com/avada/

    Best Regards,

  3. rafilathif
    Member
    Posted 7 months ago #

    Thank you for your replay

    yes. i'm using the avada theme i already inform to my theme provider.
    they said me to contact plugin provider.

    thanks for your advised also.if you have any private discussion board tel me i'll join become i love your wordpress work.

    cheer...

  4. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @rafilathif,

    Thank you for your reply.

    I will test the plugin using the Avada theme.

    In the meanwhile can you please just check whether the Avada theme is causing the problem and nothing else by using WordPress default theme Twenty Twelve?

    I want to know why do you need private discussion board?

    We have WPMU DEV Community for our paid members but it's not private.

    Kind Regards,

  5. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @rafilathif,

    Advanced going to the editor dashboard

    Clicking on the Advanced tab takes you directly to the admin area where you can edit the wiki inside your dashboard, this is a functionality of the wiki plugin and not an issue.

    Edit is going above the header
    create new also same

    I tested the Wiki plugin using Avada theme version 3.3 on WordPress 3.8 and it worked fine without any issue.

    Have you made any changes in the theme?

    There may be plugin conflict on your site which is causing this issue. You can check for the conflict by following the instructions provided in the flowchart on the below page.

    http://premium.wpmudev.org/manuals/getting-support/

    Regards,

  6. rafilathif
    Member
    Posted 7 months ago #

    thanks for your replay i also tested with Twenty Twelve and Twenty forty theme same problem i understood it's sure the some of the plugin is conflict i'll deactivate the plugin one by one and i'll tell you which plugin is that
    let me check

    thanks for your quick support..

  7. rafilathif
    Member
    Posted 7 months ago #

    hi wiki developers

    i found which plugin is conflict with wiki
    i'm using seo plugin my site. WordPress SEO this is the plugin developed by yoast.

    when i deactivate the WordPress SEO plugin wiki working fine after activate WordPress SEO again the problem persist

    the free plugin link : http://wordpress.org/plugins/wordpress-seo/installation/
    Developer site : http://yoast.com/wordpress/seo/#utm_source=wpadmin&utm_medium=plugin&utm_campaign=wpseoplugin

    Please give me a solution for this issue

    i have one more question
    is it possible to do my users can upload media file in to the post using wiki plugin?

  8. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @rafilathif,

    Thanks for the quality reply.

    i found which plugin is conflict with wiki
    i'm using seo plugin my site. WordPress SEO this is the plugin developed by yoast.

    Try adding the code posted on the following reply in functions.php file of your child theme.

    https://github.com/Yoast/wordpress-seo/issues/277#issuecomment-28511630

    is it possible to do my users can upload media file in to the post using wiki plugin?

    You can add media files to the wiki by clicking Advanced tab of the wiki. To allow other user roles than admin to upload media files use the solution provided on the following reply.

    http://premium.wpmudev.org/forums/topic/how-do-i-allow-wiki-contributors-to-upload-files#post-567525

    Please advise if you have more questions.

    Cheers,

  9. rafilathif
    Member
    Posted 7 months ago #

    Thanks cheers it's works for me. i have to give some restriction to my user. if any user want to publish any article users need to get a admin verification.

    also if i click advanced tab its going to the wordpress dashboard here i need to hide all meta boxes is there any way to hide this

  10. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @rafilathif,

    Thanks cheers it's works for me. i have to give some restriction to my user. if any user want to publish any article users need to get a admin verification.

    The following thread will best answer you.

    http://premium.wpmudev.org/forums/topic/admin-approval-of-user-submitted-wikis-possible

    also if i click advanced tab its going to the wordpress dashboard here i need to hide all meta boxes is there any way to hide this

    You hide the metaboxes using by adding following code in functions.php file of your child theme.

    // Change what's hidden by default
    add_filter('default_hidden_meta_boxes', 'hide_meta_lock', 10, 2);
    function hide_meta_lock($hidden, $screen) {
    
            if ( 'incsub_wiki' == $screen->post_type )
                    $hidden = array('postexcerpt','slugdiv','postcustom','trackbacksdiv', 'commentstatusdiv', 'commentsdiv', 'authordiv', 'revisionsdiv');
                    // removed 'postexcerpt',
            return $hidden;
    }

    And use the solution provided on the following page to remove screen options so that user can not enable it again.

    http://wordpress.stackexchange.com/questions/25034/how-to-remove-screen-options-and-help-links-in-the-admin-area

    Alternatively you can remove metaboxes using the solutions provided on the following page. Just use incsub_wiki in place post_type in the code.

    http://wordpress.stackexchange.com/questions/118888/remove-custom-metaboxes-from-custom-post-type

    Cheers,

  11. rafilathif
    Member
    Posted 7 months ago #

    mmm... add the code which you give me above. but it's not work. it's ok no problem

    basically i'm not happy to give any user to access my wordpress dashboard i just give the permission for testing propose the wiki. now i return to the restriction for entering the dashboard.

    i don't understand why the advanced tab going to the wordpress dashboard. what is the impotent thing to go to the dashboard.

    how can i upload media file using wiki

    i show the pro version price is mention $19/m. what is the meaning this
    do i have to pay every month $19

    best regards

  12. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @rafilathif,

    mmm... add the code which you give me above. but it's not work. it's ok no problem

    I have tested it on my test site and it worked fine but the meta boxes are not shown as long as user hadn't modified his preferences in screen options.

    If you want to hide it regardless of screen options settings then just change 'default_hidden_meta_boxes' filter name with 'hidden_meta_boxes' in the previous code.

    i don't understand why the advanced tab going to the wordpress dashboard. what is the impotent thing to go to the dashboard.

    It is developed such a way that it is redirecting admin to the dashboard for making major changes like adding media, changing publish date / status, attributes, other custom metaboxes values but it can be customized to do these all things from the front end which will require major custom coding.

    how can i upload media file using wiki

    It is already answered previously in the following reply.

    http://wordpress.org/support/topic/plugin-not-working-for-my-site?replies=9#post-5060854

    i show the pro version price is mention $19/m. what is the meaning this
    do i have to pay every month $19

    To use pro version of this plugin you have to only pay $19 once but to get support and updates for the plugin you have to pay $19 per month.

    You will find more information about it on the following page.

    https://premium.wpmudev.org/join/#faq

    Cheers,

  13. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 7 months ago #

    Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.