WordPress.org

Ready to get started?Download WordPress

Forums

Super Zoom Gallery
[resolved] Plugin not working correctly in IE8 & below (13 posts)

  1. vaibhavbthl
    Member
    Posted 1 year ago #

    Hello

    Thanks for making this awesome plugin. I have tried this plugin in almost all new browsers and its working fine in all of them except ie8 & below. Its working fine in ie9 & 10. Problem is that the zoomed image is automatically showing in ie8 without hover and it also doesn't go away when i remove cursor from main image. I think its some css issue. Following is a screenshot - http://www.images.rudragems.com/ie8%20screenshot.jpg
    In the above screenshot i haven't touched the image but it is showing zoomed image automatically. I need to make it work in ie8 because 30% of my traffic uses ie8 (don't know why people still use it).

    Regards
    Vaibhav

    http://wordpress.org/extend/plugins/super-zoom-gallery/

  2. Niels
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Vaibhavbthl,

    Thanks for the kind remarks, and thank you for using and testing Super Zoom Gallery,

    IE8 and lower is a bit of a problem I noticed it myself. So your support question made me look for a better solution then I now have. I also think it is a CSS problem.

    It is hard for me to test on a IE8 browser at this moment, so I was wondering if you could see if trying these classes solves the problem. If so, I'll put them in a new release immediately. They live at the bottom of the szg-style.css file of the plugin, if you put these lines of code beneath them they should be used.

    If you don't have the time to test it for me, don't worry, I'll try it myself somewhere next week.

    .szg-show {
      /* IE 8 */
      -ms-filter : "progid:DXImageTransform.Microsoft.Alpha(Opacity=100)";
      /* IE 5-7 */
      filter: alpha(opacity=100);
      /* Netscape */
      -moz-opacity: 1;
      /* Safari 1.x */
      -khtml-opacity: 1;
      /* Good browsers */
      opacity: 1;
    }
    
    .szg-hide {
      /* IE 8 */
      -ms-filter : "progid:DXImageTransform.Microsoft.Alpha(Opacity=0)";
      /* IE 5-7 */
      filter: alpha(opacity=0);
      /* Netscape */
      -moz-opacity: 0;
      /* Safari 1.x */
      -khtml-opacity: 0;
      /* Good browsers */
      opacity: 0;
    }
    
    .transparent_class {
       /* IE 8 */
      -ms-filter: "progid:DXImageTransform.Microsoft.Alpha(Opacity=50)";
      /* IE 5-7 */
      filter: alpha(opacity=50);
      /* Netscape */
      -moz-opacity: 0.5;
      /* Safari 1.x */
      -khtml-opacity: 0.5;
      /* Good browsers */
      opacity: 0.5;
    }

    Kind regards,

    Niels

  3. vaibhavbthl
    Member
    Posted 1 year ago #

    Hi Niels

    As instructed i pasted these classes at the bottom of szg-style.css but unfortunately i didn't worked in ie8. Still having the same problem. Zoomed image showing automatically and not going away. I created a live page on my website - http://www.rudragems.com/test-page/, i thought it might help you in checking. If you can again update css for this issue then i can again test it in ie8. Its the least i can do to Thank You for your time & effort in making this plugin.

    Regards
    Vaibhav

  4. Niels
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Vaibhav,

    Thanks for testing, to bad it doesn't work. I'll try testing it in IE8 and see what's wrong, maybe the javascript events don't fire or something.

    I'll let you know.

    Kind regards,

    Niels

  5. vaibhavbthl
    Member
    Posted 1 year ago #

    Hi Niels

    Thanks for your support. I badly need this plugin because it fulfills all my needs for a gallery plugin. Hope to get an update soon.

    Thanks & Regards
    Vaibhav

  6. Niels
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Vaibhav,

    Tested it in IE thanks to this little IE virtualbox here, which comes in handy!

    As I suspected, it was a javascript bug. IE8 doesn't seem to support console.log and thats why the window didn't dissapear.

    Well, I tested it with twenty ten in IE8 and it works fine. Hopefully it works on your clients site as well. I've checked it in, the changes are in the 0.5.7 version. Could take a couple of hours before you get an update message.

    Hope it works, good luck with your clients site!

    Kind regards,

    Niels

  7. vaibhavbthl
    Member
    Posted 1 year ago #

    Hi Niels

    Now its working fine in IE8 but it has stopped working in IE9 and Firefox 19.0.2. Images & thumbnails are showing correctly but zoom effect is not working. Following is a test link on my website - http://www.rudragems.com/test-page/
    Can you check whats causing this problem.

    Regards
    Vaibhav

  8. Niels
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Vaibhav,

    I hope this is some kind of weird caching issue as I am unable to reproduce it. I've tested your test-page with windows 7 and IE9 and with FF19.0.2 on mac.

    Here are two screenshots:
    IE9 on win7
    And:
    FF 19.0.2. on mac

    Hard to tell what is causing the problem, maybe clearing your cache helps, if it persists let me know and I'll look at some different browser/os combinations on your test page.

    Kind regards,

    Niels

  9. vaibhavbthl
    Member
    Posted 1 year ago #

    Hi Niels

    I cleared the browser cache and it worked perfectly. Thanks again for this awesome plugin.

    Regards
    Vaibhav

  10. vaibhavbthl
    Member
    Posted 1 year ago #

    Hi Niels

    Sorry for disturbing again but now i am having a weird problem. I am using style attribute to define two buttons on my page but when i hover over them they become non clickable. When i disable this plugin then they again start working correctly or when i remove my style attribute from the button code then also they work correctly. Following is the link to my page just try to click on the "Buy it Now" button - http://www.rudragems.com/1-mukhi-rudraksha-certified-collector-quality/
    I think there is some clash between the plugin css and my button css but i am not able to find what is causing this problem.
    Thanks for your precious time.

    Regards
    Vaibhav

  11. Niels
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Vaibhav,

    You are right, that has to do with the super zoom gallery. I tested some javascript changes to get this working and commited it to the repository. The 'zoombox' was preventing the selection of the buttons and the input field, because it would still be there just not visible. I now make it really dissapear when the mouse leaves the medium image.

    The 0.5.8 version resolves this problem!

    Thank you for your great testing efforts of the plugin, I believe we have made some good improvements thanks to you thorough testing and feedback!

    Kind regards,

    Niels

  12. vaibhavbthl
    Member
    Posted 1 year ago #

    Hi Niels

    I upgraded the plugin but that Partially resolved the problem. The button is still not clickable unless i hover the cursor to the image first. The button is clickable only after the zoomed image appears. To make sure that there is no problem with my browser i cleared all things like cookies, cache etc. You can see it on the previous link that i posted. Can you check this issue.

    Regards
    Vaibhav

  13. Niels
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Vaibhav,

    Last night I was thinking about this situation, I added a line of CSS to avoid this.

    It should work in 0.5.9

    Kind regards,

    Niels

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic