WordPress.org

Ready to get started?Download WordPress

Forums

Amazon SES DKIM Mailer
[resolved] Plugin Not Working After Upgrade to 1.4 (10 posts)

  1. benwills
    Member
    Posted 1 year ago #

    I saw the upgrade was just an upgrade to phpmailer and went ahead and installed the plugin upgrade.

    Where the plugin was definitely working before for 2+ weeks, I have not received emails since (when I should get at least two a day for backup reminders) the upgrade.

    Sending the test email through Chrome gives this error:

    The website encountered an error while retrieving http://fullfeminine.com/wp-admin/options-general.php?page=amazon-ses-and-dkim-mailer/configure-smtp.php. It may be down for maintenance or configured incorrectly.

    Thoughts?

    Ben

    http://wordpress.org/extend/plugins/amazon-ses-and-dkim-mailer/

  2. benwills
    Member
    Posted 1 year ago #

    Also, I am using the most recent WordPress version, 3.5.2.

  3. benwills
    Member
    Posted 1 year ago #

    Anyone have any ideas on this?

  4. Roger MacRae
    Member
    Plugin Author

    Posted 12 months ago #

    try uninstalling and reinstalling the plugin

  5. ianxharris
    Member
    Posted 12 months ago #

    Hi, I've just upgraded to the latest version and I'm getting the same issue. The error in Apache's error log is as follows

    PHP Fatal error: Call to undefined method PHPMailer::IsAmazonSES() in /var/www/ianxharris/wp-content/plugins/amazon-ses-and-dkim-mailer/configure-smtp.php on line 380, referer: http://ianxharris.co.uk/wp-admin/options-general.php?page=amazon-ses-and-dkim-mailer%2Fconfigure-smtp.php&settings-updated=true

    I've checked in the classes and these methods don't seem to be there.

    Any ideas anyone?

  6. scottylogan
    Member
    Posted 12 months ago #

    The IsAmazonSES function is missing from class.phpmailer.php in both 1.4 and 1.5. In 1.3, it's this:

    /**
       * Sets Mailer to send message using Amazon Simple Email Service(SES).
       * @return void
       */
      public function IsAmazonSES() {
        $this->Mailer = 'amazonses';
      }
  7. Roger MacRae
    Member
    Plugin Author

    Posted 12 months ago #

    sorry folks, this was an oversight. The issue is fixed now. Please update to version 1.6

  8. benwills
    Member
    Posted 12 months ago #

    Awesome. Thanks, Roger. Installed and it looks to be working now. Thanks a ton for this plugin!

    Do you have anywhere we can donate, etc?

    Ben

  9. ianxharris
    Member
    Posted 12 months ago #

    Cool, installed and working too. I'm getting a spurious error at the top when I use the test but all comment emails etc are working. If you want the error I'm seeing with the test it's as follows:

    An error was encountered while trying to send the test e-mail.
    
    AmazonSES Error: 0000013fee6883a7-76d88286-fe34-48c4-8574-fd767946be80-000000 e6166505-ef22-11e2-83b8-f1b458495c98

    Thanks again for the quick fix.
    Ian

  10. Roger MacRae
    Member
    Plugin Author

    Posted 12 months ago #

    yeah that error is not an error. I am trying to track down why it is showing as it doesn't happen every time

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.